Sign in with
Sign up | Sign in
Your question
Closed

Low FPS Issues in Bad Company 2

Last response: in Graphics & Displays
Share
October 11, 2010 5:04:04 AM

Hello all,

I just wanted to come here and post about a problem with my FPS while playing Bad Company 2. Basically the issue is that I have bought new graphics cards twice now and have got no improvement with performance what so ever. I am really confused by this.

When the game was first released, I was running (2x)1gb EVGA Geforce GTS 250's in SLI. My FPS would range mostly from 25-45fps with all game settings on High, no AA and AF, HBAO off, 1920x1080. I then bought a 1.28gb EVGA Geforce GTX 470 when they first released. Even with this my FPS remained at 25-45fps with the game exact settings. However, all other games were met with huge performance gains such as Crysis, Metro 2033, Modern Warfare 2, etc. I wasn't too worried though since drivers were still new so I figured I would give it some time. However a few drivers releases later and almost 6 months later my FPS hasn't improved. Now for the thing that really throws me off, I just picked up another 1.28gb EVGA Geforce GTX 470 to run SLI. With this addition, I saw huge improvements in Crysis, Metro 2033, and Modern Warfare 2 again so I was feeling good so I booted up Bad Company 2. I was met with bad results as I am still at 25-45fps with the same settings.

I am really at a loss here. It just seems weird that all my other games see huge improvements with my graphics card upgrades but my performance with Bad Company 2 remains the exact same. On a side note as well, I played the Medal of Honor Open Beta and mainly got 25-45fps in that game as well. It may of been a little bit higher but not by much. I know that they run on the same engine so I am assuming it has something to do with that. The thing of it is too is that I have friends that have worse systems than me that can run this game better. Looking at benchmarks and reviews online for the GTX 470's I am no where near the performance that I should be at as well. Here is my complete computer specs:


Operating System: Windows 7 Ultimate 64bit
Motherboard: MSI P7N SLI Platinum
Processor: Intel Core 2 Quad q9550
Memory: 8gb G.Skill DDR2 pc6400
Graphics Card: (2x)1.28gb EVGA Geforce GTX 470 in SLI
Sound Card: Creative Sound Blaster X-FI Titanium
Hard Drive: 80gb/(2x)500gb Western Digital IDE
Power Supply: Corsair 850watt HX850W


I have my processor OC'ed to 3.4ghz at 1600mhz FSB. I also have my graphics cards lightly OC'ed to 625/1250/1700. I am running the 258.96 drivers right now. I tried out the newest beta's but had some problems with them so I am using the last official drivers release until next official ones are released. All of my other drivers are up to date as well and all Windows Updates have been installed.

So I am asking all of you guys if can help me with my problem. If you have any info or suggestions please let me know. Thanks for your time!

SippyCupXIII
a c 189 U Graphics card
October 11, 2010 5:29:22 AM

It's like the game itself is the trouble...
Have you patch it or update it? If the other games are fine then your system is fine, the only main concern here is BC2. Try re-install it and patch it if there's any available patch...
Score
0

Best solution

a c 105 U Graphics card
October 11, 2010 5:44:54 AM

I've seen some games NOT get higher frame rates with "better" cards. But at the same time the minimum frame rates have increased as well as playability. Take that same video card and use it with a 6core Phenom or an i7 processor and your frame rates will jump.

I have almost the same setup as you described above and the game plays flawlessly for me. ( 1920x1200 ) One exception is this machine has a 5850 on it. Perhaps if you lower the physx settings a notch or two ?
Share
Related resources
a b U Graphics card
October 11, 2010 7:00:55 AM

A recent Tom's review to find the bottleneck in 20 games might be an interesting read for you:

http://www.tomshardware.com/reviews/game-performance-bottleneck,2737-7.html

Not sure, but it would seem to confirm you should be getting better frame rates. The only thing off-putting about your configuration is the (old/slow?) HDs. Is the 80GB drive your OS drive? If so, what's its status (usage, swap file, etc).

Other than that, was your Win7 install clean? No mobo swap after building the OS? Anything unusual about it. Reaching here.

The Q9550 isn't exactly chopped liver, here shown vs i5 750:

http://www.anandtech.com/bench/Product/50?vs=109
Score
0
October 21, 2010 9:01:51 AM

Hey all,

Thanks for all the replies, sorry I am just now getting back. Yeah, I was a little confused about my performance when I have friends that have worse rigs and their game ran equal or better than mine. I tried to reinstall but that had no effect as well as all the settings tweaks and what not. Funny enough since I have posted one of my friends bought my motherboard, cpu, and memory off me. So I have now upgraded to the following:


Operating System: Windows 7 Ultimate 64bit
Motherboard: Asus P6X58D-E
Processor: Intel Core i7 950
Memory: 6gb Corsair XMS3 PC3-12800
Graphics Card: (2x)1.28gb EVGA Geforce GTX 470 in SLI
Sound Card: Creative Sound Blaster X-FI Titanium
Hard Drive: 2tb Seagate Barracuda XT
Power Supply: Corsair 850watt HX850W


Everything is new besides the graphics cards, sound card and power supply. I had those when I made my first post on this issue. I now am getting 50-60fps (vsync enabled) with same settings as mentioned in previous post. That is without having my processor oc'ed yet and my memory is currently only running at 1066mhz instead of 1600mhz. So I am sure once I get that taken care of I will probably be at a constant 60fps for the most part. I have just never oc'ed a i7 system, I have done plently of the older core 2 series though. I could use a little insight on this if anyone can help. Thanks for your time!

SippyCupXIII
Score
0
October 28, 2010 12:50:26 AM

Best answer selected by SippyCupXIII.
Score
0
a c 271 U Graphics card
October 28, 2010 2:48:44 AM

This topic has been closed by Mousemonkey
Score
0
!