Sign in with
Sign up | Sign in
Your question

Asrock P67 Extreme 4 - Code 45/Dual Chan Probs

Last response: in Memory
Share
November 7, 2011 2:40:29 AM

Hello all - just purchased this board and some Gskill Ripsaw (2 sticks of 4GB each - F3-17000CL9D-8GBXM to be exact). Looking to get dual channel out of this - according to the manual of the board you have to have one stick in either A1 or B1 and the other stick in A2 or B2. Well when placed in the proper slots for dual channel I get a code 45 on the Dr Debug. Now, when I put them in A1/A2 system works fine boots up no problem. Went to the BIOS and noticed on the first screen that I am indeed running single channel memory mode. Timings are 9-11-10-28 and voltage is 1.65v according to the memory info and that is exactly what the BIOS reflects.

What is going on here? I see some people on the Newegg forums had some problems with this error code. Beyond RMA'ing the board not sure how to proceed. Anyone had this problem?
November 7, 2011 5:47:22 AM

Hi beefy,

I'm having the same problem except I can only use b1 and b2 to boot single channel memory but can't use a1 and a2 to boot dual. I have gskill ripjaws x f3-12800cl8d-8gbxm. I'm using a new asrock extreme4 gen3 mobo, how about you?

I'm going to stop by bestbuy tomorrow to buy some different ram sticks to test the mobo and see if it's a compatibility issue. Otherwise I'm going to rma the board back to newegg...sigh let me know if you have a fix!
m
0
l
November 7, 2011 12:00:16 PM

i had a problem recently where i could only use slot a2 and b2 on my motherboard and turned out heatsink retention bracket was loose, if you haave just built system you could try remounting cpu

i say this as think weight of my heatsink was unseating cpu enough to stop one channel working

m
0
l
Related resources
November 7, 2011 5:04:16 PM

thanks for the tip donkey! I'll definitely have to try that. I'm currently using a Cooler Master Hyper N520 cpu cooler and it does have a retention bracket. I'm pretty sure the bracket is on tightly though. I've taken it off and reseated the CPU a few times too but will check again when i get home.

I've even tried installing just the stock core i7 heatsink+fan (this doesn't use a retention bracket) and i still get error 45 if I put any two RAM sticks in A1 or A2. Putting in B1/B2 lets me post as single channel memory and I've been able to install Windows 7 and get my new build up and running (albeit at only 8GB of single channel memory :cry:  )

Seems like the board is unable to post using dual memory (A1/B1 or A2/B2). I'm in the process of RMAing the board through NewEgg. After reading a bunch of other forums it seems like ASROCK has had a bad batch of boards and the easiest thing to do is to replace it.
m
0
l
November 10, 2011 1:18:49 AM

beefy,

did you get it to work? I ended up RMAing (same board as you) back to NewEgg and should be getting the replacement back soon. I've been stalking multiple forums and so far i think the possible culprits could possibly be one of the following:

1) Defective Motherboard - The motherboard only recognizes single channel (Slots B1/B2), A-channel memory (slots A1/A2) isnt being read correctly. RMA would be the best course of action.

2) Defective Memory - I was at least able to verify my memory sticks were OK by using a combination of all 4 sticks in slot B1/B2 (slots furthest from CPU on the ASRock Extreme4 Gen3). They all work in B1/B2 but if any of them were put into A1/A2 I would get error code 45. I'm holding off on RMA-ing the memory until I get my mobo back from NewEgg.

3) Bent CPU Pins - I've read that not seating the CPU properly results in bent pins in the socket which can also mess up the memory channels. I tore apart my build multiple times and scoured the socket and board looking for bent pins...everything looked ok...Since I have a core i7-2600k there aren't any pins on the CPU but i did look at the socket. Everything seemed OK there (all the socket pins seem to be bent in a uniform fashion..this is normal right?) In my case, I was able to boot up, install windows, and run the comp for 8+ hours with only the 8gb RAM loaded in. I'm pretty sure if i had bent pins the computer wouldn't even function right? I doubt it's a CPU issue, but I'm also holding off on RMA-ing this until I get my mobo back.

Any other suggestions or tips from the community would be most welcome!

Someone PM'ed me and said I should have just RMA'ed the Mobo/CPU/Memory in the first place so I would have a fresh build all at once :o  ...silly me I didnt even think of this!
m
0
l
!