Sign in with
Sign up | Sign in
Your question

XFX Radeon 5750 Caushing Crashes

Last response: in Graphics & Displays
Share
October 11, 2010 10:39:05 PM

I build this setup about 8 months ago, and since I have had an increasing amount of system crashes. Most of them are BCC 124, various 'caused by' drivers.

Motherboard: ASUS M4A78T-E
Processor: AMD Phenom II X4 955 Black Edition Deneb 3.2GHz
Memory : 8GB (4x2G) Kingston HyperX DDR3 1600
Video Card: XFX Radeon HD 5750 1GB 128-bit DDR5 PCI Express 2.0 x16
NIC: PCI-Express Killer Xeno Pro Gaming Network Card
Power Supply: XCLIO STABLEPOWER 1000W

Running Windows 7 Home Premium 64bit

I've been doing a lot of troubleshooting, and I think I have narrowed my crashes down to my video card. Right now I am running off the on-board video adapter, and so far, NO CRASHES. It's only been about a day, but seeing as I WAS crashing multiple times a day, I think I found the problem.

Now, the question is, how to fix it. I've been reading lots of forum article, and it seems that this is a big issue for a number of people.

This article, Radeon 5750 Display Driver Stopped Responding, seems to describe the problem I am having, although not the exact same card. I've tried the solution (the work around) described, but no luck.

This article, XFX Radeon 5750 problem, also describes my problem, but offers no solution. Although it DOES allude to a possible fix about to be issued by ATI.


I guess my question is, Has anyone who has had this problem found a way to fix it? OR has anyone helped someone else fix it?

I appreciate you reading, thanks a lot for any help given.
a b U Graphics card
October 11, 2010 11:24:15 PM

are you using the drivers that came with the card if so it's time to update

update to 10.4 or better
m
0
l
October 11, 2010 11:29:24 PM

I just got the newest drivers off the XFX site, although the site says its ver 8.771.
m
0
l
Related resources
a c 130 U Graphics card
October 11, 2010 11:37:13 PM

Try downgrading to the newest driver before Catalyst 10.1.
m
0
l
October 12, 2010 12:55:09 AM

Quote:
Try downgrading to the newest driver before Catalyst 10.1.

Tried that, no luck. Could it be something to do with Adobe Flash Player? cause it seems to crash alot when I look at youtube videos. It's not isolated to that, but the majority of times it's youtube.
m
0
l
a c 130 U Graphics card
October 12, 2010 9:48:43 AM

Maybe Hardware Acceleration has something to do with it? Have you tried disabling that?

*Edit

http://www.overclockers.com/forums/showthread.php?t=628...

Just found this.
Quote:
1) Some people were reporting that disabling the ATI HDMI Audio driver was helping their 2D instability issues and so I went a step further and DISABLED the ATI HD AUDIO DEVICE in Device manager and I haven't had a 2D crash since. Now I notice you are using your HDMI socket but presumably not for sound, yes? If so you might try this yourself?

2) I installed Battlefield 2 on my machine and would hard crash with a Brrrr sound every single time after less than a minute. I noticed that full screen video was a problem for many users of my card and so ( despite knowing that video and 3D applications are completely different animals) I tried running the game in windowed mode and was able to set it up and play without issue. I then restarted and selected Fullscreen and have played for hours without issue. Might you try this with your games?

m
0
l
a c 107 U Graphics card
October 12, 2010 8:14:30 PM

The first thing I would do is go to Windows Update. then I would go to AMD's site and get new drivers. then uninstall the old ( card ) from my device manager and reboot. Reinstall new drivers. Trash the network card. Big waste of money and may be the culprit ? What are you powering your system with ? What are you using for sound ? If you're not using the ATI sound you can either do an advanced install and not install it or disable the on board sound in the BIOS. Or you can look in the control panel under sound and try fixing it there. Sound drivers may be the problem... ???
m
0
l
October 13, 2010 12:43:10 AM

shadow187 said:
Maybe Hardware Acceleration has something to do with it? Have you tried disabling that?



I never overclocked it before. I've tried solutions that involve overclocking it (apparently, some cards have some trouble idling). After I found out they didn't work, I turned it off.

shadow187 said:
Just found this.
1) Some people were reporting that disabling the ATI HDMI Audio driver was helping their 2D instability issues and so I went a step further and DISABLED the ATI HD AUDIO DEVICE in Device manager and I haven't had a 2D crash since. Now I notice you are using your HDMI socket but presumably not for sound, yes? If so you might try this yourself?


Tried this today, and sadly no help.
m
0
l
October 15, 2010 6:57:23 AM

[ SOLUTION ]


EUREKA! Today, I found THIS. And oh my, am I happy.

Adobe Flash Player ver 10.1 apparently affects your 2D clock speed. That, paired with the fact that my card is unstable at low speeds, explains my crashing.

SO, if you are looking for a FIX, un-install adobe flash player here. And then install 10.0. So far, no more crashing.

Oh, and if you are skeptical of my story, here's some proof.



*NOTE* Adobe Flash Player was released Jun. 11 2010. (I didn't get until the 26th, but you get the picture.)
m
0
l
!