Sign in with
Sign up | Sign in
Your question

PC Stuck on BIOS screen

Last response: in Motherboards
Share
November 7, 2011 2:49:50 PM

Hey,

Recently my computer has started to get stuck on the intial black BIOS screen when I try to switch it on. I hear it POST (I am able to get continuous beep's when I remove all the RAM as well) and all the fans spin up as normal but I'm not sure what has caused this as it worked the previous evening and shut down as normal, the next morning I am faced with this problem.

So far I have tried clearing the CMOS, re-seating everything as well as stripping it down and running it bare-bones. But nothing has helped so far and it gets stuck in the same place.

I have also tried swapping the PSU, RAM, CPU and Hard Drive for known working ones to try and eleminate faulty parts but the problem persists.

Any help would be greatly appreciated.

More about : stuck bios screen

a c 435 V Motherboard
November 7, 2011 3:18:38 PM

You should hear one single beep. If you get no video image, then your video card may be bad or the onboard video may have stopped working. I would swap the motherboard next. If you need a guarantee and the replacement is used, be sure to see the board running windows. Some boards will post but windows fails to load, indicating a bad capacitor or other issue.
m
0
l
November 7, 2011 3:38:34 PM

Thanks for the reply.

I am able to get hear a single beep as the computer starts. I am also able to get video from the motherboard using it's on-board graphics (although I am only able to see the BIOS splash screen asking me to press DEL for BIOS, F12 for Boot Menu etc as this is where it gets stuck). I am also unable to enter the BIOS or select anything on this screen.

I will try and swap the motherboard next this evening. I'm starting to think it's the motherboard thats the problem.
m
0
l
Related resources
December 15, 2011 3:58:02 PM

Hi CplBob,

I am having the exact same problem as you are. I hear the single beep when the computer starts, but then the motherboard BIOS screen comes up and does not go away. It doesnt let me enter BIOS either, just like it doesnt for you. The weird thing is that this happened once, and then went away after a few days. My computer was back to normal. Then, after another 3-4 days, the same thing happened again (BIOS screen stuck) in the same way. This keeps going on, like a cycle, for the past month.. I'm super confused. have you been able to resolve this?

thanks.
m
0
l
December 15, 2011 5:46:12 PM



Hi both of you,

as you can see I'm in Kenya. At the coast in fact... The worst climate ever for PCs, just believe me. Now here it is a common problem especially during rain season: The PC works fine this night. You shut it down, won't boot next morning. Lights are coming on, fans are running, but mostly not even a single beep and no POST screen.
Solution in at least 75% of all cases (well, at least here):

Take the RAM out. Use a clean white sheet of paper (80 g printer paper), fold it so that you can pull the contact row of the memory strip through it applying rather a lot of pressure to the contacts with your finger tips.

- make sure to only 'grind' the contacts. keep away from components on the modules, you might rip them off.
- check the paper. Probably you'll find some greenish/blackish stuff where it rubbed the contacts.
- repeat with a fresh clean spot on the paper edge until it remains white.

We are seeing copper-oxide that built up on the contact surfaces causing the problems. Since paper is actually not really as smooth as it seems to be (it's rather like very fine grinding paper), you sort of grind the oxid layer off the contacts. Chances are that the PC works after that procedure.

Remark - in my experience - once this has started, you shall have to repeat the cleaning every now and then depending pretty much on ambient conditions and climate.

IMPORTANT: Please take care to NEVER bend the RAM strips when you do the cleaning. Probably that will render them useless since the solder joints underneath the chips will crack.
m
0
l
June 23, 2012 10:25:09 PM

Hi, I am after buying a completely new machine, all parts brand new. I set it up and got it working after a few hours of work. However I am also getting this error where it either gets stuck at the bios screen and I cannot use my keyboard when its there. It also restarts continuous while at that screen. When it gets past that screen the only other problem is that windows updates don't seem to be installing correctly.
It seems to just do this randomly, I'll try starting it and it will not work. A few hours later ill try again and it will work perfectly. No idea what is causing it. :( 
If anyone knows why this may be happening I'd be grateful for any info on the matter.
Thanks.
m
0
l
!