Sign in with
Sign up | Sign in
Your question

Asus sabertooth p67 cpu led red

Last response: in Motherboards
Share
November 8, 2011 4:40:58 AM

Recently just install the ASUS Sabertooth P67 MOBO with a 2600K i7 processor.

Everything setup great, 520W PSU in my case.

Hit the power button... all fans turn on for about 2 seconds, CPU LED turns on then power goes out.

It will then cycle like this perpetually.

Bad CPU? Bad Socket?

Any Suggestions will help a lot!!

Thanks
a c 180 V Motherboard
a b Ĉ ASUS
a c 219 à CPUs
November 8, 2011 4:58:11 AM

I had an Asus Rampage 111 Extreme that did the same exact thing and I ended up having to RMA the board. If you just got it then it will be no problem if it's within the 30 days , just call up where you got it from and they will issue you a RMA number and the only thing is you will most likely have to pay for the shipping one way.
m
0
l
November 8, 2011 5:02:58 AM

Sounds good!
Thanks for the reply.

At this point I just wanna get it working....

I'll let you know how this turns out.

glad I'm not the only one... :( 
m
0
l
Related resources
November 22, 2011 2:49:29 AM

Just as a quick follow up...

I got the Motherboard RMA'ed from where I got it, but I still got the same error.

I guess that means its a bad CPU (maybe was since the beginning).

Otherwise I might try to play with the connections to see if its having a problem reading the fan?
In the manual is doesn't label the fan connections very well at all... but it is written on the correctly.

Unless anyone has any suggestions I probably will have to RMA the CPU through Intel...


Thanks
m
0
l
November 24, 2011 4:42:59 AM

If not posting, could actually be a memory issue. Have you tried the MEM OK button? my Asus AMD board did the same thing on first power up. After powering off, held button a few seconds until led starting flashing. As speed of flashing increases, the board is checking the memory. It will either get you booted (though possibly not at max mem speed) or tell you there's a problem. Mine wound up beeding it done twice, but now reads speed correctly and boots fine. Love that button!
m
0
l
!