Sign in with
Sign up | Sign in
Your question
Solved

SATA Drives showing up AS IDE in bios.

Last response: in Motherboards
Share
November 8, 2011 1:40:05 PM

I Just built a computer and have a GIGABYTE GA-Z68XP-UD3 and am running windows 7.

When I went into my BIOS I seen

Master0 (set as my SSD which has the OS on it)
Slave0 (my DVD drive)
Master1 (my storage drive)

Now why are they showing up as IDE when they are plugged into SATA ports.
I don't even think this motherboard has IDE ports.

Thanks
a c 212 V Motherboard
November 8, 2011 1:50:45 PM

Because you have them operating in IDE mode (vice AHCI or RAID). This can be changed in the BIOS. Really, you are fine as is.
m
0
l
November 8, 2011 1:56:38 PM

I recently tried to use AHCI but did not work.
What is the correct way of doing this?

I already have windows 7 installed and the I went in to the BIOS and changed the setting to AHCI it rebooted flashed a blue screen then came back to some message saying that there was a hardware or software change

what would I like to do

scan for a fix
start windows normally. (which if I recall did not work)

So I wnt back to the BIOS and changed it back, and is working again.

So what is the correct way to set this up?

I heard you are to do it prior to installing windows.


Thanks for the help.
m
0
l
Related resources
a c 216 V Motherboard
November 8, 2011 2:24:47 PM

You will need AHCI mode for proper operation of your SSD.

Windows 7 needs to pass the TRIM command to the SSD and to be able to do that properly requires AHCI mode. TRIM is required to maintain the SSD's performance. If TRIM isn't working your SSD's performance will drop over time and you will notice as it becomes slower.
m
0
l
a c 212 V Motherboard
November 8, 2011 2:26:36 PM

ko888 said:
You will need AHCI mode for proper operation of your SSD.

Windows 7 needs to pass the TRIM command to the SSD and to be able to do that properly requires AHCI mode. TRIM is required to maintain the SSD's performance. If TRIM isn't working your SSD's performance will drop over time and you will notice as it becomes slower.

This is true. That is why I would simply reinstall Win 7 (with the system configured for AHCI in the BIOS) and not mess with the "fix". You end up with a cleaner install and no goofiness in the registry.
m
0
l
November 8, 2011 2:29:02 PM

So should I go into the BIOS first select the AHCI then install windows?
or is there something I need to do during the windows install?
m
0
l

Best solution

a c 212 V Motherboard
November 8, 2011 2:32:42 PM

Jordan_22 said:
So should I go into the BIOS first select the AHCI then install windows?
or is there something I need to do during the windows install?

Yes, set in the BIOS before you install Win 7. No, once the install begins, you won't have to do anything. Win 7 will load the drivers properly to support AHCI.
Share
November 12, 2011 12:13:42 AM

Best answer selected by Jordan_22.
m
0
l
December 12, 2012 10:21:34 PM

There's no problem changing the msahci Start DWord value to 0 to enable AHCI SATA storage type in the registry. Many have done it successfully after a W7 install if they don't know to or forget to do it in the BIOS before hand.

The problem is, that does not necessarily enable your SSD as AHCI. The drive itself could still shown as IDE in the BIOS because the SATA 3 controller can also be set to AHCI or IDE.

This is the problem I'm currently facing. I set the SATA storage type to AHCI in the BIOS before the W7 install, but I was not aware until after the OS install that there was also a AHCI mode for my Marvell 9128 onboard SATA 3 controller. I also know of no way to change it in the registry.

On SATA 3 my SSD doesn't even show in the list of devices under AHCI Configuration in my BIOS, but on SATA 2 it does. In the storage boot order it's listed as [IDE: SO PLEXTOR PX] ether way though.

This makes it damn hard to determine whether it's actually running as AHCI or not.
m
0
l
!