Sign in with
Sign up | Sign in
Your question

5770 crossfire artifacting.

Last response: in Graphics & Displays
Share
October 13, 2010 8:58:36 PM

Ok, so here's my issue. I bought an XFX ati 5770 XXX series card, I asked XFX if the Juniper XT version would work in crossfire with it (i figured it would but just to make sure I asked them). Of course they said yes, the overclocked version will just downclock to match the gpu of the XT version. Anywho, I purchased this second card, put it in my machine and now I see artifacting in games. BAD artifacting that is, I then switched my cards around to see if it was the slots or even if it was because the wrong one was primary. No go nothing worked, XFX says it sounds like a mobo issue (which isn't the case) I called asus and they said it wasnt a mobo issue. Anywho the weird part is that, it only happens when the game is in focus. If I alt-tab out of the game and i'm able to see the game in a window unfocused it works flawlessly (but i cant play the game because its out of focus). I've ran myself up the wall troubleshooting and have no idea what it could be.
Note: I've tried drivers ranging from 10.6-10.9, app profiles 10.6-10.9, and Ive also tried overclocking the lower model to match the higher one (although I didn't expect it to work and xfx said it didnt matter)



My specs are as follows:

i7-930 2.8
P6X58D-E LGA 1366 INTEL X58 SATA 6G
Rosewill Xtreme Series RX950-S-B 950W
3x2gb G.Skill PC2000 1.6v DDR3
XFX 5770 XXX series
XFX 5770 Juniper XT
October 13, 2010 9:44:28 PM

1) try the new card alone in the machine... perhaps the card is defective from the moment you got it.
2) what temps are the vid cards at when your playing? are they overheating?

**I have never brough a vid card back after artifacts appear, this is just my experience but i bet that your new vid card is fried.
m
0
l
October 13, 2010 10:29:31 PM

I tried them both alone, doesnt seem like theres any issue. My temps are 56-84C (thats the max gpu-z has recorded, average is 74C)
m
0
l
Related resources
October 13, 2010 10:35:46 PM

I wanted to add another speculation. If I reboot my computer with my dual monitor set up I dont get artifacts, but If I disable the second monitor I do get artifacts.

Before anyone asks anything. I have been using driver sweeper before switching drivers.
m
0
l
October 14, 2010 12:33:51 AM

I think I actually got it fixed - I reinstalled the 10.9a hotfix drivers, then reinstalled the app profiles, and last but not least disabled catalyst AI (which ive done all this before but for some reason this time it worked) hopefully it continues to work.
m
0
l
!