Sign in with
Sign up | Sign in
Your question

Xfx 5850 works fine until i install a game

Last response: in Graphics & Displays
Share
October 14, 2010 6:57:07 AM

Hey guys,

First off here are my system specs...

AMD phenom 2 quad 955 black edition
MSI 790x g45 mobo
4gb OCZ3F1600LV4GK
XFX 5850
Corsair 650watt psu
WD 640gig caviar black
Samsung DVD burner
Sony 46inch 120hz TV
windows 7 64bit

Ive just completed my first build about 2 weeks ago and from the start ive had nothing but troubles. first thing i tried to do was set the memory speed to 1600, voltage to 1.65 and timings to the adverised 7-8-8 but it just wouldnt work so i left it on speed 1600, voltage 1.67 and auto timings of 9-11-11...
Anyways, I installed windows, and then downloaded and installed the ATI driver catalyst 10.9, the system rebooted and all seemed to be working well..

The first thing i noticed was weird was when i was watching a movie either on the internet, dvd or avi file etc it was extremely jerky, pretty much unwatchable. So i started playing around with the video settings and i noticed when i set it to 30hz interlaced it worked fine, which confuses me cause my tele is more than capable of 60hz...

Next thing i did, (which is p*ssing me off the most) i installed GTA4 ( a genuine bought copy ) everything installed fine and i actually got to play the game for a bit before i went to bed that night. I woke in the morning, turned on the computer and as soon as it got past the windows loading screen, there was just a screen full of green and black squares and also the computer locked up and i couldnt move the mouse or anything. I turned off the computer at the back, waited a minute, turned it back on and got the same screen... so next time i booted up into safe mode, ran driver sweeper, rebooted back into normal windows and reinstalled the ati 10.9 driver... I then rebooted and went to play GTA4 again but about 20 seconds into the game, the screen flickered a bit, then alot, then the game quit back to the desktop then showed a notice that the display driver has stopped working. i thought it was maybe the game so i tried also the dirt 2 demo, loaded it up fine, but a couple of seconds into the game it did the same flashy screen and then cut out back to the desktop displaying the same display driver has stopped working notice... i also tried doing a furmark stress test and it did the flashy screen a few times but didnt cut out of the program though.

After that i tried to reinstall windows, reinstall everything again, and still the games keep cutting out... everything else works fine, that is, general internet browsing, music, movies (except for the 60hz not working) i dont know what to do? Is it my video card? the ram not being able to be set to its exact timings? my motherboard is stuffed somehow???

Please help!!!
a b U Graphics card
October 14, 2010 7:11:54 AM

Clear CMOS, load "Safe Defaults", and save. Boot through, and see if the problems recur.
m
0
l
October 14, 2010 9:27:54 AM

Ive just given my rig to a mate of mine to check it out... i'll try resetting the cmos when i get it back. thanks
m
0
l
Related resources
October 14, 2010 4:55:49 PM

I should also add that the very first time i booted up my computer it didnt post, so i played around with the ram sticks, pulled them both out, put one in, didnt work, put the other one in, then it did work. tried them both in and then it worked, weird... Also ive run memtest twice overnight and have gotten no errors whatsoever, so i guess that counts out the ram as being stuffed
m
0
l
October 14, 2010 5:02:34 PM

Sounds like your Video Card may have some issues. Try running 3dmark vantage or another game and see if it works. It sounds like the card is defective.
m
0
l
a b U Graphics card
October 14, 2010 7:06:47 PM

Your experience with memory may indicate you didn't insert the sticks properly. Memtest isn't a bad approach, but frankly more memory issues are often detected by running Prime95 for a couple of hours with "Detect Rounding Errors" checked. That also allows you to check for heat.

While the problem does feel more like a graphics card issue at this point, its important to get hidden build issues out of the way first if we can.
m
0
l
a b U Graphics card
October 14, 2010 7:23:42 PM

Since your having issues with booting you can try using a tool called "Ultimate boot CD" This has some memory test tools along with burn in programs. Try this to see if memory really is your issue or if you need to look into other possible reason for the problem.

Link: http://www.ultimatebootcd.com/
m
0
l
!