Computer not going past BIOS Splash Screen...

I just bought a used ASRock 4Core1600P35-WiFi+ motherboard from PCDirect. Supposedly it was a functional motherboard. I hooked up all my components (correctly as far as I know) and set all the jumpers right. When I turned the computer on, it loaded up until the splash screen where it says "Press F2 for setup, F11 for Boot menu, etc... And then nothing. I press all those buttons and no response, it just sets there. I've tried a wireless USB keyboard and a wired PS/2 keyboard to make sure input was going through. At the splash screen, with the PS/2 keyboard, I can't turn Caps or Num Lock on or off and the [F]mode indicator light (between caps and num lock) just stays ON like the keyboard is locked up. Also, while the computer is off the [F]mode button just stays on. I've reseated everything and tried with and without HD and CD Drive and all my ram in all the different slots.

The components I'm actually using are:
-Intel Core 2 Duo 3.16GHz, 1333FSB CPU
-2xG.Skill DDR2 1066 PC2-8500 1GB RAM
-nVidia GEForce 8500GT video card
-450W PSU

I know that some of these components aren't on ASRock's Qualified Vendor's List, but pretty much the only brand ON their QVL is Intel stuff, so I'm assuming its not the brands causing this. Any help is greatly appreciated and I need to get my computer running soon to do homework. Thanks for any help.
2 answers Last reply
More about computer past bios splash screen
  1. What were the jumpers for...hard drives?
  2. No, they were FSB jumpers. I read the mobo's manual and it said to set them a certain way if I had a 1333FSB CPU and DDR2 1066 memory and thats exactly what I have.
Ask a new question

Read More

Chipsets Computer Splash Screen Motherboards