Sign in with
Sign up | Sign in
Your question

HD 5850 So many errors...

Last response: in Graphics & Displays
Share
October 15, 2010 11:56:12 PM

I got an XFX Radeon HD 5850...
Where to start, I plugged it in, all the parts were there, and it fit in, but the Small part of the PCI-e x16 didn't click in like other cards normally do, I assume, whatever, it's a big card, maybe it's me?(Still don't know) But I plugged all my stuff it, booted my computer, and I heard the fan whir up, so it was getting power, no screen. Naturally, I flipped out because I've had so many issues with graphics cards lately, then I started thinking straight, so I contacted XFX, they told me to replace the faceplate because I cut the tabs off(Didn't work so it doesn't matter, I'm an idiot sometimes I know) they keep blaming my MoBo not being 2.1 compatible, I have the Asus M3A78-EM ((http://usa.asus.com/product.aspx?P_ID=5pvgDAXJUV2orYzn)) It's Pci 2.0, I was told to update my Bios, I would have, but there's yet ANOTHER snag I've run into, Asus doesn't want me or any of my friends to be able to download the Bios utility, I can download the Bios file, but not the utility to install it (I believe I need to do that?) So I requested an RMA from XFX and got it, but I'd like to update my Bios before I even send it in, so I don't have to waste shipping charges if I don't have to. Any ideas fellows?

More about : 5850 errors

October 15, 2010 11:58:54 PM

Its not a PCI-E x16 card.......
m
0
l
Related resources
October 16, 2010 12:04:30 AM

http://www.tomshardware.com/forum/281255-33-motherboard...

"Yea youll be fine, according to wikipedia, 2.1 just has some of the features that are going to be implaced in version 3.0, 2.1 still has the same bandwidth rates. In other words, its basically just a marketing thing"

Are you sure? Cause there aren't any 2.1 motherboards out yet, so I doubt that's true.
m
0
l
a c 273 U Graphics card
October 16, 2010 12:05:45 AM

Randomacts said:
I stand corrected, but if you have a 2.0 motherboard a or anything but 2.1 an 2.1 will not work.. Unlike with other generations 2.1 seems to not be backwards compatible.

It is, just that some people have problems and some don't.
m
0
l
October 16, 2010 12:10:52 AM

Timendo said:
http://www.tomshardware.com/forum/281255-33-motherboard...

"Yea youll be fine, according to wikipedia, 2.1 just has some of the features that are going to be implaced in version 3.0, 2.1 still has the same bandwidth rates. In other words, its basically just a marketing thing"

Are you sure? Cause there aren't any 2.1 motherboards out yet, so I doubt that's true.

oh it is?

I've just seen about 5 threads per a day with your same problem, all of them have one thing in common: The card is a PCI Express 2.1....


Mousemonkey said:
It is, just that some people have problems and some don't.



This Lots of people have problems with PCI 2.1 it seems =p It can't be a fluke with 5+ threads on it a day.
m
0
l
October 16, 2010 12:15:59 AM

Maybe there's some reason, I doubt they'd put a card out at 2.1 if 2.0 boards can't support it, and am I right about NO 2.1 boards?
m
0
l
October 16, 2010 12:17:08 AM

Mousemonkey said:
It is, just that some people have problems and some don't.


Timendo said:
Maybe there's some reason, I doubt they'd put a card out at 2.1 if 2.0 boards can't support it, and am I right about NO 2.1 boards?



Dunno but there seems to another trend with post in this section.

Most of the "Omg I need help" threads are for ATI cards. :lol: 
m
0
l
a c 273 U Graphics card
October 16, 2010 12:19:54 AM

Randomacts said:
oh it is?

I've just seen about 5 threads per a day with your same problem, all of them have one thing in common: The card is a PCI Express 2.1....





This Lots of people have problems with PCI 2.1 it seems =p It can't be a fluke with 5+ threads on it a day.

I think it says more about ATi's lack of compatibility than the standard though as the problems are all with ATi cards and PCIe 2.0 cards are backwards with PCIe 1.0, the same lack of compatibility is found with DP adapters.
m
0
l
October 16, 2010 12:20:06 AM

There's still some NVidia's. and most of the ATI are XFX apparently
m
0
l
October 16, 2010 12:20:41 AM

Mousemonkey said:
I think it says more about ATi's lack of compatibility than the standard though as the problems are all with ATi cards and PCIe 2.0 cards are backwards with PCIe 1.0, the same lack of compatibility is found with DP adapters.


Just buy nivida

nuff said.


:bounce: 
m
0
l
October 16, 2010 12:22:37 AM

Or...we can help find out why my ATI card that I CAN'T RETURN won't work?
m
0
l
October 16, 2010 12:32:38 AM

Timendo said:
Or...we can help find out why my ATI card that I CAN'T RETURN won't work?

Why can't you return it?



And I'm afraid there is a good chance that it is the buggy ati pci 2.1. :( 
m
0
l
October 16, 2010 12:35:20 AM

Dude, as long as it's not MY fault, I'm friggin' happy rofl. and I can't return it cause I bought it off Newegg and it's been outta return for quite a while, and the pci 2.1 error, should be fixed when they replace it right?
m
0
l
October 16, 2010 12:49:08 AM

Timendo said:
Dude, as long as it's not MY fault, I'm friggin' happy rofl. and I can't return it cause I bought it off Newegg and it's been outta return for quite a while, and the pci 2.1 error, should be fixed when they replace it right?

You could return it for money ask nicely in livechat or phone for them to wave the restock fee and buy a different card


And its not your fault =P

For what you spent you can get a GTX 470 with the return money.

Unless you voided your RMA but doing something stupid...

Also please list your PSU so I can say y/n on if it will work before you get the GTX 470 as it is more power hungry then ati cards. :) 
m
0
l
October 16, 2010 12:57:13 AM

Not getting 470, had it, MAAAAAD heat issues, I'll get a 460, and save it for a new mobo so I can SLI it. and PSU.
Xion 580W
So offkey I know O_O
m
0
l
October 16, 2010 1:01:59 AM

Timendo said:
Not getting 470, had it, MAAAAAD heat issues, I'll get a 460, and save it for a new mobo so I can SLI it. and PSU....Ill edit it, hold on



Oh ya... the GTX 470 is a monster you need good airflow for it.

But I have a gtx 460 and it runs fine with just 1 fan in the back *stupid dell prebuilts...* Just don't overclock it if you have bad airflow..

Hell I don't even see a reason to overclock GTX 460 yet.

:) 
m
0
l
October 16, 2010 1:08:40 AM

Any ideas on the mobo Bios update ***? Still haven't got that figured out
m
0
l
a b U Graphics card
October 16, 2010 1:17:34 AM

Have you read your motherboard manual ?
Modern bios's usually have a spot in the bios menu to select.
You point towards a usb stick formatted with fat32 that contains your bios, and it can read and upgrade.
Thats how this generation of gigabyte boards can update, along with a windows based flasher.
m
0
l
October 16, 2010 1:19:06 AM

well...I havent read the manual, but the site says there's Bios utilities, and the one file in there is the installer, which I assume is the Bios update installer? Dude, Im a noob to Bios and I dont WANNA mess with that, Im afraid to do ANYTHING to that lol
http://usa.asus.com/product.aspx?P_ID=5pvgDAXJUV2orYzn
That's my Mobo's site for ease of access lol
m
0
l
October 16, 2010 1:31:36 AM

Rofl, I just realized I'm a tard. I didnt get the Card to work, but may have a factor. I never installed my Mobo's drivers from the disk, I just recently killdisk'd my drive and recovered from it, but the problem is, I JUST inserted it...Windows 7 isn't supported by this disk ;_;
m
0
l
October 16, 2010 1:35:17 AM

Timendo said:
Rofl, I just realized I'm a tard. I didnt get the Card to work, but may have a factor. I never installed my Mobo's drivers from the disk, I just recently killdisk'd my drive and recovered from it, but the problem is, I JUST inserted it...Windows 7 isn't supported by this disk ;_;

You mean the graphic card driveres?

Try to install your mobos newest drivers from the maker's website
m
0
l
October 16, 2010 1:38:41 AM

Not my gpu drivers, my mobo's. I can't install gpu drivers for no gpu :p 
And I just checked the site, no drivers. But the CD and board are Pre-Windows 7 sso...I mean, it's sort of an old board, I might as well just upgrade my board if I get the Video Card back the same? Like, if the card came backe and they're like, there's nothing wrong with it, what do. Upgrade Board?
m
0
l
October 16, 2010 1:43:22 AM

Timendo said:
Not my gpu drivers, my mobo's. I can't install gpu drivers for no gpu :p 
And I just checked the site, no drivers. But the CD and board are Pre-Windows 7 sso...I mean, it's sort of an old board, I might as well just upgrade my board if I get the Video Card back the same? Like, if the card came backe and they're like, there's nothing wrong with it, what do. Upgrade Board?



You are going past what I know...

But not past what people here know..
*Plays elevator music*
http://www.youtube.com/watch?v=SbIaYZEUF1M
Please hold.
m
0
l
October 16, 2010 5:48:52 AM



I know its bad to suggest making a new thread..


But often people look at a thread see post and just assume the problem is solved. :( 

m
0
l
!