Sign in with
Sign up | Sign in
Your question

ASRock Extreme4 code 45 - Memory

Last response: in Memory
Share
November 14, 2011 8:20:00 PM

So here are my previous topics :
http://www.tomshardware.com/forum/299856-30-computer-bo...
http://www.tomshardware.com/forum/318311-28-dead

Specs :
i5 2500K
ASRock Extreme4
GTX560 Ti
2x4GB Ripjaw X DDR3 1600
Corsair HX620W

Short version :
My computer turned off one night. I could not boot it back up and it would just give me a split second flash of power. After posting and troubleshooting it seemed like it might be the PSU. I got a new PSU (Corsair GS700) and the computer turned on but would not boot. The motherboard showed a code of 00. (later when I plugged my old PSU back in it did the same thing so my PSU was not the problem to begin with).

So figuring with the troubleshooting done and my previous issue with the motherboard (the primary PCIE slot did not work, gave a d6 error no matter what card was put into it, the bottom slot worked fine) I RMA'd my motherboard. Got the new motherboard and it did the same thing (code 00 and no boot).

That narrowed it down to RAM or CPU. I tried testing one RAM stick before and still no dice so I figured it was the CPU. Went out today and got a new i5 2500K. The computer now booted, but the code showed 45 and it would not post. I looked through everything I found and most posts seemed to indicate a memory error.

Again I tried one stick at a time and it showed a code 45 when either stick was in slot A1 (blue) or A2 (white). If one or both sticks were in slots B1(blue) or B2(white), the computer boots and works fine. The only problem is, I can't run dual channel unless the ram is in the same color slots. Found some posts and they stated to try reseating the CPU. Did that and still the same problem.

I checked my MB for any bent pins but did not see any (somewhat hard to see). If the RAM is in slot A1 or A2, the MB will show code 45 and not boot. If I have the ram in slots B1 or B2 or both, it will boot but only works in single channel.

Anything I could be missing? ASRock states they tested the MB before sending it so I doubt they would overlook something like this...but I have no idea what could be causing the issue now.
March 8, 2012 7:00:49 PM

Hi there,

I am having the exact same problem with my ASRock Extreme4. Same thing happened to me: let the computer open for a night, then the next day screen was all black and I could not boot again. Dr.Debug gave code 45. I RMA'd my motherboard like you did, thinking the problem was with the slots of memory (slots 3 and 4 (or B1blue and B2white) are not working for me). Whenever I put RAM in any of these 2 slots it won't boot and stop at error 45.

I am wondering if you found a solution...

Here are my specs:

CPU - i7 2600k
MOBO - ASRock Extreme4
Graphics - MSI - Radeon R6950 Twin frozr III
RAM - Had 4x4Gb Corsair Vengeance CMZ16GX3M4A1600C9, currently using only 2x4Gb of these, not using dual channel
PSU - FSP Aurum gold 700


My guess is that Corsair have some issues with compatibility on this motherboard, what do you think?

Thanks for any help...!
m
0
l
March 8, 2012 7:14:57 PM

oh and I never overclocked nor did I touch any BIOS settings... I know my specs suggest it but I'm kinda new to this so I'm taking things slow :) 
m
0
l
March 8, 2012 11:48:22 PM

After the RMA my motherboard worked fine. So it was the motherboard for whatever reason since they had tested it. They did state that when they received it all of the slots worked for them.
So I'm truthfully not sure if it was a combo of what RAM I had and something in the motherboard or what. But the new one they sent me works fine.

I had two different sets of RAM that I tested and both did the same thing. I would try testing the RAM in another computer. When I tried it both my G.Skill Ripjaw X and my Corsair Vengeance gave the same error so not sure if it is Corsair at all.
m
0
l
!