Sign in with
Sign up | Sign in
Your question

What is limiting my framerate?

Last response: in Systems
Share
December 14, 2010 3:19:17 AM

No matter what new game i play, i get around 10-20 fps. The only games that don't cause me issues are verrry classic ones. Not only that but games that should run better run worse. For instance, i played aion and got 20-30 fps with high settings full resolution immediately after playing wow and getting 10-15 on medium settings. Also it seems that no matter how i tweak the graphics in games, it doesn't affect my frame rate.

My components are:

Gforce 9800GTX 1GB
AMD Phenom 2.8
6GB Ram
750watt OCZ
6 fans for cooling

Before you ask, I keep my hardrive clean and run system mechanic frequently. Also, when playing games I never turn Vsync on. And yes my drivers are up to date.
Please help.

More about : limiting framerate

December 14, 2010 4:07:26 AM

I can sure as heck tell you it isn't a bottleneck. Although your card isn't the most powerful card in the world, it should be doing a LOT better then it is. Fix the issue before attempting to throw money at it.

Despite your up-to-date drivers, I would bet this is a driver issue. Download and run driver sweeper to clean out all your video card drivers and reinstall the newest version.

Have you ever had high framerates in said games, or has your computer always been slow by the way?
m
0
l
December 14, 2010 4:43:21 AM

Is the issue on all games or only online games?
m
0
l
Related resources
December 14, 2010 4:58:12 AM

My speeds always been this slow... also i just swept/ installed the new drivers booted up World of Tank which was giving me 19 fps hasn't helped, its now slightly worse because i have the firefox window up.
m
0
l
December 14, 2010 5:13:23 AM

could it have anything to do with the fact that i use a hdmi to vga converter to display on my lcd moniter?
m
0
l
December 14, 2010 6:37:12 PM

I also play WoT beta. How do you connect to the internet. Are you using a router? What monitor are you using? Are you saying that you are driving the vga port on the monitor from the hdmi port on the vid card? Are you using a vga or hdmi connecting cable?
m
0
l
December 14, 2010 6:57:29 PM

I've got time warner broadband.
i'm using a Mag Innovision 24 inch moniter.
ya I'm using the hdmi to vga adapter that came with it plugging that into my card and running a vga cable to the vga port on my moniter.
m
0
l
a b B Homebuilt system
December 14, 2010 7:04:20 PM

Certainly seems your system is capable of doing better. You didn't mention your HDD.... Hopefully not an old IDE drive!

Wouldn't think the converter for the video would do that!

Some screen shots from within CPUZ would tell us a lot. Can you download and capture (CPU, Memory and GPU tabs)?

As deltadevil suggested... Do a driver clean and install again for good measure. Also, ensure you have the MB / chipset drivers installed.
m
0
l
December 14, 2010 7:05:27 PM

It really sounds to me like that you have a faulty card, can you list some specific games and tell us what fps you are getting? and also what resoluion are you gaming at? have to tried lowering thr resolution and game settings to improve your frame rate?
m
0
l
December 14, 2010 7:53:52 PM

Well its funny right now i'm playing eve and i aways get an amazing frame rate in it... I have it on all the highest setting, with 16xq anti aliasing and i have a somewhat solid 60fps, somewhat being that every so often the framerate will drop for a split second. In counter strike source i also get a rough 35... but games like Dragon Age I get between 10-20 the whole time.
m
0
l
December 14, 2010 8:37:05 PM

nah thats not my moniter, but mine does have input for dvi, i use that... would it help much?
m
0
l
December 14, 2010 8:58:12 PM

try it. I get 80+ frames in WoT with most all at max.
m
0
l
a b B Homebuilt system
December 14, 2010 9:06:41 PM

Go into the nvidia control panel and turn physx off.
m
0
l
December 14, 2010 9:16:01 PM

I already have physx off, i only have one card
m
0
l
a b B Homebuilt system
December 14, 2010 9:27:44 PM

Only having one card doesn't mean physx is off. You have to manually deselect it in the nvidia control pane.
m
0
l
December 14, 2010 9:33:26 PM

try turning V SYNC off :p 
m
0
l
December 14, 2010 9:45:08 PM

ya, but i've turned it off already cause some of my games (mirror's edge) won't boot with it on. Also i never enable Vsync, i just turned it on all the way on Eve online because all of the other setting were all the way up and i got amazing fps, i turned it all the way up and its still at 60
m
0
l
December 14, 2010 11:40:54 PM

What resolution do you run on your monitor?
m
0
l
December 14, 2010 11:46:30 PM

Check your cpu/gpu max temps, use occt, etc and make sure they are ok.
m
0
l
!