Sign in with
Sign up | Sign in
Your question

Trouble getting my M4A87TD/USB3 to run DVD drive

Last response: in Motherboards
Share
November 15, 2011 10:02:10 PM

Just rebuilt from blown MB. Got new proc & MB. DVD drive shows up in bios, but will not read disc from boot or in Win7/64. Bios config. issue? Something overlooked? Was sure it was working before. PATA dvd connected to IDE-2SATA HDD's connected to ports 1 and 2.
a b V Motherboard
November 15, 2011 11:59:59 PM

Are the jumpers configured for master or single and on the end of the IDE cable ? not the middle connector of the cable.
Marked or colored edge of IDE cable to #1pin on dvd and motherboard?
m
0
l
Related resources
November 16, 2011 1:20:12 AM

Not registry, will not work in non Win environment. Believe jumper set to either master or cable select-moved from slave when prob. started. IDE cable, besides having colored edge, is keyed at least 2 ways, could never understand how you could connect wrong. Maybe the thing is just dead. Maybe I'll go through trouble, slap it in another pc to check it.
m
0
l
a b V Motherboard
November 16, 2011 3:19:22 AM

What kind of mobo & CPU was the original and what is the new one? It sounds to me like you replaced the mobo and cpu and tried to boot up without reinstalling windows. That's usually a bad idea because the new mobo requires different drivers unless it is the exact same board.

What type of interface are you using to connect the DVD drive and HDD, SATA or IDE? If it's IDE you may need to set the DVD drive as the slave device on the IDE interface to get it to work properly.

Also, since you can see the DVD drive in BIOS, did you check the boot order. Set the DVD drive as the 1st boot device and the HDD that you want to install windows onto as the 2nd boot device. Disable any other devices listed in the boot order (especially USB based drives and external drives).
m
0
l
November 16, 2011 4:03:36 AM

Again, thanks for your support, but did you read what I said? I know all about boot orders, etc. And the thing will not read from boot. What I'm not sure about are things like, do I need to configure the drive type. I know that with this mobo, they tell you to use a SATA optical drive on SATA 5 or 6, then set 5&6 to IDE in BIOS. Why IDE for a SATA? Ask Asus (in the manual). I thought perhaps I was missing something. Had to install Windows from a USB drive. Like I said, maybe the DVD just puked? Was hoping it was something new I wasn't aware of.
m
0
l
November 16, 2011 9:19:19 PM

JohnyGt said:
Just rebuilt from blown MB. Got new proc & MB. DVD drive shows up in bios, but will not read disc from boot or in Win7/64. Bios config. issue? Something overlooked? Was sure it was working before. PATA dvd connected to IDE-2SATA HDD's connected to ports 1 and 2.

Let me try different wording. Will not read from DVD on start-up, regardless of boot priorities, even if both HDD's are physically disconected, and the only thing enabled in bios boot priority is DVD. Again, it finds the drive in bios, names it correctly, and promptly pukes. Thinking maybe it is an internal drive problem. Have tried multiple discs with same results-thing keeps telling me to insert a disc that's already in the drive.
m
0
l
November 17, 2011 5:51:29 PM

Ok. turns out that in Win7 reads some cd's, but not dvd's. in Device manager it shows up with the right name, but under details tab (again, in Device Mgr) shows up as cd-rom. I thought in Win 7 it would show as dvd.
m
0
l
March 13, 2012 10:12:49 AM

JohnyGt said:
Let me try different wording. Will not read from DVD on start-up, regardless of boot priorities, even if both HDD's are physically disconected, and the only thing enabled in bios boot priority is DVD. Again, it finds the drive in bios, names it correctly, and promptly pukes. Thinking maybe it is an internal drive problem. Have tried multiple discs with same results-thing keeps telling me to insert a disc that's already in the drive.

I have same problem with this MB, and it drives me crazy.... :fou:  :fou:  :fou:  Cant find solution... :\
m
0
l
April 5, 2012 12:00:27 AM

JohnyGt said:
Just rebuilt from blown MB. Got new proc & MB. DVD drive shows up in bios, but will not read disc from boot or in Win7/64. Bios config. issue? Something overlooked? Was sure it was working before. PATA dvd connected to IDE-2SATA HDD's connected to ports 1 and 2.

Okay, so it seems to work only for reading CD's through Win7, even though it recognizes that it's a DVD/RW. From bios, it's reported to be there, but won't read anything. Meanwhile, the ASUS disc won't work with other known good DVD/RW's, so beleive disc to be junk. Asus will be happy to issue RMA, but not to just send another disc. Think I got most of what I wanted from it through Asus.com
m
0
l
!