Sign in with
Sign up | Sign in
Your question
Closed

How do you disable the onboard graphics on an m4a89gtd mobo?

Last response: in Graphics & Displays
Share
October 19, 2010 10:46:47 PM

I already have the graphics card installed and the vga switch card on the secondary slot. I know you can disable it on the bios but when i'm in the igp controller i have no clue how to. Can anyone explain it to me please I'm dying to play some games
a b U Graphics card
October 19, 2010 11:33:42 PM

A discrete graphics card will overwrite the igp, so no need to bother with the bios.

I'm guessing you've made the age old mistake of forgetting to connect your monitor cable to the actual CARD though, not the igp slot on your mobo. ;) 
Score
0
October 19, 2010 11:40:28 PM

eyefinity said:
A discrete graphics card will overwrite the igp, so no need to bother with the bios.

I'm guessing you've made the age old mistake of forgetting to connect your monitor cable to the actual CARD though, not the igp slot on your mobo. ;) 


so do i have to connect my vga cable to my gpu then? because i was using the hdmi cable :p 
Score
0
Related resources
a b U Graphics card
October 19, 2010 11:41:49 PM

Does your gpu not have an HDMI connection? If not, use the vga and you're ready to go.
Score
0
October 20, 2010 12:08:35 AM

eyefinity said:
Does your gpu not have an HDMI connection? If not, use the vga and you're ready to go.

it doesn't show any picture. I would use my vga or hdmi it wouldn't show any picture. My monitor would just go to power saving mode
Score
0
a b U Graphics card
October 20, 2010 12:14:40 AM

Take the graphics card out and go back to what you had before, the HDMI running off the igp.

I assume that was working ok yes?

If you can get it back to this then we can continue and get it fixed.
Score
0
a c 271 U Graphics card
October 20, 2010 12:21:03 AM

In your BIOS there may be a setting under integrated peripherals to use either the onboard VGA or PCIE, not all motherboards automatically disable the onboard VGA if a discrete card is plugged in.
Score
0
a b U Graphics card
October 20, 2010 12:27:00 AM

It's an asus 890gx so i'd be really surprised if it didn't disable the igp. It's worth a shot though I guess.
Score
0
October 20, 2010 12:28:12 AM

eyefinity said:
It's an asus 890gx so i'd be really surprised if it didn't disable the igp.

is there anyway to disable the graphics then?
Score
0
a c 271 U Graphics card
October 20, 2010 12:30:00 AM

Check in your BIOS by pressing the delete key when starting the machine.
Score
0
October 20, 2010 12:32:37 AM

Mousemonkey said:
Check in your BIOS by pressing the delete key when starting the machine.

i did it but i'm not sure what to do. i go to the igp controller and it says this other stuff which doesn't look like to disable the whole thing
Score
0
a b U Graphics card
October 20, 2010 12:33:53 AM

He's already got into the bios.

In the IGP section, you probably have to use your arrow keys to highlight it, then press enter. After that you should be able to change the setting using the arrow keys again.

Bios's are still a black art...and I'd be amazed if that was why it wasn't working. Be warned, if you switch of the IGP and the graphics card isn't working, you are now into reset-bios territory, and there is no way I'm gonna explain that one lol.
Score
0
a b U Graphics card
October 20, 2010 12:34:25 AM

I'm guessing you see stuff like GFX0-IGP-PCI ?
Score
0
a c 271 U Graphics card
October 20, 2010 12:34:36 AM

PsychoHistory said:
i did it but i'm not sure what to do. i go to the igp controller and it says this other stuff which doesn't look like to disable the whole thing

List the options you have there.
Score
0
October 20, 2010 12:36:58 AM

ok can you wait a bit then?
Score
0
a b U Graphics card
October 20, 2010 12:39:22 AM



This page is useless to you psychohistory.
Score
0
a b U Graphics card
October 20, 2010 12:40:39 AM



This one has the options at the bottom. You should be able to put "internal graphics mode" to disabled.
Score
0
a b U Graphics card
October 20, 2010 12:46:35 AM

You should be able to change them around so that it says PCI-GFX0-IGP or something like that.

I honestly don't think this will work btw :p  But you seem determined to disable the igp.

Are those links I posted dead btw? I can't see them now.
Score
0
October 20, 2010 12:48:57 AM

eyefinity said:
You should be able to change them around so that it says PCI-GFX0-IGP or something like that.

I honestly don't think this will work btw :p  But you seem determined to disable the igp.

Are those links I posted dead btw? I can't see them now.

there not dead. but the pci-gfx0-igp was set there. i have no clue why itsstill using the igp. lemme check ok
Score
0
a b U Graphics card
October 20, 2010 12:56:49 AM

It can't use the IGP if nothing is connected to it.

Take the HDMI cable out of the IGP slot.
Score
0
October 20, 2010 1:01:30 AM

eyefinity said:
It can't use the IGP if nothing is connected to it.

Take the HDMI cable out of the IGP slot.


nothing was connected to it. the card is a 768mb gtx 460 by galaxy. do you think the mobo needs a bios update to support the card because im guessing the gtx 460 came out after the the mobo or am i wrong. im banging my head now because of this :fou: 
Score
0
a c 271 U Graphics card
October 20, 2010 1:08:47 AM

Do you not have a page like this in your BIOS?
Score
0
a b U Graphics card
October 20, 2010 1:11:46 AM

You don't need a bios update to run a graphics card.

Just install the card by itself in your pci-e slot, put your vga cable into the back and switch it on.

Did you plug the pci-e connectors into the card btw? The 2 6-pins that need to be connected to the back of the card INSIDE the pc.
Score
0
October 20, 2010 1:48:01 AM

eyefinity said:
You don't need a bios update to run a graphics card.

Just install the card by itself in your pci-e slot, put your vga cable into the back and switch it on.

Did you plug the pci-e connectors into the card btw? The 2 6-pins that need to be connected to the back of the card INSIDE the pc.

yes everything is plugged in buddy and i can feel the air coming from the fan of the card. if i remember correctly i have that switch card on the secondary pci x16 slot
Score
0
a c 271 U Graphics card
October 20, 2010 1:53:42 AM

PsychoHistory said:
i have one like that but one thing i noticed was the primary graphics adapter was only PCI by itself. for me its PCI-GFX0-IGP or something like that

Then try each one in turn.
Score
0
a b U Graphics card
October 20, 2010 1:55:07 AM

Try switching the cards around in the slots too btw. By "switch card" you mean a dummy card right?
Score
0
October 20, 2010 1:55:41 AM

Mousemonkey said:
Then try each one in turn.

Even though there is no single word like PCI/ i guess ill ty all the combinations. Hope it woks and it will ake me a couple of minutes
Score
0
October 20, 2010 2:03:00 AM

eyefinity said:
Try switching the cards around in the slots too btw. By "switch card" you mean a dummy card right?

yes the dummy card. the dummy card is on the secondary slot as usual.
Score
0
October 20, 2010 2:10:02 AM

Mousemonkey said:
Then try each one in turn.

i noticed the page is a bit different grrrr/ im still trying the options though
Score
0

Best solution

a b U Graphics card
October 20, 2010 6:12:51 AM

If it's still not working after all that, there's a high chance you've got a kaput card mate.
Share
October 20, 2010 10:54:13 PM

eyefinity said:
If it's still not working after all that, there's a high chance you've got a kaput card mate.

i hope not though im still trying to disable it
Score
0
October 20, 2010 11:24:09 PM

eyefinity said:
If it's still not working after all that, there's a high chance you've got a kaput card mate.

i might reinsert the card when i have the time to check if its broken or not. But right now thanks for the help
Score
0
October 31, 2010 12:53:06 AM

Best answer selected by PsychoHistory.
Score
0
a c 271 U Graphics card
October 31, 2010 12:56:13 AM

This topic has been closed by Mousemonkey
Score
0
!