Sign in with
Sign up | Sign in
Your question

BIOS Question on my New Build

Last response: in Systems
Share
December 17, 2010 12:01:15 PM

Hi all, I have now built my PC http://www.budgetbuybuild.com/specmanager/15996/ and it all went without a hitch. I installed my copy of Win7 Home Premium and then installed the BIOS from the CD-ROM which came with the GA-MA770T motherboard. It installed apparently OK and the PC is working fine but the install didn't follow the stages as shown in the User Manual. I put the CD in the drive expecting a Gigabyte options screen to appear with the install options showing but instead just got the Win7 installer box which I okayed and the install went ahead and after a couple of reboots I was back at the Win7 screen. Everything apparently works fine but I read in one of the Win7 users help pages I had found here and other sites via Google that as I understand it in Win 7 when installing programs I should right click and choose "Install as Admin" from the drop down menu instead of using the left click option as I did.

My question then is, should I be worried that Windows Installer has installed the programs on the CD as I would have done or has it used Windows drivers etc instead of the Gigabyte drivers etc etc. Would it be a problem if I uninstalled the BIOS and reinstalled again but using the Admin option this time, or am I worrying needlessly?.

More about : bios question build

December 17, 2010 12:52:15 PM

no worries.
December 17, 2010 1:19:11 PM

Thanks for the reply pinaklonkar, but do you mean no worries as in leave it as it is?, or no worries as in reinstall the BIOS?
December 20, 2010 7:55:47 PM

Unless there is a problem of any sort, I would not update the BIOS or reinstall or whatever.
!