Sign in with
Sign up | Sign in
Your question

ISO 4870x2pe52gxoc Bios plz!

Last response: in Graphics & Displays
Share
October 21, 2010 5:20:18 AM

Does anyone have this specific bios? In my arrogance I forgot to back up the original bios. Yes I know dumb mistake but was in a hurry at the time. So I was wondering does anyone happen to have the bios for slave and master?

Please let me know would greatly appreciate it thanks!
October 21, 2010 8:15:01 AM

Although yours is a Diamond card and the stuff for it that was available is all 1024MB version, I was able to find the Sapphire 2048 Bios, now if that is compatible and will work since the rest of the hardware is the same, you'll need to tweak it up to your 800/950 clocks to get the default back.....
http://www.techpowerup.com/vgabios/42940/Sapphire.HD487...

That's the link to it....
October 21, 2010 8:29:22 AM

thanks :)  hopefully this works
Related resources
October 21, 2010 8:55:02 AM

Yeah, let's hope that is work...
October 21, 2010 9:25:52 AM

Does not work -_-

Hopefully someone can post the original bios up here ;/

thanks for the help so far though.
October 21, 2010 9:30:04 AM

So, at the first, you are flashing the BIOS and didn't succeed, right?
As far as i know, if you failed on flashing BIOS then your card is just ruined...
October 21, 2010 9:42:57 AM

What message are you getting? and what program are you using to flash the bios of the card?
October 21, 2010 9:54:34 AM

I am able to flash the card but for some reason it does not display anything when I restart the comp. I can hear the fan going + it running but no screen.

I was gonna use atiflash379

but I have been using radeon bios editor.

I cant seem to get my usb drive to boot up, I used HP USB Disk Storage Format Tool. I stopped using it since I could not get it too boot on my comp.
October 22, 2010 3:43:59 PM

Ok I flashed both gpus on my hd 4870 x2, yet for some reason I still get a blank screen. I have a second card in the #2 pci card slot, its a cheep 50$ card. Although I am able to log onto windows and see everything with the second card in. While I got my hd 4870x2 in the first pci slot. Yet now I am confused what to do... I notice windows recognizes I have a hd 4870x2. Problem is I cannot get a picture on my monitor.. anyone know what to do ><?
!