Sign in with
Sign up | Sign in
Your question

ASRock Z68 Extreme7 Memory Slot Problem Causes No Post

Last response: in Motherboards
Share
November 18, 2011 3:20:49 PM

Hello everyone, I just got a bunch of new computer upgrade parts and have run into a problem. The ASRock Z68 Extreme7 motherboard won't post if I use memory in either of the A slots but works fine if I ONLY use the B slots.

I tested all 4 memory sticks (G.Skill Ripjaw 16gb DDR3 2133) in all 4 slots and in all different combinations with the following results:
- If used individually, all 4 sticks work correctly if used in slot B1 or B2
- If used in combinations of 2, all 4 sticks work correctly if used in slots B1 and B2
- Nothing works (no post) if I ever put any stick or combination of sticks in slots A1 or A2

The recommended use for dual channel is:
- 2 sticks via A1 and B1 or A2 and B2 (doesn't post for me)
- 4 sticks in all 4 slots A1, B1, A2, B2 (doesn't post for me)
If I do either of those recommended placements my system won't post, it will only work if all sticks are removed from the A slots.

When using the B1/B2 slots I am able to get into the system perfectly fine with either 1 or 2 sticks in place. So, using those slots I looked through the Bios to see what the memory was running at. It was being recognized correctly and showing the 2133 speed with 11-11-11-30 timings and 1.6v exactly how they are specced. After Googling for any ideas I saw some forums where people had similar issues and the general consensus was 3 options:
1. Dead Ram
2. Bent pin causing CPU connection issues associated with memory slots
3. Dead Mobo

With my various testing it seems like I have ruled out dead ram so I am down to either a bent pin or simply a dead motherboard. Before I RMA the Mobo to NewEgg I wanted to see if anyone has any ideas or bios upgrade tips, etc that I could try to fix the issue. I will take a look tonight to see if any pins look bent, the CPU seemed to go in perfectly with no issues when I put it together.

Here are the full specs of the machine:
Motherboard: ASRock Z68 Extreme7 Gen3 LGA 1155
Ram: G.SKILL Ripjaws X Series 16GB (4 x 4GB) 240-Pin DDR3 2133
CPU: Intel I7 2600K Sandy Bridge Quad-Core 3.4Ghz
PSU: ABS Tagan BZ Series BZ1100 1100W ATX12V / EPS12V SLI Ready
Video cards: EVGA GeForce GTX 580 Classified 3GB (x2 in SLI) *note I tried my testing with both 1 vidcard and 2 in SLI just to see if SLI might be related, same issue*
HD: Crucial M4 256GB SATA III Internal Solid State Drive (SSD)
Case: COOLER MASTER Stacker 830 Evolution Black Aluminum ATX Full Tower
Monitor: Dell 30" LCD with 2560x1600 native resolution
OS: Windows 7 Pro 64bit

If anyone has any ideas or suggestions please let me know, I would love to get this resolved without having to RMA if possible.
a c 435 V Motherboard
a c 128 } Memory
November 18, 2011 3:33:29 PM

I would contact asrock by email. I doubt the ram slots are bad. A simple bios setting change may be all you need. Just link this post to their tech support and fill out any forms required. Give them at least 24 hours to respond. In the meantime, just use the two slots that work.
m
0
l
November 18, 2011 3:38:20 PM

It could be the mobo. although it is possible that it is a BIOS issue.
m
0
l
Related resources
November 18, 2011 3:39:53 PM

Good idea, making a support request to ASRock right now, problem is I am at work so I can't look at the Serial # and don't know the Bios version =(

Are there many different Bios versions available for the ASRock Z68 Extreme7?
m
0
l
a c 435 V Motherboard
a c 128 } Memory
November 18, 2011 3:48:14 PM

There are four bios versions for your board. But none of the new bios updates list any memory issues for fixes. If you find the tech support form, just use the first bios file 1.00 for the request form. Also check out the youtube videos on your board's web page for tips. (my link didn't work).
m
0
l
November 18, 2011 3:53:43 PM

Thanks, I went ahead and submitted the ticket to ASRock with Bios 1.00 (which I think it is) to see what they say. I looked through the BIOS versions and agree, nothing is mentioned about memory.
m
0
l
a c 435 V Motherboard
a c 128 } Memory
November 18, 2011 3:56:43 PM

If you just don't have any patience, you can try one more time changing the bios using just the two sticks that work. Press the "del" key when posting to enter the bios. Change the memory setting from "auto" to "manual" and use 1600 for the speed. Also set the ram voltage in manual mode to 1.5v,save and exit, power down, and try all four sticks one more time. If the board works with all four sticks, then you'll know the ram and board are ok and maybe save an rma. If this doesn't work, power down and remove the two sticks that cause the problem and leave it alone until asrock responds. You're liable to damage a slot by changing the ram too much. I worked at dell, and was always straped in with an esd strap to prevent electrostatic discharge damage when handling motherboards, cpus, and ram. It's a real issue that blows circuits, so the less you touch your components, the less chance you'll damage something. Good luck.
m
0
l
November 18, 2011 4:56:15 PM

I don't want to mess with it too much more considering I already switched through every combination of memory in every slot multiple times so I went ahead and created an RMA with NewEgg.

The really nice thing is I was able to call them and have them send the replacement now, but I will continue to use the current board with just 2 slots until the replacement shows up. Once the replacement arrives then I can send out the bad one and as long as they receive the RMA part in time my card won't be charged.

<3 NewEgg and their great service, wish me luck that the replacement ASRock board works
m
0
l
a c 435 V Motherboard
a c 128 } Memory
November 18, 2011 5:05:04 PM

Keep my suggestions handy in case the new board has the same symptoms.
m
0
l
November 18, 2011 7:23:41 PM

I heard back from ASRock support and they basically had similar suggestions

"Hi,
· Remove all the memory sticks modules out. Flash the bios to 1.3 http://www.asrock.com/mb/download.us.asp?Model=Z68%20Ex...
· Insert 1 memory module only with proper dram voltage that require with ram, (DRAM voltage)
· Adjust the DRAM freq as well, save and exit out the bios.
· Go back into the bios again, and make sure the 1st memory is being proper detect under the bios. If it does, then install the 2nd memory module.
· Repeat the same steps above, until you have all memory install. If for some reason you still not able to get the all ram detect properly. Please do let us know we glad to swap the board for you. Thank you.
· You can leave the memory timing on auto (press F9) load default setting from Bios.
· Please download the memtest86+ to verify each ram still are error free.
Tech Support Team"

In the interest of being thorough I went ahead and followed the suggestions, flashed to Bios 1.30, manually set Memory info and the exact same problem persists. Only thing left is to wait for the RMA replacement to arrive as I don't want to go monkeying with the CPU pins and risk voiding the Warranty.
m
0
l
November 23, 2011 5:48:50 PM

Another update for anyone interested, I RMAed the board and got the replacement one in. All 4 memory sticks work perfectly right out of the box. If anyone ever has issues with slots of memory not working I would recommend an RMA ASAP as a fully functioning board shouldn't have that issue.
m
0
l
!