Sign in with
Sign up | Sign in
Your question

Need help with Asrock N68-s ucc...

Last response: in Motherboards
Share
November 18, 2011 4:30:23 PM

So i have bought an Asrock N68-s ucc and installed it. When I turn on my pc the motherboard screen comes up and i have some options to choose from. (F11 for boot settings, F12/Del for setup etc.) But when I click on a button on the keyboard, there is no response at all. I Have tried 2 different keyboards and mice, no response. I don't think I've done anything wrong while installing the mobo in pc and connecting cables. Can anybody help me?

More about : asrock n68 ucc

a c 435 V Motherboard
November 18, 2011 4:42:55 PM

You have to be quick. Press the keyboard quickly before the post screen appears. Or try another keyboard with a different connector, such as ps2 instead of usb.
November 18, 2011 4:53:58 PM

I have tried pressing the keyboard repeatedly while starting the pc, but no luck, still no response. I have tried an usb and a ps2 keyboard, no response on both of them.
Related resources
a c 435 V Motherboard
November 18, 2011 5:06:28 PM

Try just one stick of ram; if that is the board has both ddr2 and ddr3 slots, use just one or the other, not both.
November 18, 2011 5:22:52 PM

Ok, I've tried removing 1 out of the 2 sticks of ram and now everything works like a charm. Thank you very much o1die!!!
!