Sign in with
Sign up | Sign in
Your question

Intel D865PERL will not boot using dual channel

Last response: in Motherboards
Share
November 19, 2011 9:45:13 PM

I've had a Intel D865PERL for several years now that has performed like a champ. Last week, however, I did my monthly Microsoft patches and, upon reboot - No POST. So I figure bad memory DIMM, right? This PC had a memory upgrade 3 or 4 years ago. The original memory was 2x 512mb Centon PC3200 DIMMs and I added an addtional 2x 1 GB Patriot PC3200 CL3 DIMMS (PSD1G400). This board has dual-channel dynamic paging, so suspect that I would have arranged the 512's in slot 0 of channels A & B, and the 1gb's in slot 1 of channels A&B. At any rate, it's been running fine just fine with 3 GB of ram installed for years now.... Until last week.

So, in troubleshooting, I figure I've got a bad DIMM... However I try booting with each DIMM singularly (boot once each with each 512 and each 1GB) and they each, by themselves POST fine. This is where it gets really strange. I can run the following configurations of DIMM placements with the following results:

(A&B are the channels, 0&1 are the slots in each channel)
A,0
A,1
B,0
B,1

1 GB - A,0 - successful POST
1 GB - A,0 - 1 GB - B,0 - No POST
512 mb - A,0 - successful POST
512mb - A,0 - 512mb - B,0 - No POST
1 GB - A,0 - 512mb A,1 - successful POST but warning of improper configuration
512 mb - A,0 - 1 GB A,1 - successful POST but warning of improper configuration
512mb - B,0 - successful POST

The only thing that's new and potentially "iffy" is that several weeks ago I replaced the CMOS battery. Further, the reboot last week may have been the first time the PC has been rebooted since then. Otherwise it's always on, 24/7 as I use it as a server. I did, today, remove the CMOS battery again, clear the CMOS and try installing DIMMS again, but with the same results.

So, currently it's online and running fine with a single 1GB DIMM in slot A,0. I'd really like to figure out, however, what seems to have happened to the board's ability to handle a dual channel memory configuration.

Any guidance or assistance would be greatly appreciated.
a c 216 V Motherboard
a b å Intel
November 19, 2011 11:27:44 PM

What happens when you place the two 512 MB or the two 1 GB DIMMs in A,1 and B,1?

Are you using Auto/Default memory settings in BIOS? Have you tried manual settings?
m
0
l
November 20, 2011 6:38:45 PM

Thanks for your reply, KO.

Here are the results of further tests:

1 GB - A,0 - successful POST
1 GB - A,1 - 1 GB - B,1 - POST, counts 2048 mb and then freezes.
512mb - A,1 - 512mb - B,1 - No POST
1 GB - A,1 - 1 GB - B,1 - 2ND TRY - NO POST... Strange, it at least posted once before...
1 GB - A,0 - 1 GB - B,1 - No POST
1 GB - A,0 - 1 GB - B,0 - No POST
1 GB - A,0 - 1 GB - A,1 - POST, counts 2048 mb and then freezes.

I tried booting with 1 GB in A,0 and find the following settings in the BIOS that I could configure, but I'm not sure what selections to make.

My BIOS version is RL86510A.86A.0075.P15

On the MAIN screen, the Memory Mode seems to be automatically set.
Currently it reads:
L2 Cache RAM - 1 MB
Total Memory - 1024 MB
Memory Mode - Single Channel
Memory Channel A Slot 0 - 1024 MB (DDR400)
Memory Channel A Slot 1 - Not Installed
Memory Channel B Slot 0 - Not Installed
Memory Channel B Slot 1 - Not Installed

On the Advanced Screen, under Chipset Configuration there is:
Extended Configuration - Default or User Defined [currently set to default]
User Defined enables Chipset Memory Timing Control
SDRAM Frequency - Auto, 266 MHz, 333 MHz, 400MHz
CPC Override - Auto, Enabled, Disabled
SDRAM Timing Control - Auto, Manual-Aggressive, Manual-User Defined
Auto - has the following defaults
SDRAM RAS Act. to Pre. [8]
SDRAM CAS# Latency [3.0]
SDRAM RAS# to CAS# delay [4]
SDRAM RAS # Precharge [4]

Manual-Aggressive - has the following defaults
SDRAM RAS Act. to Pre. [5]
SDRAM CAS# Latency [2.5]
SDRAM RAS# to CAS# delay [2]
SDRAM RAS # Precharge [2]

Manual-User Defined - has the following ranges of options
SDRAM RAS Act. to Pre. [8, 7, 6, 5]
SDRAM CAS# Latency [2.0, 2.5, 3.0]
SDRAM RAS# to CAS# delay [4, 3, 2]
SDRAM RAS # Precharge [4, 3,2]

I'm tempted to purchase a fresh set of 1 GB DIMMs and see what happens.

Of note, there is a couple other clues:

Clue 1 - May be unrelated - For years now, if the pc is rebooted, the BIOS POST sequence will stop after detecting the drives and display "Press F4 to Resume". No error. just press F4 and on it goes. It's only an annoyance if I need to remotely reboot, which does sometimes happen. However, i discovered that if I do not have a keyboard plugged in (either USB or PS2) I don't have this problem.
Here's where that part gets weird: I found on a forum post that if you DISABLE S.M.A.R.T. detection, it will not give this problem. So I experimented.

I have 5 drives in the system and found that the 2nd drive (drive 1 in the boot, Primary Slave) was going bad. All the other drives pass with no errors. Ah hah! I said, so I disable S.M.A.R.T detection on this drive. However, the problem persists. So, I experiment some more and find that I have to disable S.M.A.R.T on the boot drive (drive 0, Primary Master) and the problem goes away, even with a keyboard plugged in.

Clue 2 - Possibly related - The other thing that is bizarre about this story, is that I have one other machine (Gigabyte GA-G41M-ES2L) who lost it's bootfile (ntloader) at or around the same time as the occurrence of my Intel D865PERL memory issue (about a week ago now). These 2 machines are on the same electrical circuit in my lab and I do wonder if I may have received a little electrical discharge from a storm or something. I have no other electronic issues that I am aware of.

Anyway, again, I sincerely appreciate your time and consideration.
m
0
l
Related resources
a c 216 V Motherboard
a b å Intel
November 20, 2011 9:57:17 PM

The reason I asked about placing DIMMs in A,1 and B,1 is because those memory sockets should be located at the end of memory bus for each channel. There is suppose to be less digital signal reflection at the end of the memory bus verses using the sockets in the middle of the memory bus when using only two DIMMs.

Two systems developing problems at the same time would seem to indicate a power surge or some electrical event that may have caused it.

The Centon Memory Power (512MBPC3200) DIMMs have a memory timing of 3-3-3-8-2T @ DDR400.

The Patriot Signature PC3200 CL3 (PSD1G400) DIMMS have a memory timing of 3-4-4-8-2T @ DDR400.

The order of the memory timings values are:

tCL-tRCD-tRP-tRAS-CMD

tCL - SDRAM CAS# Latency
tRCD - SDRAM RAS# to CAS# Delay
tRP - SDRAM RAS# Precharge
tRAS - SDRAM RAS Active to Precharge
CMD - Command Rate

In the Advanced menu list, select Chipset Configuration sub-menu and use the following settings to see if you are more successful:

Extended Configuration - User Defined

SDRAM Frequency - 400MHz
CPC Override - Enabled <----- This should enable 2T Command Per Clock
SDRAM Timing Control - Manual-User Defined

SDRAM RAS Act. to Pre. [8]
SDRAM CAS# Latency [3.0]
SDRAM RAS# to CAS# delay [4]
SDRAM RAS # Precharge [4]
m
0
l
November 21, 2011 12:49:28 AM

So, I set your timing settings as indicated and found the following results.
Try 1 - Going for the Gold - 1 GB - A,0 || 512 mb - A,1 || 1 GB - B,0 || 512 mb - B,1 - No Post,
Try 2 - 1 GB - A,0 || 1 GB - B,0 - POST, counts 2048 mb and then freezes.
Try 3 - 1 GB - A,0 - Successful Post
Try 4 - 1 GB - A,1 || 1 GB - B,1 - NO POST...
Try 5 - 1 GB - A,1 - Successful Post
Try 6 - 1 GB - A,0 || 1 GB - A,1 - Successful POST counts 2048, but in single channel mode. BIOS pauses at the end of post stating such and asked to Press Any Key to Continue. System would boot from there. Rebooted to test to see if Press Any Key warning would continue... it does. Seems the board really doesn't like 2 DIMMS in single channel mode.
Try 7 - 1 GB - A,0 || 1 GB - B,0 - (2nd try) NO POST.

I'm beginning to believe there may be some kind of hardware issue going on that is preventing the Dual Channel process from working. I'd order 4 new 1 GB DIMMS if I weren't puzzled why they would post individually.

Is there a way to test memory if the system doesn't post? I guess I could run MemTest on each DIMM individually and see what happens. KO, I appreciate your help and I'm going to definitely save these details about the memory configuration. That part of the BIOS I've never quite understood. I will follow up your settings recommendations with some research about how all that works.

Again, I truly appreciate your diligent efforts.
m
0
l
December 1, 2011 12:39:29 PM

**UPDATE** 2011-12-01 - Still running on only 1 x 1 GB DIMM. Next step is to bring down system and test DIMMs one at a time using MemTest86.
m
0
l
December 7, 2011 11:09:32 PM

Each 1 GB DIMM passes MemTest86 individually with no errors. Tried adding 2nd 1 GB DIMM again to slot B,0... Board posts, counts 2048 mb of memory and then freezes. Reboot and system will not post. Removed 2nd DIMM and board boots but reports "memory errors" and that the "default memory settings have been loaded."

Any further guidance would be greatly appreciated.
m
0
l
December 18, 2011 11:57:22 AM

...
m
0
l
December 24, 2011 1:04:10 AM

I'm having a similar problem with D865PERL. 4 Identical Crucial 1gb sticks will work initially. PC will post and boot normal. Then, if I shut the pc down and try to start, it won't post. I pulled stick 4 out leaving only 3 and it boots fine. This happened with different ram values as well. The pc worked fine prior to this. It happened suddenly. I'm curious if it's a bad capacitor or chip or something.
I've tried removing CMOS battery, replacing it with new one, clearing the CMOS. None of those things work. Only thing that lets it post is removing ram stick #4. weird.

Anyone have any thoughts on this?
m
0
l
December 24, 2011 1:05:11 AM

By diff ram values, I meant 512mb sticks too.
m
0
l
December 30, 2011 11:28:52 PM

@iguana9 -- Very interesting. I checked my board over pretty well looking for a swollen capacitor but found none. Although that doesn't necessarily mean much. I suspect I'm probably going to relegate this board to some kind of menial task or just make wall art of it at some point. The tough part for me is that is is my main server at home and, well, I'm just reluctant to change. I'll hold out to the bitter ends though. So if anyone else has similar experience, I'll certainly love to hear it.
m
0
l
May 10, 2012 12:14:13 PM

WOW, I am also having the same issues! and I think it happened after an update. I have been pulling my hair out too on this.
m
0
l
May 30, 2012 8:03:09 PM

Very interesting Duster37! I've since "abandoned" the board so to speak. It's currently sentenced indefinitely to the punishment pile. It might even make it up to "the roof". Every so often, in an effort to curb my genetic hoarding tendencies with all things mechanical and electronic, my wife does a little "purge" of my inventory. I don't blame her at all and it keeps me from being on one of those television shows. So who knows how much longer I'll have it. But I'll keep an ear out for any solutions.

m
0
l
!