Sign in with
Sign up | Sign in
Your question

How do I get my i7 950 to recognize all my RAM

Last response: in CPUs
Share
March 14, 2011 7:31:11 PM

I have an i7 950 CPU, ASUS Rampage III Forumula MB, Zalman 9900 CPU cooler, EVGA 580GTX, Win7 64 bit and 6 sticks of Corsair TR3X6G1600C8 RAM (6x2GB each). I can only get some of my memory to show though. When I had 3 sticks in it only showed 4 GB of RAM instead of 6 and when I installed 6 sticks is fluctuates between 6 and 8GB of RAM (depends of how lucky I get at start up). I had removed all the RAM and put one stick at a time in the C3, B3 and A3 slots and they all showed up as 2GB and then I installed all 6 sticks and it showed 12GB, however when I restarted the machine it only showed 8GB the next time and now I can only get it to show between 6 and 8GB. I spoke with ASUS support and they said to change the voltage to 1.65 and the speed to 1600MHz - no effect, same thing happens. I spoke to Corsair and they said I should be able to get it to run, but that was about it. I contacted Intel, they told me that the CPU will only handle 800 or 1066MHz RAM. I have built a couple computers, but never got into OCing, is there a way for me to get my system to show all of my RAM?

Both ASUS and Intel said I could RMA their products, but that it most likely wouldn't help.I have run MemTest and didn't get any errors and I tried running the Intel Processor Diagnostic Tool and it didn't show any issues. Can I remedy this by OCing or did I just screw up and need to buy crappy RAM? If I can fix this by OCing, could you tell me a good place for those inexperienced with doing it, where is a good step by step site to go to or is there one on Tom's Hardware?

Any help would be greatly appreciated, especially with the lack of help from the companies themselves.


Eki

More about : 950 recognize ram

March 14, 2011 9:33:05 PM

Either something is defective, or you aren't overclocking right, or something is messed up in bios.. Most likely something is defective with either the mobo or the ram. That or your bios settings are messed up. There's a lot of reasons why this could/would happen.
m
0
l
a b à CPUs
March 14, 2011 9:46:21 PM

That's bad advice from Intel saying you can only run 800 or 1066mhz ram. I have 1600 ram and are running it at 1650 with my overclock. I had the same problem with my ram it would show up as 2 gigs even tho I have 6. I just reseated mine and all 6 showed up.
m
0
l
March 14, 2011 9:47:42 PM

christop said:
That's bad advice from Intel saying you can only run 800 or 1066mhz ram.


Has intel ever given good support?
m
0
l
March 15, 2011 5:54:38 PM

The only thing I had done in BIOS was change the RAM setting to 1600MHZ and up the Voltage to 1.65, and it still has the same issue. I have gone back and reset the BIOS to default settings (1066MHz and 1.5V) and it still does the same thing. I spoke with Intel again today and they said that the memory isn't compatible and that it will burn up the processor (Intel said it is common with this board) oh, and they also said I could void my warranty running ram that isn't supported. I have removed and reseated my RAM several times talking with ASUS support and it keeps changing every time I do it, but it never stays stable (i.e. it shows 8 GB and the next time 6 GB) Could it be that I just have the CPU tightened down too much? I have seen others say that having having the mounting bracket too tight on the CPU can cause issues?

Okay, I just got off the phone with ASUS Tier 3 support and he recommended I shut down the system and remove all ram except for the A2 slot and then remove the CMOS battery for about 10 min. Then after restarting go into AI Overclocker and change to XMP, shut down and reinstall all remaining RAM. I have done this and it posted the 12 GB of RAM. I shut down the system and it still posted 12 GB the second time. I am keeping my fingers crossed that this will be the same when I next turn on the system tomorrow. If not, back to the drawing board.

Thanks to those who posted on this

Eki
m
0
l
March 16, 2011 6:13:26 PM

Yep, that was an update, but I actually have another one :( 

I logged in today and now I am showing 10 GB of RAM. Also, last night, I could run most applications and browse the web just fine, but when I tried gaming, the system would crash to BSOD sometime within a minute or two of entering the game and sometimes I could play for about 20 min. Trying to contact ASUS again to see WTF is going on here. I think it may be setting it to XMP instead of manually setting the timing and MHz
m
0
l
March 16, 2011 7:14:54 PM

Basically, no I am not OCing. The only thing that Tech support told me to do were the steps above (remove the CMOS battery, restart and when in BIOS change to XMP from Auto which detects your RAM speed and latency and sets it for you). I did this, it worked fine last night except I couldn't game (I think the longest I played Homefront was for about 20 minutes before I got the BSOD). I started it back up and logged into my NHL GameCenter account and watched a game for 3 hours with no problems streaming video. My have to check some other games out to see what happens. I am also running CoreTemp and my max temps showing never exceeded 54 degrees C, so that shouldn't be a problem.
m
0
l
March 16, 2011 7:22:44 PM

Did that previously, no faults found
m
0
l
March 16, 2011 10:24:40 PM

I have tried putting RAM in each slot and it worked fine, it was only after installing all of the RAM that I get the issues. Basically, it comes down to two things, I can install all or some of the RAM and run the system on default settings, but then I only show 6 - 8 GB of RAM, I have it on the XMP and it showed 12 originally and now 10, but system is unstable when I game, fine for everything else though. Actually minor change to that, I just tried playing Counter Strike and it didn't seem to have a problem with that. I could go buy some new RAM to test it out, But not sure what would be a better latency, the one I have is tested at 8-8-8-24. I have also read that if the CPU is seated too loosely or to tight, that it may cause issues, but I will check that out this weekend (don't have time after work to tear my system apart and put it back together). Other than that, I am waiting for ASUS to call back about this and see what they say.
m
0
l
March 17, 2011 12:19:29 AM

From what I understand, when tightening down the CPU cooler, if you over or under tighten it, it could cause contact issues. I think that would warp the MB though and the MB isn't warped, so i don't think that is it. I may take it apart this weekend just to make sure though. This board (ASUS Rampage III Formula is supposed to handle 1600MHz + RAM, so it could just be an issue with the MB.
m
0
l
March 17, 2011 9:19:27 AM

In my BIOS, the default for the RAM was 1066MHz and that's what the XMP setting does, it steps up the clocking to 1600MHz and the Latency to 8-8-8-24 to match the RAM
m
0
l
March 17, 2011 12:07:43 PM

That's what I need to check up on. I have read in some other threads/forums to not use the XMP, but to manually set the voltage, speed and latency. I may give that a try tonight and see how it works.
The computer runs fine on everything but games although I did play Counter Strike without any problems for about 10 or 15 minutes last night, but it isn't as much of a resource hog as BFBC2 or HomeFront, but with a EVGA 580GTX vid card with 1 GB of RAM, I didn't think that would be the issue. And running CoreTemp program, none of my CPUs cores are going above 54 centigrade (or there about) so it shouldn't be crashing from overheating.
m
0
l
March 17, 2011 1:08:48 PM

Yeah, you could say it has me stumped. I am not going to buy 1066MHz ram as there is none that I saw that was particularly good, and I am not sure why I can't get my system to read all the mem in it when it seems others can. This is the first time I have run into an issue like this and this is the third comp that I have built, I just never really got into the OCing or tweaking of the computers because I was afraid I would wreck them and they ran sufficient for my needs. However this RAM issue has got me quite puzzled.
m
0
l
March 18, 2011 8:32:43 PM

Minor update: I think I have it narrowed down to one of two things, either I have a bad stick of RAM or my MB has a bad Mem slot. I will test it out tonight or tomorrow, but I took out all the RAM and put in three sticks again, and set the BIOS to default (1066MHz, Auto Detect, and voltage back to 1.5) and I have been getting 6GB to show for two days now and have been able to play games again. I think I am going to try installing the other three sticks of RAM one at a time in the open slots and see what happens, if one stick fails to post immediately or within a day or two, then I think I just have a bad stick of RAM causing me problems. If the same stick posts to two of the open slots but not the other, then I probably have an issue with the MB and need to RMA it. That's about as far as my thinking will take me right now. I tried running the Intel Processor Diagnostic tool I found on Intel's site and it is passing all of its tests to include a stress test and the memory controller test. :pt1cable: 
m
0
l
March 19, 2011 12:23:23 PM

Yeah, the only thing that has me stumped is why had it showed up to 12GB when I had all the RAM in (at least for an evening) but then wouldn't run games? Can one stick of RAM or a bad RAM slot be able to pick it up for a little bit and then lose connection and then totally jack up the system?
m
0
l
March 19, 2011 12:24:12 PM

Best answer selected by ekipage.
m
0
l
March 20, 2011 6:35:38 PM

Okay, have had it stable with 3 sticks of RAM and just got around to testing the other three sticks today. I put the first stick in the three open slots and it read the extra RAM, I put in the next stick and it read 8 GB, I put in the last stick in the third slot and it only read 6GB, so....it appears that I have one bad stick of RAM that was causing the problem. I didn't think one bad stick would jack up the system that bad. Looks like I need to contact Corsair to get an RMA for this memory pack.
m
0
l
April 18, 2011 7:47:16 PM

Oh yeah! It was a bad stick of RAM. I RMA'd the bad ones back and got a new pack the other day. Running 12 GB stable at 1066MHz for about a week or so now. Now to see how it handles when I tweek the bios to run it at the 1600MHz speed it is rated at.
m
0
l
!