Sign in with
Sign up | Sign in
Your question

Catalyst 10.10 is out,post your results

Last response: in Graphics & Displays
Share
October 22, 2010 8:02:47 PM

There you go
http://game.amd.com/us-en/drivers_catalyst.aspx
It seems it gives a good small performance boost in numerous games.

More about : catalyst post results

October 22, 2010 8:07:04 PM

Bummer, I thought I was going to beat you to it :lol: 
Related resources
October 23, 2010 10:26:00 AM

The hotfix seems to work for 6850 and 6870 but i guess it should work fine with other series too.
October 23, 2010 3:06:41 PM

Best driver ever!

Everything from AVP to Crysis to Unigine has improved 4-5 fps average! I love it. Also my Windows Experience Index went up from 7.6 to 7.7 on the graphics rating portion.

10.5 http://imgur.com/ZdJYS.png

10.10 http://img594.imageshack.us/img594/7097/newz.png

Btw I'm using a single XFX Radeon HD 5850. Now all games I can max out with no AA @1920x1080 and play comfortably @30fps avg
October 23, 2010 3:13:47 PM

Good to hear Carc! I guess I'll have to pick this driver up soon.
October 23, 2010 5:16:13 PM

i updated it through steam so i dont kno if i got the open cl driver.
October 23, 2010 5:55:11 PM

infernox_01 said:
i updated it through steam so i dont kno if i got the open cl driver.

it should show in GPU-Z
@Maziar I din't even bother with 10.10 installed 10.10a and like it, bfbc2 seams to run just a bit fester(got 5770)also here there is some CF improvements ( I got doubts about that)
October 23, 2010 6:04:52 PM

:ouch:  This is scary...everybody, i have news for you. AMD has fired the monkeys on their driver team and have real people! :lol:  But seriously, even with my 4890 is notice less problems, and even a few extra fps here and there. VERY good job AMD, you are becoming the better all-around company now. Before good cards, bad drivers, now better cards, good drivers. I wish i had 5xxx though to test this MLAA stuff out, that might be huge for them. I also cant wait until 10.11. Thats what 6xxx was built for, and is suppose to really bring the real performance of it out. Released with cayman im sure.
October 23, 2010 6:14:19 PM

My 5850 hasn't burst into flames or anything, so all good so far. I have the 10.10 with OpenCL, and OpenCL shows in GPU-Z.
October 23, 2010 7:21:46 PM

well i checked gpu-z and the opencl box is empty just like cuda, pshyx and directcompute.
October 23, 2010 7:31:05 PM

@ares1214 i wouldn't jump the gun so fast..there are people already complaining about some pinkish/ reddish tint with open CL driver
October 23, 2010 7:38:05 PM

ortoklaz said:
@ares1214 i wouldn't jump the gun so fast..there are people already complaining about some pinkish/ reddish tint with open CL driver

yep, installed the 10.10 CL version and got red tint on everything, had to set red at -10 brightness in CCC to get it to look normal... wonder whats up with that.

and when OCed the idle clocks on my 5770 won't go as down as with the 10.4 drivers I previously had installed. Now the gpu idles at 400 and memory doesn't downclock at all
October 23, 2010 7:38:29 PM

I don't see it on mine. I thought that was 10.10a or 10.10 beta.
October 23, 2010 7:42:18 PM

Actually, I take that back. I may have an extremely faint red tint, though I wouldn't have noticed if I wasn't looking for it (and I still need to check with a calibration site to see if it really is).
October 23, 2010 7:51:29 PM

Just installed and noticed an increase of ~3-4 fps in BF:BC2
October 23, 2010 7:51:38 PM

Hitting "Restore Factory Defaults" (NOT "Restore Defaults") fixed the problem from me. Now I need to recalibrate the gamma though.
October 23, 2010 8:09:45 PM

EXT64 said:
Hitting "Restore Factory Defaults" (NOT "Restore Defaults") fixed the problem from me. Now I need to recalibrate the gamma though.

lol no wonder it didn't work for me the first time, wrong button. The tint is gone, thank you. :bounce: 
October 23, 2010 8:53:10 PM

hmmm i thought i didnt have the opencl but i also have this red tint issue. used the restore factory defaults and its back to normal now.
October 23, 2010 11:32:33 PM

Wow, the red tint thing happened to me aswell... I already restored it, now i'm gonna run Unigine benchmark to see if there are any perfomance improvements (HD 5770)
October 23, 2010 11:44:38 PM

Rocket254 said:
Just installed and noticed an increase of ~3-4 fps in BF:BC2


A whole 3-4 fps :o  that just AMAZING!!! :sarcastic:  :lol: 
October 24, 2010 12:07:22 AM

Ok, here are my results on unigine heaven V2.1 with 10.9:

FPS:
23.8
Scores:
601
Min FPS:
13.5
Max FPS:
51.3

Here are my results with 10.10

FPS:
24.9
Scores:
626
Min FPS:
15.1
Max FPS:
54.0

a small increase of minimum - max FPS.

My specs are:

C2D E7500
4 GB DDR2 PC 6400 Corsair XMS2
Sapphire HD 5770 1 Gb GDDR5
WD Caviar Blue 500GB
W7 ultimate 64bit

The benchmark's settingsd were all on high, DX 11, tesselation ON, x4AA x16AF @ 1280 x 720. Not bad. I'm sticking with 10.10
October 24, 2010 12:09:12 AM

Mousemonkey said:
A whole 3-4 fps :o  that just AMAZING!!! :sarcastic:  :lol: 


OH COME ON! Give them some credit!
October 24, 2010 12:10:06 AM

ares1214 said:
OH COME ON! Give them some credit!

Why?
October 24, 2010 12:10:34 AM

Quote:
@carc Did you install that Open cl driver?


Yes I did :) 
October 24, 2010 12:12:54 AM

Mousemonkey said:
Why?


Because, they fixed several issues, introduced some new features, and boosted performance 5-10% in 1 driver release. Thats pretty good, especially for AMD. Not like Nvidia is doing amazing driver updates now.
October 24, 2010 12:14:01 AM

ares1214 said:
Because, they fixed several issues, introduced some new features, and boosted performance 5-10% in 1 driver release. Thats pretty good, especially for AMD. Not like Nvidia is doing amazing driver updates now.

Have you tested the latest Nvidia drivers?
October 24, 2010 12:59:14 AM

Mousemonkey said:
Have you tested the latest Nvidia drivers?


No, but their performance gains havent been anything spectactular from whats been reported.
October 24, 2010 1:08:57 AM

ares1214 said:
No, but their performance gains havent been anything spectactular from whats been reported.

The release notes report performance gains (for the 480 & 460 at least) and just because you haven't tried them or can't try them does not mean that they might not be giving the same 3-4 fps increase in some games.
Quote:
GeForce GTX 480:

o Up to 10% in StarCraft II (2560x1600 4xAA/16xAF Ultra)
o Up to 14% in S.T.A.L.K.E.R.: Call of Pripyat (1920x1200 4xAA/16xAF)
o Up to 16% in S.T.A.L.K.E.R.: Call of Pripyat (SLI – 2560x1600 4xAA/16xAF)
o Up to 6% in Aliens vs. Predator (SLI – 1920x1200 noAA – Tessellation on)

GeForce GTX 460:

o Up to 19% in StarCraft II (SLI – 1920x1200 4xAA/16xAF Ultra)
o Up to 15% in Battlefield Bad Company 2 (SLI – 2560x1600 4xAA/16xAF)
o Up to 12% in S.T.A.L.K.E.R.: Call of Pripyat (2560x1600 noAA)
o Up to 9% in Aliens vs. Predator (1680x1050 4xAA/16xAF – Tessellation on)
o Up to 7% in Metro 2033 (1680x1050 noAA – Tessellation on)
o Up to 11% in Dirt 2 (SLI – 2560x1600 4xAA/16xAF)
o Up to 12% in Crysis:Warhead (SLI – 1920x1200 4xAA/16xAF Gamer)
o Up to 13% in Far Cry 2 (2560x1600 4xAA/16xAF)
o Up to 12% in H.A.W.X (SLI – 1920x1200 4xAA/16xAF SSAO Very High)
o Up to 5% in Just Cause 2 (1920x1200 4xAA/16xAF)
o Up to 22% in Riddick: Assault on Dark Athena (1920x1200 noAA)
o Up to 5% in 3DMark Vantage (Extreme Preset)

Source.
Maybe Nvidia users are not so rabid as to go ga ga over a few FPS as ATi users are?
October 24, 2010 1:19:53 AM

Its not uncommon to see nice gains in multi gpu usage from driver to driver tho
Remove those, and that list becomes small
Having a brand new arch is another thing nVidia has going for it as well
Not knocking nVidia here, just the facts
October 24, 2010 2:20:18 AM

Installed, reinstalled, many times. Now for some reason whenever I try to open CCC, it won't open. Everything else works properly, though.
October 24, 2010 1:44:20 PM

3DMark Vantage GPU score up from 23347 to 24587 overall score went from p19521 to p20273, most other DX11 games went up 3-4 fps, overall so far I'm pleased, only thing that I've noticed is a pink hue on my desktop where it used to be white!
October 24, 2010 1:45:43 PM

Did you try the fix I found several posts up?
October 24, 2010 4:09:20 PM

Just installed it,(had the pink hue issue but it was fixed by "Restoring the factory defaults".
So far so good.
October 24, 2010 8:45:55 PM

It wouldnt be an AMD driver release if it didnt have atleast one problem :sarcastic:  :lol: 
October 24, 2010 8:49:41 PM

Now, Hue do you think you ares?
October 24, 2010 11:08:02 PM

^ Nice :lol: 
October 25, 2010 2:11:57 AM

Crosspost:

I did a test with 10.9 and test with 10.10 and went from 65.7 to 60.2

My setup:
2 5870 crossfire
i7 930 @ 3.8ghz
ddr3 ripjaw 1600mhz
samsung 1tb hd

So what's the deal? I thought this driver was going to increase it?

I'm trying to reinstall 10.10 but I keep getting an INF error.

Edit: Did some tweaking and I think I finally got 10.10 to work... and here's my benchmark for heaven 2.1

http://dl.dropbox.com/u/46885/ati1010.png
http://dl.dropbox.com/u/46885/unigine_20101024_2128.htm...

Would you look at that. Same FPS as 10.9. lol
October 25, 2010 2:44:43 AM

Well, same is better than going down. Did they claim that FPS were supposed to go up in that benchmark?
October 25, 2010 3:59:53 AM

certain gray tones appear to be pink, this is ridiculous you should not have to adjust multiple color settings of a brand new driver to get them to look normal. Seriously disappointing regardless of a few frame per second increase on my 5770, when the hell are they going to get it right because I have read numerous posts on other sites with people complaining of this problem just thought I would bring this to some peoples attention here at Toms


edit*** whoops didnt see the top of the post where this is already mentioned several times, however it is a shame they left the color scheme faulty by default. I found 10.7 to be pretty stable but why should we be forced to use old drivers bc the new ones are crap cmon AMD
October 25, 2010 4:02:03 AM

Sigh.

Up near the top of the thread I already posted this:

Hitting "Restore Factory Defaults" (NOT "Restore Defaults" ) fixed the problem from me. Now I need to recalibrate the gamma though.

Yes it is annoying, but it is extremely easy to fix.
October 25, 2010 4:08:57 AM

EXT64 said:
Sigh.

Up near the top of the thread I already posted this:

Hitting "Restore Factory Defaults" (NOT "Restore Defaults" ) fixed the problem from me. Now I need to recalibrate the gamma though.

Yes it is annoying, but it is extremely easy to fix.



yeah that did nothing for me unfortunatley but after messing with several settings I have a semi normal picture why should I have to go through all this bs this should be a non issue. Unacceptable
October 25, 2010 4:09:53 AM

Then, send the card back
October 25, 2010 4:18:20 AM

JAYDEEJOHN said:
Then, send the card back



The card is fine, its AMDs sorry excuse for a driver that cannot nail a standard color scheme, I'm just dissapointed that after a couple marginal driver releases they would step up their game for 10.10. performance of a single 5770 is becoming marginal at best anymore, I'm ready to swap it out completely and go with two 6870s.
October 25, 2010 4:20:08 AM

If anyone is looking to put Morph AA on to an older 5xxx card
http://forums.guru3d.com/showthread.php?t=331108&page=1

Worked out on my 5770 although it's far from light on my card, x8 adaptive aa does less of a load also lol if you real on the forums certain programs get all blurred. But w.e it was likely just written for the barts cards for a reason.

Also my 5770 surfers from the redish hue now too i just when into desktop properties
set it to red
brought the brightness down by 5 and the contrast down by 5 which pretty much brings it back to where it should be at least on my monitor. You shouldn't mess the the gamma that just fucks up the entire color. You could also do the adjustment on your monitor but i would think it may talk longer.

As for games as the 5770 isn't my main machine i never really keep track to notice a tiny difference if there is one.
October 25, 2010 4:24:50 AM

If youre that disatisfied, return the card
If the fix didnt work for you, as it has for everyone else, return the card
October 25, 2010 4:33:31 AM

JAYDEEJOHN said:
If youre that disatisfied, return the card
If the fix didnt work for you, as it has for everyone else, return the card



the card cannot be returned at this point, making your solution illogical, Also it is perfectly okay for me to be dissatisfied with the driver, I took care of the problem it is just the principle that no tweaking should have been necessary to begin with. Why are you so adamant about returning a card?? The problem is fixed but I'm just surprised to see a moderator being so rash, maybe my tone was misinterpreted but the bottom line of my comment is that if several color settings needed to be tweaked at all to get rid of an obnoxious pink hue than IMO that makes for a half ass driver from the get go. Yeah they are improving but color scheme should be nailed without a doubt. So as a consumer of AMD products I am telling them to get there drivers straight please, for their own good.
October 25, 2010 4:36:22 AM

IzzyCraft said:
Zeesh if the color thing makes him disillusioned i can't wait till his cursor freaks out and he has to restart to get it to look normal again.
http://forums.amd.com/game/messageview.cfm?catid=279&th...



yeah no cursor freak out pal, Problem is fixed like I have stated but the point is that it should have NEVER been a problem to begin with, yes it took me 30 seconds to fix but it is just the principle of the matter.
!