Sign in with
Sign up | Sign in
Your question

Creative Fatality HS-1000 USB headset Microphone issues 'input'

Last response: in Components
Share
March 16, 2011 8:44:28 AM

Hi, I have a Creative Fatality HS-1000 USB powered headset with a detachable microphone running on windows 7.

The problem is, like with my last 'jack' microphone, the sound that I hear works perfectly, yet both the usb and cheap jack headset have problem transmitting or ''input' sound via the microphone.

My computer recognizes both the microphone from the headset correctly 'Creative (record) headset' or something along those lines, as well as the playback creative headset for listening (which works fine).

I just can't transmit to anyone without using my webcam as the mic, which I obviously do not want to do anymore.

My computer and ventrilo both recognize the headset, but when I speak (Push to talk) it doesn't come with any number but '0' when I monitor the sound on ventrilo, nor do any green bars light up when i speak in control panel > sounds > recording devices, yet my webcam's bars light up, showing that it knows Im talking.

I have checked that the mic is not muted nor is it 'off' and have tried all the 'mixers' in vent possible, yet the only mic that works is my webcam mic. I fiddled around and got the headsets mic to work, but when i took it out of the usb port and into the other couple it didn't work, and when i put it back it stopped working on that one too - All my ports work too (tried via mouse). Basically I can hear perfectly, yet I cannot transmit sound to others via my headset, and I have tried both the CD's drivers as well as the latest drivers for my headset - Neither help.
March 16, 2011 4:43:09 PM

The most likey cause is that you have not set it to the default input/recording device.

If you have Vista/7 right click the little speaker icon and select recording devices.

While you are in there, disable every other sound input that is not your creative mic. You will have to restart vent after, but then using the default input device should work. Set your mic as both default and default recording device.

m
0
l
March 17, 2011 2:50:16 AM

nukemaster said:
The most likey cause is that you have not set it to the default input/recording device.

If you have Vista/7 right click the little speaker icon and select recording devices.

While you are in there, disable every other sound input that is not your creative mic. You will have to restart vent after, but then using the default input device should work. Set your mic as both default and default recording device.
http://img687.imageshack.us/img687/6298/defaultzq.jpg


Tried doing it mate, disabled the other 2 and stuff but no dice.. Then disabled everything and enabled the headset under input and still no sound (After rebooting vent etc.)

Keep the ideas coming though if you can - Appreciate it.
m
0
l
Related resources
March 17, 2011 3:14:48 AM

i notice that if you use linein(lets say to pass sound from another computer) on some cards, then you have to disable all enhancements(in mic) to get the mic to work. strange as they are non related, but that's just how it is.

It may be worth trying to disable enhancements to see if it helps.

If you talk, does the blue/green indicator do anything on the windows recording screen?
m
0
l
March 17, 2011 7:02:37 AM

nukemaster said:
i notice that if you use linein(lets say to pass sound from another computer) on some cards, then you have to disable all enhancements(in mic) to get the mic to work. strange as they are non related, but that's just how it is.

It may be worth trying to disable enhancements to see if it helps.

If you talk, does the blue/green indicator do anything on the windows recording screen?



I'll definitely try disabling the enhancements.. the green bars go up on the recording screen only for the built-in webcam microphone, but the creative headset's bars stay unfilled ;/
m
0
l
!