Sign in with
Sign up | Sign in
Your question
Closed

Gtx 460 768mb Interesting dilemma

Last response: in Graphics & Displays
Share
October 26, 2010 9:36:00 PM

All righty so when I go to start up games all is dandy until i get into the game fps hang around 30 for every game and the gpu usage goes from 30% to 70% or so , now here's the weird thingy , I alt tab out or alt enter the gpu usage goes up to high 70's through 99 , 70's though 99 is what I want of course since it boost the frames to constant 50's and 60's 60 being the vsync cap.

So my question is , is my card getting stuck in 2d clocks when i first enter games? I check msi afterburner to monitor the clocks and i believe it is skipping between 405 and 800 being my core clock , should i check for the latest video bios for the card or alter them for myself? I'm pretty sure the 2d/3d clock is the problem but I thought i'd ask the question just for more technical info in case there is more to consider.

Thanks , I appreciate all responses/suggestions.
a b U Graphics card
October 26, 2010 9:39:23 PM

What game ? All games ?
You can go in to Nvidia control panel and change power management mode from adaptive to 'prefer maximum performance' or you can do that on a per game basis under the program settings tab.
You need to reboot to force this behavior.
Score
0
October 26, 2010 9:41:40 PM

All games i've tried so far yes , and thanks i'll try that and post here in a second.
Score
0
Related resources
October 26, 2010 9:54:04 PM

Tried it and nothing changed , the gpu wont run between 80-99 percent unless I alt tab in whatever game I'm playing , the core clock still dropped to 405 when i'm on desktop but in game i've flashed back to msi afterburner to see if the clocks dropped while game and it say's that they haven't so don't have any idea why i'd have to alt tab in every game to get the gpu to run like it's suppose to.
Score
0
a c 624 U Graphics card
October 26, 2010 11:17:59 PM

You have great timing. The latest 260.99 WHQL drivers from Nvidia were released today:
"Improves Alt-Tab compatibility for several PC games." (see below). Try them out and see if they fix your issue.

NVIDIA GeForce Forceware 260.99 Win XP | 7 | Vista drivers.
Release Highlights:
This is the second WHQL release from the Release 260 family of drivers. You can read about the major new features and performance improvements in the Release 260 family of drivers here. This driver package supports GeForce 6, 7, 8, 9, 100, 200, 300, and 400-series desktop GPUs as well as ION desktop GPUs.

New in Release 260.99
Increases performance vs. v260.89 drivers in the following PC games: Civilization V (SLI), Fallout 3, Final Fantasy XIV and F1 2010 (DX11).
Adds SLI profiles for the following PC games:
Need for Speed: Hot Pursuit
Star Wars: The Force Unleashed II
Fallout: New Vegas
Improves compatibility for Fallout 3: New Vegas with antialiasing enabled.
Improves Alt-Tab compatibility for several PC games.
Score
0
October 27, 2010 12:37:03 AM

Yeah just bought the card and downloaded those yesterday as the first drivers for it :( 
It's just weird , basically I have to alt tab then alt enter to get full performance from my card , never heard anything like it before.
Score
0
October 27, 2010 1:10:57 AM

I use afterburner ^.^ and the clocks are 800/1600/2100 , 405/324 (dont know shader clock then) , and last 51/135 , also dont know shader clock

I'm new to nvidia but i did what the other guy posted to go to the control panel and under global put maximum performance and that didnt help
Score
0
October 27, 2010 1:19:36 AM

Honestly i think it might be a power supply issue if i run prime95 and kombuster at the same time kombuster gpu usage will fluctuate between 70-99 percent I'm using this psu http://www.newegg.com/Product/Product.aspx?Item=N82E168... but.. idk i've had it 2 year's and it just could not be on par anymore or if it ever was , using it with a phenom II pulling 207 watts at max according to sandra.
Score
0
a c 173 U Graphics card
October 27, 2010 3:45:32 AM

that psu should be fine. are you saying you think your getting low performance from your card? or are you just looking at gpu useage and letting yourself believe that it has anything to do with performance? for a start dont run prime 95 when using kombuster if your checking gpu useage, that will throw things out. What brand card is it? maybe there is a BIOS update you can try.
Score
0
October 27, 2010 10:37:43 AM

Ok i'll try to explain when i start up a game and begin to play the framerates stay at 30fps for any game and drop to low twenty's and the gpu usage is between 30% and 70% if and when i alt tab then alt enter the gpu usage goes up to 70-99% an frames are 45 and up, so my flashing to the desktop then flashing back to the game is telling the card to work better or something thats the only way i can figure it
Score
0
October 27, 2010 10:39:45 AM

EVGA is the brand and the bios are the latest i can find they are those "performance boost" bios , they came with the card since i just purchased it.
Score
0
October 27, 2010 1:04:02 PM

I have the same exact problem with my 460. Low gpu usage is a common problem for them, I hope it can be fixed with a driver update in the future. The worst game I've found so far is Mafia II. I was only getting like 20-30% usage and the framerate was horrible. I switched off Physx and it runs 80-90% and a solid 60 frames.
Score
0
October 27, 2010 1:11:54 PM

ooooo thanks man i'll try that
Score
0
October 27, 2010 3:13:14 PM

Unfortunately I don't think that made a difference :( 
Score
0
October 27, 2010 3:18:46 PM

Did you restart the game after you turned it off? That worked for me. And on a side note, I've noticed when I enter a 3D application it takes a couple of seconds for the card to switch to the 3D clock speeds. Every time I start a game the very first screen will be choppy for about a second and then it's okay. I really want to like the 460, but I've had nothing but problems so far. This is the second one I've had and they both act the same.
Score
0
October 27, 2010 3:31:05 PM

I've read numerous threads about the usage issue and it's a driver error, but i have the latest drivers installed so i guess i'm gonna redownload the latest drivers incase any errors happened during installation and reinstall everything see if that helps.
Score
0
October 27, 2010 3:33:26 PM

For example when i start crysis up it shows 30%-60% usage on 1980x1050 and 30fps drops to low 20's but if i hit alt enter "three times" to get it to full screen mode again the usage goes up to 70-99 percent and frames 35-55 :( 
Score
0
October 27, 2010 4:37:59 PM

Hmm I seem to have found something if i play a game in windowed mode everything is fine but unless i do the alt enter thing when the game is fullscreen i get the low gpu usage maybe i should try the 260.89 drivers
Score
0
October 27, 2010 4:45:22 PM

I'm going to have to try that, and I had the latest drivers (260.89) too before today. I'll try the new ones (260.99) later on tonight. The low usage is frustrating, but I still have hope because it puts up decent frames even with the low usage. I can't wait until they figure out a fix. I'm going to check the Nvidia forums, if anybody knows how to fix it it will probably be on there.
Score
0
a c 624 U Graphics card
October 27, 2010 5:01:28 PM

Try to do a clean install of the drivers the old fashioned way. Uninstall everything Nvidia related in the Add/Remove section of the Windows Control Panel, restart, then install the new drivers.

Then check the settings in the Nvidia Control Panel. The Adaptive Power setting should be "Prefer Maximum Performance". You should also make sure to opt for "Single Display Performance mode". It defaults to "Multiple Display Performance mode" for some reason. Make sure your game settings are set for "Full Screen" and not "Windowed" mode as well. There are probably a few other things to check that I can't think of right now.
Score
0
October 27, 2010 5:58:32 PM

Yep tried that didn't work , hey i got a picture for you and see what you think


you can see the 60% usage squiggly line then you can see the dip thats where i alt tab then you can see it get boosted to high 90's percent thats after i hit alt + enter
Score
0
October 27, 2010 5:59:52 PM

^ thats in crysis btw and you also see the minimum frame rate boost from high 20's to 30s to 47
Score
0
a b U Graphics card
October 27, 2010 6:08:53 PM

Make sure under windows power options your using the high performance profile.
Under advanced settings make sure under
PCIe link state power management is set to off

edit: One more thing to try. Right click the shortcut of whatever game/benchmark your using. Check use compatibility mode, select windows Vista SP2 and check disable desktop composition.
Score
0
October 27, 2010 6:30:33 PM

Put that to off like you said still the same thing only run's between 30% and 60% on crysis with settings at 1980x1050 high settings vsync on , UNTIL I alt tab then alt enter then usage goes up and stay's between 75-99% msi afterburner doesnt register a clock change during and after i do the alt tab/alt enter , but it has to be using a lower clock when i'm only getting the 30% - 60% of the 800 clock i have it set at and the 2d clock 405 that it defaults to when i first start up a game even though msi afterburner isnt showing it thats the only thing i can think of.
Score
0
October 27, 2010 6:32:56 PM

No option to run vista sp2 under compatibility i'm on vista 64 bit atm

Edit: tried windows xp sp2 compatibility mode and no change still same gpu usage.
Score
0

Best solution

a b U Graphics card
October 27, 2010 6:46:08 PM

Look in your bios for power saving features and try changing them. Do one thing at a time, so you can find what might work and what doesn't.
I don't have this problem. Something is obviously not waking up.
Some flag withing the gpu driver/bios/OS

Do you have it so your cpu set to 100% min / 100% max under power options.
Processor power management.
Share
October 27, 2010 6:53:22 PM

Yeah it's overclocked to 3.6 maximum frequency cool and quiet off
Score
0
October 27, 2010 6:55:35 PM

Is it worth noting that upon installing the driver package that the first game i pull up and alt tab out of makes the desktop screen resolution 800x600 and i have to reset it to 1980x1050 also here's a horrendous drawing of what it looks like after the first time i alt tab out of a game after installing the driver package

Score
0
October 27, 2010 6:57:28 PM

I'll go snoop in bios for a second and see what i find then come and see if you have any new suggestion's , thanks for your help btw.

Edit: didnt see anything in bios.
Score
0
October 27, 2010 7:31:19 PM

Playing in windowed mode seems to work perfect then i alt enter for fullscreen and everything's fine but still i shouldn't have to do that so like you say something isnt registering somewhere at the initial start.
Score
0
October 27, 2010 10:54:46 PM

Update tried 260.89 drivers didn't make a difference.
Score
0
a c 173 U Graphics card
October 28, 2010 3:36:06 AM

have you tried playing around with "max pre-rendered frames" setting? Also turn v-sync off to see what happens. It kinda sounds like you being capped to the 30fps vsync and then alt tabbing/alt enter is overriding it to no vsync.
Score
0
October 28, 2010 12:52:59 PM

Tried the rendered frames setting messing around with nothing changed , about the vsyn being 30 there might be some truth to that but why would the usage go to like 30% during lot of activity and drop to 18 fps where if i alt enter get the 90 percent usage they never drop lower than like 28fps and average 45 how do you overide the 2d clocks you gotta use nibitor? Cause thats the only thing left that i can think to try to change
Score
0
October 28, 2010 7:24:58 PM

Try the 260.99 beta drivers, I got a noticeable performance increase from them over 260.89.
Score
0
October 28, 2010 7:47:45 PM

Yeah i've been using the 260.99 drivers since they were released on nvidia main site.
Score
0
November 7, 2010 6:19:10 PM

Best answer selected by im_thinking1.
Score
0
a c 272 U Graphics card
November 7, 2010 6:24:52 PM

This topic has been closed by Mousemonkey
Score
0
!