Sign in with
Sign up | Sign in
Your question

My computer won't POST, and I'm fairly certain it's the motherboard.

Last response: in Systems
Share
December 25, 2010 10:43:51 PM

Backstory: Up until about 10 AM this morning, my computer was working fine with the follow specs...

-AMD Phenom II X4 955 @ 3.2 gHz w/ stock cooling
-4x2 gig G.Skill Ram @ 1600 mHz
-XFX ATI Radeon 5770 @ whatever the default is
-ASUS M4A785T-M motherboard
-Some Western Digital hard drive
-Some cheap CD drive
-RAIDMAX 630w PSU

My computer, to the year, is almost a year old. For Christmas this year, I was lucky enough to receive the Corsair H70 liquid cooling system from my parents, and I was very excited to put it to work right away. So, I opened up my computer, and took the opportunity to organize my wires and such which really weren't organized at all before. Then, over the course of an hour, I very carefully removed the old stock cooling system, used rubbing alcohol and a lint-free microfiber cloth to remove the old thermal paste, and installed the my new Corsair H70 liquid cooling system, and...nothing. The computer turns on, but it doesn't POST, and nothing happens. The fans spin, and when I hit the eject button on the CD drive it pops out a little bit before automatically going back in. Anyway, there were no pops, or clicks, or bangs, or any clouds of smoke. It just...didn't work and didn't POST.

So, I checked all the connections, reseated everything, and even replaced the SATA cables with some newer ones I had lying around. Still, it didn't work. At this point I was very frustrated, and reseated the CPU and processor (even replacing the thermal paste) - still, it didn't work.

So, being the meticulous little nerd I am, I took apart the whole PC and rebuilt it. Nothing. Oh, and this was after resetting the CMOS, letting it sit for 20 minutes with the RAM out and the PSU turned off - basically, I tried every solution that I found via Google. Anyway, even after rebuilding it completely, it didn't work. Each individual part seems to work fine, but it's just that the computer won't POST. My theory is that I somehow damaged the motherboard, despite being grounded the whole time to prevent static electrical sparks and being almost completely certain that I caused no damage to the motherboard itself.

Actually, my first thought was that it could be the processor, and that I had forgotten to power the cooling, thus causing the processor to overheat and fry itself seconds after turning it on to test. But, nope, that was plugged in and working fine. Oh yes, and it's not the liquid in the cooling system itself, as none of it has leaked out.

So, is there anything else I could try? Or can I be certain that it's the motherboard, and go out to tomorrow to buy a new one, assuming that I damaged it while installing the H70 cooling system?

Thanks in advance for any help I receive!
a b B Homebuilt system
December 25, 2010 11:05:19 PM

Reinstall the stock heatsink/fan, disconnect everything (all CCA, video included, ribbons, molexes, SATA lines) but the cpu, one stick of RAM....if the comp can turn on , it should detect that no video adapter is present, and beep according to your BIOS...

Have another PSU you can try as well? (the fact that the DVD drive won't even open fully says something is amiss with power, but, is certainly possible your MB is also shorting the power...)
m
0
l
a b B Homebuilt system
December 25, 2010 11:53:34 PM

I would also be suspicious of the power supply, try substituting it if possible.
m
0
l
Related resources
December 25, 2010 11:56:06 PM

I'm going to try the power supply - what would make you suspicious of this fact?
m
0
l
December 26, 2010 12:37:55 AM

Ok, I tried it with another power supply - same thing. Pretty sure it's the motherboard, then.
m
0
l
December 26, 2010 4:44:49 AM

did you use a ESD wrist strap when opening your case?

i know alot of people dont, i dont alot of times.
but all it takes is one time for ESD to destroy somehting :( 
i destroyed a mobo by failing to use a strap/mat.
and it did the same thing you are describing


m
0
l
December 26, 2010 12:47:06 PM

No, I didn't, but I'm fairly certain I was grounded. But, then again, I was fairly certain that it was going to work. I guess I've learned my lesson today...
m
0
l
!