Sign in with
Sign up | Sign in
Your question

Games stop working! Big issue

Last response: in Graphics & Displays
Share
October 27, 2010 11:58:37 AM

Hello forum.

I just got a new Powercolor 5870 after having RMA'd my old one. Problem is, I still get the same error as I did before.

Well, as the headline says, games stop working. Lately I've been playing Mafia 2 and the crash usually occurs after about 15-20mins of gameplay or something like that. The crash occurs at random places in the game and often with a short weird sound.. But now after I've got a new card and the problem still persists, I am starting to belive this doesn't have anything to do with my graphic card. Might be a driver issue? or some other component in my computer that is causing this. I'm not sure!

If nothing will help I guess I will just RMA this one aswell and choose another 5870 brand or just try Nvidia.

Anyhow, here's my specs:
Gigabyte 770 mobo
Amd phenom 945 x4 3,3~ Ghz
Powercolor 5870 FACTORY OC (875/1225-OC might be causing the problem??)
Crucial DDR3 ram 4gigs 1333MHz
Corsair TX 650watts

Lastly, I found this message in the event viewer:
Faulting application name: mafia2.exe, version: 1.0.0.1, time stampe: 0x4c6d595d
Faulting module name: mafia2.exe, version 1.0.0.1, time stamp: 0x4c6d595d
Exception code: 0xc0000005
Fault offset: 0x00251acf
Faulting process id: 0xa48
Faulting application start time: 0x01cb75cdd3d3f50d
Faulting application path: C:\Program Files (x86)\2K Games\Mafia II}\pc\mafia2.exe
Fault module path: C:\Program Files (x86)\2K Games\Mafia II\pc\mafia2.exe
Report Id: 84fb5b57-e1c6-11df-a4fe-00241d8dbad2

Thanks for any help!
October 27, 2010 12:12:05 PM

Could you do a memtest on the RAM's and see if there are any errors there.
October 27, 2010 12:21:40 PM

Should I download memtest86? Never done a memtest before.
Related resources
October 27, 2010 12:40:31 PM

Downloaded and running some free memtest for windows now.
October 27, 2010 12:42:15 PM

If you do get some errors let us know.
October 27, 2010 12:44:07 PM

Sure, the program said something about several memtest should be run for multicore cpu's, didn't really understand though, am I supposed to open 4 memtest because I have a quadcore?
October 27, 2010 12:46:44 PM

memtest tests you memory (RAM's). If your RAM's are causing a problem it would let you know.
October 27, 2010 3:55:54 PM

Okay I've been running this memtest for like 5 hours now, guess that should be enough! But no errors found :( 
October 27, 2010 6:56:27 PM

By the way, after the games crash I see weird colours on some stuff, for example, when I open internet explorer I can just see the sidebars and stuff. The webpages are all just weird colours and can't see nothing.
October 29, 2010 7:14:22 PM

Any suggestions on what it could be?
October 29, 2010 7:36:35 PM

What are your temps ?
I have read people had trouble with stability with this card.
I would down clock it a little bit and try a gaming session, see what happens.
You can even use ccc
try 825/1100
The funny colors could be gpu memory issues.
October 29, 2010 8:29:03 PM

I agree with Notty, this sounds like video memory errors, use CCC (catalyst control center from ATI) to declock your video cards memory to below stock speeds by a couple % as notty suggested.
If the system returns to normal colors after a reboot and games play properly for a short period of time it may be heat or your power supply thats cuasing the issues as well, although I have had great experiances with the corsairs, so I would check temp's first.
October 29, 2010 10:27:06 PM

Alright. Thanks for the info, I'll try to lower the clocks as soon as I can.
I doubt the card is getting too hot, it stays around 50 at load. Could it be the CPU? I have overclocked it, no voltage tweaks though, so maybe not.

Anyways, could it be possible I get 2 faulty card in a row? Is Powercolor a crap manafacturer or something?
The power supply might be the problem.. But on the other hand I don't know much about power supplies so who knows. I just know that the power supply is powerful enough for my pc.
October 29, 2010 10:37:20 PM

There are other issues with the 5 series and memory. The 5850's use the same memory as in this card and its clocked at 1000mhz. They are rated for 1250mhz, they also get hot and have no heat sinks.
What your describing sounds like classic memory artifacts.
Lower the memory speeds especially and test.
Thats what I think it is.
October 29, 2010 10:43:58 PM

Just ran mafia 2 with 825/1100 and everything froze up with weird sounds and i ctrl alt del, then mafia2 has stopped working. :S
October 30, 2010 2:56:45 AM

"Could it be the CPU? I have overclocked it"

I see you don't have a BE cpu. If you overclocked your CPU by increasing your FSB you have also overclocked your video card, which has already been factory overclocked. Remove your overclock settings and see if you are still having the same symptoms.

If this allows you to play mafia 2 then you will need to modify your pcie bootstrap value to return the video card to its original clocks.

Good luck and let us know how things go.
October 30, 2010 3:39:57 AM

yep, when you raise the fsb a lot of other things go up too, including the PCIE bus and the memories, you have to lower the multipliers on other stuff till you get as close as possible to stock clocks
October 30, 2010 9:50:46 AM

Should I move the FSB down to 200 again?
October 30, 2010 5:18:32 PM

yes you should, just for troubleshooting purposes you should reset the bios to it's default settings
October 30, 2010 5:21:45 PM

How do you reset it?
October 30, 2010 5:30:27 PM

when pressing del. at startup and entering the bios you should see a list of shortcuts with several functions, there should be a "reset defaults" one, they're most commonly located at the bottom of the screen
October 30, 2010 5:34:01 PM

Amd phenom ii x4 945 is not meant for overclocking purposes, although you can overclock it a bit, but at your own risk and why there is any need of overclocking graphics card, it(5870) is an overkill for any game that exist on the planet. BTW, is it happening with mafia 2 only? If yes, then game is itself faulty, try reinstalling and if problem still remains, get a new copy of the game.......and also which mobo you have???
Is it this one
http://indonesia.test.giga-byte.com/Products/Motherboar...

which os you have??? I doubt if it is xp.
Also, update all your drivers and clean your cpu cabinet, make sure there are no viruses and registry errors, also reply me regarding mobo and os question, so that we can have correct idea of your pc.
If problem still persists than contact your pc dealer, nywayz, just one reply and we users can help you solve your problem.
If possible, then upload the screen shot of the error and the problems which you are facing.

October 30, 2010 5:41:10 PM

his 5870 is factory OC'd and he didn't do it himself.

October 30, 2010 5:45:46 PM

@ wiinippongamer oh sorry, I didn't read that
October 30, 2010 6:48:52 PM

Have now loaded optimized defaults in BIOS! Will test if it still crashes soon, also checked if the clocks really had changed in CPUZ.

@ATi RaDEoN
First of all, on this card the only game I've experienced crashing is Mafia 2, however, I don't really have any other games to try atm since I haven't any others installed. But if I would try other games I belive they would crash aswell (maybe not all), because my last card, which replaced the one I have now (might not be the graphic card that is the problem again), I had the same problem on that. Same crashes, same after-effects, etc, which gives me reason to belive that the card I have now would do the same! My old gpu crashed in games like Just Cause 2, NBA 2K10, DiRT 2, and Mafia 2 of course.

Here is the full name of my motherboard: Gigabyte GA-MA770T-UD3P AM3 socket
Windows 7 Ultimate OS

Already checked for viruses and such, guess I could try removing drivers and installing new.
October 31, 2010 3:24:08 AM

@ joeses
Which was your old gpu???
Was the error same in old as well as in new gpu crashes???
October 31, 2010 4:16:40 AM

ATi RaDEoN said:
@ joeses
Which was your old gpu???
Was the error same in old as well as in new gpu crashes???



Quote:
I just got a new Powercolor 5870 after having RMA'd my old one. Problem is, I still get the same error as I did before.

!