Sign in with
Sign up | Sign in
Your question

P8P67 PRO HDD not detected

Last response: in Motherboards
Share
November 27, 2011 9:51:52 AM

Recently I've built a desktop pc from the following components:
* CPU: Intel Core i7 2600K (brand new)
* Video card: Gainward/Nvidia GeForce 7600GS (note: this is my old card, used, because the new one will be available later - then I'll replace them)
* PSU: Corsair GS800 (brand new)
* RAM: Corsair 2x CMZ8GX3M2A1600C9 (brand new)
* Moterboard: Asus P8P67 PRO 3.1 (brand new)
* Some USB Mouse and Keyboard (used in the old pc)

This set works without problems, allowing me to access the uefi bios. The keyboard works there, as is the mouse. The PC also boots without problems from a usb flash-drive with puppy linux.

Now the problem is with sata. When I (with the power turned off) connect a sata2 WD2500KS (note: I know it's old, I'll be buying some new disk in a few days) disk to the Intel 3.0Gb/s ports (I've tried all 4), connect sata power plug to this disk, and then start the PC, i see "No Hard Disk detected" or something similar on the screen for a second, and then I get to a splash screen with Asus logo and this text: "Press Del to enter bios setup" or something like that. Pressing Del on the keyboard doesn't work, nor CtrL+Alt+Del or F1. It looks as if it hung. I'm sure the hard disk and the sata cable e both good because both worked in my old PC before connecting the HDD to the new motherboard and after (I've checked after to be sure that the disk won't broken during installation).

I can access the bios setup only when I disconnect the disk. In there I've tried setting sata ports to ide instead of ahci, setting compatibility mode, nothing works. I've loaded optimized defaults, reseted bios with a jumper on the motherboard. Didn't help. I've updated the bios to the latest version (v. 2001), rebooted and loaded optimized defaults. Also didn't help.

So I ask you for help. I would be very glad if it's just something set wrong in the bios or the disk is maybe incompatible. If the motherboard is really defective, and I need to RMA it, it's bad, because I need this PC now, not in a month.

Thanks in advance for any help.

More about : p8p67 pro hdd detected

November 27, 2011 10:17:24 AM

The wd2500ks is the only sata device connected. No other HDDs. No optical disc drives (I'll buy one later). I think I've tried disabling the splash screen. I'll try another time tonight.

I forgot to mention, that when the HDD is plugged in and I start the PC, I can hear it starting, spinning, moving the head, parking the head, so it's working and doing "something".

I have an additional question, which maybe would help me: this motherboard has four sata 3 (6Gb/s) connectors. Can I use these with a sata2 HDD?
November 29, 2011 7:00:14 PM

I have some updates. I've tested two other drives which I've borrowed. Both are Seagate sata2 drives, and both work with this motherboard.
Also, my WD drive works, if I boot the pc without it attached and then hot-plug it - then it's detected.

Any clues? I'm thinking about rmaing it. But it doesn't have sense if this is a problem with this all p8p67pro's.
Its sick that this mb doesn't work with some drives. I have a last resort question. Does some one have it working with WD Caviar Black WD5002AALX or similar model?
Maybe someone could suggest me another motherboard (Gigabyte for example) with similar price and capabilities? One, which would have no such surprises.
!