Sign in with
Sign up | Sign in
Your question

Windows 7 Laptop, Connects to router, BUT NO internet

Last response: in Wireless Networking
Share
September 7, 2010 3:52:35 PM

Hi, people. I could really use some help. i have tried many things to try to restore internet connectivity. it's an eMachines laptop that has Windows 7 Home Premium. It worked great with internet for the longest time and then BAMM, it stopped working (connecting to internet). it's driven me nuts, i have tried many things.
Anonymous
a b D Laptop
a b $ Windows 7
September 7, 2010 7:44:13 PM

Check TCP/IP Properties.

Start, Connect To, Connection, Properties, Scroll Down TCP/IP and highlight, click Properties and check that Obtain DNS and IP address automatically are enabled.
m
0
l
September 8, 2010 2:55:14 AM

Quote:
Check TCP/IP Properties.

Start, Connect To, Connection, Properties, Scroll Down TCP/IP and highlight, click Properties and check that Obtain DNS and IP address automatically are enabled.


Yes of course all that has been checked and rechecked. i have done SO many things it is brutal.
everything from resetting IP stuff to winsock, disabling/enabling, checking drivers, etc etc., eliminating firewalls, ....

i will say this - that with the DNS and IP checked for 'automatic' detection, i had a yellow triangle with an exclamation point over it. but when i put in
4.2.2.1 and 4.2.2.2 into the DNS, the yellow triangle went away. But I still cant get internet.

I am not happy with this at all. ANYTHING? should I upgrade to Windows 7 Professional? I am considering it - ........

thank you for responding and any help from anyone............
m
0
l
September 8, 2010 3:00:50 AM

I was getting internet GREAT - whether at home or at a public hotspot. But then POOF, i cant get it anymore on this laptop. Incidentally, other devices including 2 other computers, an IPOD Touch, a Wii, can all get internet FINE at home - but NOT this Windows 7 Notebook computer.

WHEN IS MICROSOFT going to release a service pack for Windows 7?
m
0
l
Related resources
!