Sign in with
Sign up | Sign in
Your question

display-driver-install-fail

Last response: in Graphics & Displays
Share
October 30, 2010 3:43:38 PM

Hello I am having a problem trying to update my ati driver from 10.8 to 10.10 mainly so a can play force unleashed 2 .Everytime I go to the ati driver update site I install everything but it says that my intial report "ATI display driver - fail" and and audio driver -fail" ? for some reason I cant seem to update pass 10.8 I have even tried to update to 10.9 but it just wont update any further
All of my pc drivers are up to date and fine I just cant seem to figure this out .

I am using a ati radeon HD 2900 xt


Windows 7 ultimate

asus p5b -premium

intel core 2 quad q6600 2.40GHz

ddr2 4 gig ram

ati HD2900xt
October 31, 2010 6:07:00 AM

This seems to be a problem with the recent ATI drivers. I have the same problem for both of my cards, HD5770 and HD3850 AGP.

What I do is, I open Device Manager, expand Display Adapter, open properties of the display adapter and click update driver.

When you try to open the Ati driver package (the big exe file), it first expands to %SystemDrive%\ , usually C:\ATI\Support\name of the package.

Now you should point to C:\ATI\Support\name of the package\Packages\Drivers\Display\W76A_INF when you click Update driver in Device Manager.

This will only install the driver portion. After restart you should click the big exe file you downloaded from Ati to install the control center.
m
0
l
November 1, 2010 11:39:59 AM

suat said:
This seems to be a problem with the recent ATI drivers. I have the same problem for both of my cards, HD5770 and HD3850 AGP.

What I do is, I open Device Manager, expand Display Adapter, open properties of the display adapter and click update driver.

When you try to open the Ati driver package (the big exe file), it first expands to %SystemDrive%\ , usually C:\ATI\Support\name of the package.

Now you should point to C:\ATI\Support\name of the package\Packages\Drivers\Display\W76A_INF when you click Update driver in Device Manager.

This will only install the driver portion. After restart you should click the big exe file you downloaded from Ati to install the control center.



Hey tnx for the time and advice .

I tried what you suggested and I am still having no joy :(  Was wondering if a fresh OS install might work? just download driver 10.10 from factory settings ?
m
0
l
November 1, 2010 12:53:09 PM

Before trying a fresh OS install - go into the control panel and create a new user account with admin privileges, log in to that account, and see if you can install it from there. It could perhaps be something running in the background on your computer, messing with things...

Also, beware of Windows Updates - they will try to "update" your ATI driver to older versions..
m
0
l
November 2, 2010 5:46:31 PM

PV9685 said:
Before trying a fresh OS install - go into the control panel and create a new user account with admin privileges, log in to that account, and see if you can install it from there. It could perhaps be something running in the background on your computer, messing with things...

Also, beware of Windows Updates - they will try to "update" your ATI driver to older versions..



No unfortunatly this didn't work either but tnx
m
0
l
!