Sign in with
Sign up | Sign in
Your question

Realtek HD Audio installed but no sound

Last response: in Motherboards
Share
November 29, 2011 12:21:12 PM

I am hoping that someone here will be able to help me. I have read a lot of post regarding realtek and windows 7 and have not been able to 1) solve the no sound issue, but 2) i have now managed to get sound manager to register a headphone and mic when nothing is plugged into the front jacks.

Here are the computer and card specs

OS- Windows 7 Ultimate service pack 1
Manufacturer- MSI
Processor- AMD Phenom II X3 705e Processor 2.50 GHz
Ram- 6.00GB
System Type- 64-bit OS

Sound Card Realtek HD Audio
Driver- 6.0.1.6449
Direct X version 11.0
Audio controller HD Audio
Audio Codec ALC892

This was a system that me and a friend built and I'm certain everything is plugged in and in the right spots. I have uninstalled both driver and hardware and reinstalled. I have disabled front jack detection, and also have set front and rear jacks to play audio simultaneously. I have tried almost everything I have found and or know on my own to no avail.

As stated above I have working speakers plugged into the analog output on the rear of computer, I have nothing plugged into the front jacks however realtek seems to think I do. When I run a sound test I see the eq lighting up but hear nothing.

Has anyone here had the same issue or anyone have any ideas how to remedy this?

More about : realtek audio installed sound

a b V Motherboard
November 29, 2011 1:56:20 PM

So, you plugged the front jacks into the mobo, yes? Did you make sure to use the right plug both in terms of on the mobo itself as well as the AC'97 or HD Audio from the case?

Anyway, if the sound is working fine from the back panel, I wouldn't worry about it thinking there might be something plugged into the front... Do those jacks work if you actually do plug something in?

Also, check out your audio settings in Windows instead of using the Realtek thing. In your tray tools (near the clock) there should be a speaker icon. Select it and go to Playback Devices and make sure the proper one is selected.
m
0
l
November 29, 2011 5:29:29 PM

Thanks for the response,

Everything looks good as far as it being plugged in.

As far as sound there is no sound at all from either ports. The rear jack detects the speakers when they are plugged in and out but no sound is being played through them. They are good speakers as I have tested them on another computer.

The speakers are set up under both windows and realtek as the default sound device.
m
0
l
Related resources
a b V Motherboard
November 29, 2011 5:51:20 PM

You might need to update your chipset drivers. I guess AMD would have them, I've only really worked on Intel boards. But basically from the Intel site I can find the most recent drivers for all chipset related stuff from USB to Audio.
m
0
l
a c 148 V Motherboard
November 29, 2011 6:01:12 PM

What video card do you have? If it has HDMI, make sure it is not set as your default sound device.
m
0
l
November 29, 2011 7:23:24 PM

downloading new chipset drivers I will let you know how that goes.

HDMI is not set as default, but thanks made me hope that it was.

m
0
l
a b V Motherboard
November 30, 2011 12:59:09 AM

Speaking of video card audio - personally, when I install my video drivers/updates, I always choose custom and deselect the audio driver so that there's definitely not going to be interference. Same goes for the chipset audio, actually, since I have a sound card :) 
m
0
l
July 15, 2012 4:31:30 PM

hi, just wanted to know - did any one found a solution for this problem??? seems that nothing works. I've updated sound drivers, chipset, even windows update - nothing worked.

help PLZ!!!
m
0
l
a b V Motherboard
July 20, 2012 6:34:58 PM

Similar problem, but my audio works through hdmi monitor.
m
0
l
a b V Motherboard
July 20, 2012 10:42:27 PM

You use the green jack for speakers to monitor speakers.
m
0
l
October 22, 2012 8:36:34 PM

Solved it!

There is a small folder-like icon in the top-right area (near the 'Advanced Options' and 'ANALOG').

Clicking this folder-icon opens a small dialog with two check-boxes:
make sure the first check-box ("Disable ... detection") is checked -
this causes both front and rear jacks to work, without the system trying to figure-out if the front jack is used or not.

Good luck!
m
0
l
October 12, 2013 2:43:22 PM

goneng said:
Solved it!

There is a small folder-like icon in the top-right area (near the 'Advanced Options' and 'ANALOG').

Clicking this folder-icon opens a small dialog with two check-boxes:
make sure the first check-box ("Disable ... detection") is checked -
this causes both front and rear jacks to work, without the system trying to figure-out if the front jack is used or not.

Good luck!


Dude!!!! You are awesome! Now I can play my speakers connected to my receiver (back jack) and my speakers in the office (front jack) at the same time! I kept switching back in forth making each device the default, this works so much better.

Thanks!
m
0
l
November 27, 2013 10:22:25 AM

goneng said:
Solved it!

There is a small folder-like icon in the top-right area (near the 'Advanced Options' and 'ANALOG').

Clicking this folder-icon opens a small dialog with two check-boxes:
make sure the first check-box ("Disable ... detection") is checked -
this causes both front and rear jacks to work, without the system trying to figure-out if the front jack is used or not.

Good luck!



I feel like I missed something. Where exactly do I go to see this folder icon?
m
0
l
November 28, 2013 9:08:36 PM

It is above "ANALOG" and below "Device advanced settings" up in the upper right hand corner.

goneng: THANK YOU THANK YOU THANK YOU!!! YESSSSSSSSSS this is exactly what I needed. Whew. You are a saint!

ChrischinLoois said:
goneng said:
Solved it!

There is a small folder-like icon in the top-right area (near the 'Advanced Options' and 'ANALOG').

Clicking this folder-icon opens a small dialog with two check-boxes:
make sure the first check-box ("Disable ... detection") is checked -
this causes both front and rear jacks to work, without the system trying to figure-out if the front jack is used or not.

Good luck!



I feel like I missed something. Where exactly do I go to see this folder icon?


m
0
l
February 3, 2014 9:07:14 AM

goneng said:
Solved it!

There is a small folder-like icon in the top-right area (near the 'Advanced Options' and 'ANALOG').

Clicking this folder-icon opens a small dialog with two check-boxes:
make sure the first check-box ("Disable ... detection") is checked -
this causes both front and rear jacks to work, without the system trying to figure-out if the front jack is used or not.

Good luck!


Thanks a lot!, My desktop had the same problem and after a week of troubleshoothing i gave up. This was 1 year ago.
Seems that the chip fails to detect the if something is plugged so it doesn't send sound at all. This is a workaround.
I needed some space and i was going to throw my desktop away. Now i can use it again :p 

m
0
l
February 23, 2014 8:42:52 PM

blahnobody said:
It is above "ANALOG" and below "Device advanced settings" up in the upper right hand corner.

goneng: THANK YOU THANK YOU THANK YOU!!! YESSSSSSSSSS this is exactly what I needed. Whew. You are a saint!

ChrischinLoois said:
goneng said:
Solved it!

There is a small folder-like icon in the top-right area (near the 'Advanced Options' and 'ANALOG').

Clicking this folder-icon opens a small dialog with two check-boxes:
make sure the first check-box ("Disable ... detection") is checked -
this causes both front and rear jacks to work, without the system trying to figure-out if the front jack is used or not.

Good luck!



I feel like I missed something. Where exactly do I go to see this folder icon?




where though!? I cannot find any area with "device advanced settings" and ANALOG" even in it! not sure where I'm supposed to be looking...
m
0
l
April 13, 2014 9:30:29 AM

click the YELLOW folder BETWEEN device advance settings and analog ................................... there lies the disable detection box...

gfed0049 said:
blahnobody said:
It is above "ANALOG" and below "Device advanced settings" up in the upper right hand corner.

goneng: THANK YOU THANK YOU THANK YOU!!! YESSSSSSSSSS this is exactly what I needed. Whew. You are a saint!

ChrischinLoois said:
goneng said:
Solved it!

There is a small folder-like icon in the top-right area (near the 'Advanced Options' and 'ANALOG').

Clicking this folder-icon opens a small dialog with two check-boxes:
make sure the first check-box ("Disable ... detection") is checked -
this causes both front and rear jacks to work, without the system trying to figure-out if the front jack is used or not.

Good luck!



I feel like I missed something. Where exactly do I go to see this folder icon?




where though!? I cannot find any area with "device advanced settings" and ANALOG" even in it! not sure where I'm supposed to be looking...


m
0
l
May 4, 2014 7:19:33 PM

jainpa said:
click the YELLOW folder BETWEEN device advance settings and analog ................................... there lies the disable detection box...

gfed0049 said:
blahnobody said:
It is above "ANALOG" and below "Device advanced settings" up in the upper right hand corner.

goneng: THANK YOU THANK YOU THANK YOU!!! YESSSSSSSSSS this is exactly what I needed. Whew. You are a saint!

ChrischinLoois said:
goneng said:
Solved it!

There is a small folder-like icon in the top-right area (near the 'Advanced Options' and 'ANALOG').

Clicking this folder-icon opens a small dialog with two check-boxes:
make sure the first check-box ("Disable ... detection") is checked -
this causes both front and rear jacks to work, without the system trying to figure-out if the front jack is used or not.

Good luck!



I feel like I missed something. Where exactly do I go to see this folder icon?




where though!? I cannot find any area with "device advanced settings" and ANALOG" even in it! not sure where I'm supposed to be looking...




Open the Control Panel, go to Realtek HD Audio Manager and if it has been updated you should see a little wrench in a box in the bottom right corner. Click this and inside there check the box next to "Disable front panel jack detection"

m
0
l
May 14, 2014 9:03:10 PM

goneng said:
Solved it!

There is a small folder-like icon in the top-right area (near the 'Advanced Options' and 'ANALOG').

Clicking this folder-icon opens a small dialog with two check-boxes:
make sure the first check-box ("Disable ... detection") is checked -
this causes both front and rear jacks to work, without the system trying to figure-out if the front jack is used or not.

Good luck!


m
0
l
May 14, 2014 9:26:21 PM

Similar problem. External speakers work with Win XP but not Win 7 Pro 64 Bit. Using latest Realtek drivers. Unfortunately disabling front jack detection had no affect. I also tried changing "device advanced settings", no help, changed them back. OS "sound manager" and Realtek sound manager shows speakers plugged in, drivers up to date, "device working properly", volume 100%, not muted, etc. I've spent many hours installing, uninstalling, and reinstalling drivers (through Microsoft, Realtek, Biostar, AMD, etc.). Sound manager "animated icon" shows speakers working. Everything "looks" correct but still no sound. Any suggestion would be greatly appreciated.
Thanks
m
0
l
June 18, 2014 3:58:27 AM

I still cannot get this to work. I've tried reinstalling drivers, disabling, enabling, scouring device manager, stalking forums online, yelling at it and even praying to the IT gods.

Everything "looks" fine. I'm in the same boat as Chosey6. Followed the bouncing ball to no avail.


m
0
l
June 18, 2014 9:14:29 AM

I finally got my speakers to work. I changed the Realtek sound manager "speaker configuration" setting from "stereo" to "5.1".
Hope this helps.

m
0
l
July 5, 2014 5:01:55 PM

Oh lord, I have had the same problem ever since I built my system 5 days ago. I have tried so many times that I am confused beyound measure. I disabled the AMD HDMI Audio device from my R9 270x (my system is https://pcpartpicker.com/user/bloodflood/saved/yQNv6h), checked that audio is enabled in BIOS, reinstalled every driver, checked with two different headsets, checked the front panel jack detection box in Realtek HD Audio, tried plugging both headsets in the front and back ports and nothing works. The equaliser shows sound but there is none. This is devastating because to try for a refund on the MBoard I need to travel a thousand kilometers and spend a decent amount of money which I would really prefer not to do. None of the solutions from this thread helped yet, maybe somebody has a fresh idea?
m
0
l
August 2, 2014 9:40:54 AM

So i was having this exact issue, my analog audio output just stopped working when i installed the r7 260x, i tried everything drivers, realtek chipset default audio devices etc. and my realtek is different than that in the picture and does not have that folder but does have an option to disable port detection or whatever. didnt work.


so yesterday i took my mobo into the computer store because thank god i got the 3 year warranty on the thing. Now im waiting to see what the problem was? If they fix my motherboard or they give me a new one im not sure? Im not even sure if this is going to be under the warranty? Will i have to pay them money for this repair? we will find out.....


EDIT:

i also tried going in a trading in the gfx card for a different one, i actually went up to the club3d r9 270, still the same problem....

it started when i put the 260x in and hooked it up to hmdi right off the bat, then i hooked back up my dvi to vga monitor, and tried my headset and speakers, nothing..... I then started dickng with the bios and OS, i ended up reinstalling windows fresh, formatting both harddrives and starting over from fresh. Still nothing. I got on the line with asus tech support and they told me oh the audio ports could be grounded, take the mobo out of the case and run the pc on a peice of cardboard. so i did. Still nothing.......

that was before i took the mobo into the store yesterday
m
0
l
August 2, 2014 9:45:09 AM

BloodFlood said:
Oh lord, I have had the same problem ever since I built my system 5 days ago. I have tried so many times that I am confused beyound measure. I disabled the AMD HDMI Audio device from my R9 270x (my system is https://pcpartpicker.com/user/bloodflood/saved/yQNv6h), checked that audio is enabled in BIOS, reinstalled every driver, checked with two different headsets, checked the front panel jack detection box in Realtek HD Audio, tried plugging both headsets in the front and back ports and nothing works. The equaliser shows sound but there is none. This is devastating because to try for a refund on the MBoard I need to travel a thousand kilometers and spend a decent amount of money which I would really prefer not to do. None of the solutions from this thread helped yet, maybe somebody has a fresh idea?




yeah my audio issues started with the R series graphics cards aswell, i wonder if this has anything to do with each other?

m
0
l
August 22, 2014 3:38:35 PM

AdrianMacG said:
So i was having this exact issue, my analog audio output just stopped working when i installed the r7 260x, i tried everything drivers, realtek chipset default audio devices etc. and my realtek is different than that in the picture and does not have that folder but does have an option to disable port detection or whatever. didnt work.


so yesterday i took my mobo into the computer store because thank god i got the 3 year warranty on the thing. Now im waiting to see what the problem was? If they fix my motherboard or they give me a new one im not sure? Im not even sure if this is going to be under the warranty? Will i have to pay them money for this repair? we will find out.....


EDIT:

i also tried going in a trading in the gfx card for a different one, i actually went up to the club3d r9 270, still the same problem....

it started when i put the 260x in and hooked it up to hmdi right off the bat, then i hooked back up my dvi to vga monitor, and tried my headset and speakers, nothing..... I then started dickng with the bios and OS, i ended up reinstalling windows fresh, formatting both harddrives and starting over from fresh. Still nothing. I got on the line with asus tech support and they told me oh the audio ports could be grounded, take the mobo out of the case and run the pc on a peice of cardboard. so i did. Still nothing.......

that was before i took the mobo into the store yesterday


Is there any chance that you are from Norway and have a "Komplett-PC"?
m
0
l
August 23, 2014 8:16:42 AM

AdrianMacG said:
So i was having this exact issue, my analog audio output just stopped working when i installed the r7 260x, i tried everything drivers, realtek chipset default audio devices etc. and my realtek is different than that in the picture and does not have that folder but does have an option to disable port detection or whatever. didnt work.


so yesterday i took my mobo into the computer store because thank god i got the 3 year warranty on the thing. Now im waiting to see what the problem was? If they fix my motherboard or they give me a new one im not sure? Im not even sure if this is going to be under the warranty? Will i have to pay them money for this repair? we will find out.....


EDIT:

i also tried going in a trading in the gfx card for a different one, i actually went up to the club3d r9 270, still the same problem....

it started when i put the 260x in and hooked it up to hmdi right off the bat, then i hooked back up my dvi to vga monitor, and tried my headset and speakers, nothing..... I then started dickng with the bios and OS, i ended up reinstalling windows fresh, formatting both harddrives and starting over from fresh. Still nothing. I got on the line with asus tech support and they told me oh the audio ports could be grounded, take the mobo out of the case and run the pc on a peice of cardboard. so i did. Still nothing.......

that was before i took the mobo into the store yesterday


I have a Gigabyte Z87 D3HP and when I installed an XFX Radeon R9 290 and then decided I didn't want to keep it and took it out again I have no sound. I originally had linux and then I swapped over to windows - all legit - and the same thing is happening with no sound output but the system identifies when I plug in an audio device - even front audio - but there is no sound actually output.

Speakers work, audio drivers switched tons of times, even a fresh operating system didn't work, so I tried flashing my bios. This did nothing to solve the problem.

Does anyone have any ideas?
m
0
l
August 26, 2014 9:38:46 PM

I just installed the R9270x and I have the same problem :( 
Did you manage to fix it?
m
0
l
September 3, 2014 8:20:21 AM

having a similar problem i'm using r9 280 i grt sound through head phone jacks but only system sounds no audio with games or youtube try'd a multitude of things listed here before even coming here any one got a solution let me know gona try giving it to my local pc repair shop to have a look at
m
0
l
September 6, 2014 12:36:26 PM

goneng said:
Solved it!

There is a small folder-like icon in the top-right area (near the 'Advanced Options' and 'ANALOG').

Clicking this folder-icon opens a small dialog with two check-boxes:
make sure the first check-box ("Disable ... detection") is checked -
this causes both front and rear jacks to work, without the system trying to figure-out if the front jack is used or not.

Good luck!


I've been trying to figure this out for months, first the front jack stopped playing and eventually the rear jack decided to quit too. I could only get sound when testing in 5.1; when it tested the center and sub-woofer. After trying your suggestion I have audio again, Woohoo!! Unfortunately it only works from the front jack, apparently the rear one is still on strike. Oh well I have audio, I'm happy. Thanks so much!
m
0
l
!