Sign in with
Sign up | Sign in
Your question

Asus sabertooth x58 & sapphire radeonn hd6950 not detected on monitor

Last response: in CPUs
Share
March 25, 2011 4:34:30 AM

hi everyone,

i have asus sabertooth x58 and sapphire radeon hd 6950 and i dont see any problem on hardware no beeps no blinking led and im not sure about the red led on cpu and dram but the thing was my monitor cannot detect the dvi/vga cable, hdmi connected to my cpu...



a c 112 à CPUs
a b Ĉ ASUS
March 25, 2011 7:01:32 AM

your not even getting a no signal message?
your power supply has enough amps to run the card?
check all the power leads are connected. especially the 20/24pin and motherboard atx.
if your gfx card has 2 power connectors, connect them both.
if your using molex converters instead of dedicated 6pin/8pin make sure there on the 12v high amp rails if its a modular psu.
check the cpu is seated properly as it the heat sync.
check the ram is firmly in place and in the rite ram sockets.
finally check all other cabling...

if all that is fine. check the gfx card in another machine if you can. if all is well then run the test below.

turn on the monitor and wait for no signal. time it to going into standby, then repeat but this time as soon as you see the no signal message, turn on the pc.
if it immediately jumps into standby on the monitor than you may be looking at a dead cpu.
m
0
l
March 25, 2011 7:36:51 AM

I Use the same Motherboard and also a HD 6970. Check if there is a red light on the card (which means insufficent power). Also is the card spinning at high speeds (a sign that you dont have the 8 pin connected just 2 6 pins).

I recently had an issue with no signal being sent to the monitor and it looked like everything was getting power including the card but it turned out that the 12v rail on the PSU was faulty and wasnt sending out enough power . unfortunately there is no onboard graphics to check
m
0
l
!