Closed Solved

IDirect3DDevice9:Present Failedevice lost (D3DERR_DEVICELOST

So, I got built my new comp:

Gigabyte H55M-USB3
i5 760 Processor
4 GB Corsair RAM 1333Mhz
ASUS ATI 5770

So, I got it set up and I've ran some benchmark tests and I've been getting some errors, first was when I ran Passmark's Performance Test. See the link below for my detailed conversation back and forht with them:
http://www.passmark.com/forum/showthread.php?p=9813#post9813

So, I ran 3DMark and got similar error, don't know what to do, Passmark people think it has to do with hardware setup, but no matter what I try, I can't do anything. I want to fix this!!!! Thanks
5 answers Last reply Best Answer
More about idirect3ddevice9 present failedevice lost d3derr_devicelost
  1. Did you let windows install the drivers or did you download them from ati's website?
  2. Best answer
    I think I know what might be wrong. My laptop had the same problem when in tried to install the ati driver. What fixed it was uninstalling the driver deleting the ati folder and then using the catalyst driver installer as apposed to downloading the complete driver package.
  3. I uninstalled everything and the Complex 3D test that I was trying to run when I get the error, worked, but it gave me a VERY LOW score that I don't think is reflective of my hardware, I have the 5770 and one of the comparison results had a 3870 and they got a much higher score? that doesn't seem right.
  4. Best answer selected by highwonder.
  5. This topic has been closed by Mousemonkey
Ask a new question

Read More

Graphics Cards Graphics