Sign in with
Sign up | Sign in
Your question

M-Audio Fast Track Ultra pops after system upgrade

Last response: in Components
Share
March 27, 2011 11:04:43 PM

I have an M-Audio Fast Track Ultra running on a Windows 7 64-bit machine. I had a Q6600 and Asus P5W DH Deluxe. I recently upgraded to an Asus P8P67 Pro with an i2500K. I'm not 100% sure, but I think I also upgraded the M-Audio drivers around the same time. I did not do a new Windows install - the same as I had before.

After my system upgrade, the M-Audio box has almost constant clicks and pops when playing back audio. To be clear, I simply have it set as my default sound card and am playing music through it - nothing fancy. I've tried the latest and the older drivers. The M-Audio box works totally fine on my laptop.

I've tried shutting down the Realtek HD Audio Manager and disabling the bluetooth on the P8P67 Pro, but no difference. I've also tried various USB ports and attaching it to its wall power as well.

Any ideas?
September 16, 2011 2:32:35 PM

Did you ever fix this issue.. i have a similar issue on the p5e3 deluxe...

Thanks
September 19, 2011 7:38:58 AM

Yes and no... I think I discovered the issue only occurred on some USB ports. Why it worked in one for a long time then starting having the problem I do not know. But I had it plugged into my monitor, and I relocated it to one of my PC's rear ports and the problem seems to have gone away. I know some USB ports (especially on laptops) do not allow for enough current draw for some devices. Try all of your USB ports. Of course uninstall and update your drivers as well.
Related resources
September 19, 2011 3:50:36 PM

I must update.. i wrote the wrong motherboard before.. i have the p8p67 deluxe rev B..

I spent 4 hours yesterday troubleshooting.. yes in fact, it was flaky ports, particularly the usb 3.0 's that had issues.. and a few usb 2.0 on the back.

For me, only usb #1 or #2 would work without issue, near the esata powered port on the back, anything else was misery.. i tried updating drivers, starting from scratch etc, all a no go.

But at least its working now :) 

September 20, 2011 3:51:02 PM

Update again.. while the change in USB ports, did seem to help, i ran into a new issue.. as i was testing in reaper, using M-audio ASIO, recording a track via analog #1 (xlr microphone), i suddenly got squealing and screeching and cracking in the headphones, attached to the m-audio..

This happened after i told it to start a new project.

All the lights on the m-audio device, in particular the red cliping lights came on at once during this.

Of course if i try to unplug the unit via the usb cable and plug it back in, or turn on and off, this doesnt help..

At one point i rebooted and the red clipping lights were still on the unit, not until i tried cycling the power a few times (on the m-audio) did that kick it out of this mode.

I'm beginning to think i have a lemon (got from ebay). Someone online mentioned a similar issue and referred to the issue as being a bad POT? While another said to plug the unit directly into a usb hub and try again.

Either way, since it happens when the pc isnt even booted up (the red lights and unit going nuts), i'm thinking its hardware.



Anonymous
December 16, 2012 11:24:00 AM

Hi everybody i think the problem could be that the usb port don´t power enought the m-audio so need to be powered by the adaptator 5v 2A some clicks desapear but i´m not quiete sure if is the complete solution
!