Sign in with
Sign up | Sign in
Your question

Failed to RDP into Home PC (Comcast)

Last response: in Networking
Share
June 15, 2010 10:41:58 PM

I've been trying to figure out what has been preventing me from RDP'ing into my home PC for months now but have had no luck.

My setup:

Windows 7 Ultimate
* with remote assistance enabled
* firewall exceptions in place for port 3389
Norton Security (From Comcast)
* with firewall exceptions in place for port 3389
Linksys WRT54G2 Router
* Port forwarding enabled for the PC's IP behind the router over port 3389 both UDP/TCP
Comcast Voice / Data Modem

I can access my PC just fine from any PC within the network - but something is blocking me from reaching it from the outside. I've tried from numerous external networks to eliminate the chance of it being related to those networks.

When I ping the IP of my router the response times out. If I run a tracert on the router IP as well I get timed out at an IP prior to the router.

My guess is this is either something on the Comcast network side (although I never had this at previous homes with Comcast cable) OR the more likely cause is the modem. Unfortunately I've not been able to find any details on the modem to see if there is some configuration utility that I could try and tweak or allow this traffic.

Anyone have any ideas? Seen this happen?
June 15, 2010 11:22:34 PM

Are you running a static IP address? If not, how are you determining your external IP address?

Also, you need more then Remote Assistance enabled for Remote Desktop Connection. You should go into Control Panel > System > Remote Settings > Remote Desktop: Allow connections, and Select Users and insure your user has permissions to remote in. However, sense you said you could access your computer from the local network, this may be a non-issue.
m
0
l
June 16, 2010 3:21:46 AM

You don't need a static IP to RDP - Comcast's IPs rarely change - we are well beyond the days of dial-up. But yes - I do have a way if I for some reason discover my IP has changed - I run NO-IP and have a free domain setup and the utility running on my PC so I can connect that way.

Regardless it's not a matter of not knowing my external IP.

As for the other settings - I understand, those are all enabled just fine. Like I said - can connect locally - something outside of my router seems to be blocking me.
m
0
l
Related resources
June 16, 2010 4:01:47 AM

If you can connect locally then your problem is pretty much guaranteed to be incorrect settings in the firewall/router or you have an incorrect ip address. Verify the ip address and firewall settings, port forwarding, internal ip address, etc.

It's a long shot but you can also your rdp listening port is on the expected port. To do this:
1. Open the registry editor
2. Navigate to: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber
3. Verify the port number is set to what you expect it to be (default 3389)

Let me know if this helps, and post back if you are still having problems. Good luck :-)
m
0
l
June 16, 2010 5:46:18 PM

kyeana said:
If you can connect locally then your problem is pretty much guaranteed to be incorrect settings in the firewall/router or you have an incorrect ip address. Verify the ip address and firewall settings, port forwarding, internal ip address, etc.

It's a long shot but you can also your rdp listening port is on the expected port. To do this:
1. Open the registry editor
2. Navigate to: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber
3. Verify the port number is set to what you expect it to be (default 3389)

Let me know if this helps, and post back if you are still having problems. Good luck :-)


Firewall - Like I stated - everything is opened up (even if I disable everything this still happens).
IP - again - I work in IT and am fully aware of how to verify my IP address, it is correct.

The port shouldn't be a problem (and I have tried changing it with no effect) because I can communicate over this port on the internal network.

I've been enjoying a chat with the Comcast tech's for some time this morning and they are unable to locate the cause as well. I can't even ping my home network/PC/router, etc. times out
m
0
l
June 16, 2010 6:31:15 PM

Not being able to ping your router probably just means that it is set to blocking ICMP request for security reasons, shouldn't have anything to do with your ISP.

You keep saying that everything is set up correctly, but you still can't connect so obviously something is wrong. Again, this is almost guaranteed to be a problem with your router settings/firewall/ip address. There is almost no chance of this being a problem on comcasts end (although i admit, there is always the possibility, however unlikely).

Without any more details on how your network is set up and how you are verifying these settings, there isn't much more i can do to help. All i can say is:

1. Verify that the computer doesn't go to sleep when it isn't touched for a while.
2. Insure the computer is assigned a static internal IP address.
3. Insure port forwarding on the router points to the correct internal IP address, and to the correct listening port for RDP
4. Insure you have the correct external IP address.
5. Insure any other settings on your router that may be preventing incoming connections are set up correctly or disabled.
6. If you have a firewall between your router and your network (instead of just on the computer) insure that is set up to allow connections as well.
m
0
l
!