Sign in with
Sign up | Sign in
Your question
Closed

Unable to permanently disable/remove Physx

Tags:
  • Nvidia
  • Physx
  • Processors
  • Graphics
Last response: in Graphics & Displays
Share
November 3, 2010 4:51:07 PM

I am doing some testings and I am trying to remove or disable Physx once for all, but I can't do it.

I unistalled the Physx drivers, I restarted the computer, but when I open the nVidia Control Panel Physx configuration still show up and as default it automatically select my 8800 GTX as Physx processor.

I want my CPU to take care of Physx. If I select CPU from the drop down menu, next time I restart the computer it goes back to 8800 GTX. Even if I save the profile and set it to start it when Windows starts, the Physx selects my 8800 GTX as default processor again.

This same problem happens with 2 computers, one using 8800GT and the other using 8800GTX card.

Any suggestion on how to permanently disable or remove Physx?
Or any suggestion on making nVidia control panel to boot up using the CPU as Physx processor? I don't want to manually do it every time I reboot.

This is a great community, thanks for your help.

More about : unable permanently disable remove physx

November 3, 2010 4:55:18 PM

Try uninstalling the driver package and use driversweep and then reinstall without Physx.
Score
0
November 3, 2010 5:45:42 PM

deweycd said:
Try uninstalling the driver package and use driversweep and then reinstall without Physx.


I tried to unistall all the nVidia video drivers, including Physx driver, Video driver, 3D driver. I used driversweep and ccleaner to clean up the registry. Rebooted, reinstalled nVidia drivers only without Physx and 3D.

Nothing to do, the Physx configuration still shows up, like if it is build with the nVidia video drivers. This is something weird, no Physx drivers, but the nVidia control panel still allow me to set my graphic card or CPU as Physx processor. Again, if I select CPU, apply settings, and save the profile, next time I reboot I still need to manually switch to CPU.

Score
0
Related resources
Can't find your answer ? Ask !
a b Î Nvidia
November 3, 2010 5:49:36 PM

What driver revision. With the 260.xx I can select cpu if I chose, but there is no reason to ? If you don't want to use physX in whatever game X, there is usually a option to not use , or enable.
You should install the latest Nvidia driver , which will include the newest physX revision, this will ensure the control panel works correct.
Score
0
November 3, 2010 5:54:47 PM

notty22 said:
What driver revision. With the 260.xx I can select cpu if I chose, but there is no reason to ? If you don't want to use physX in whatever game X, there is usually a option to not use , or enable.
You should install the latest Nvidia driver , which will include the newest physX revision, this will ensure the control panel works correct.


Yes, I am using the 260.xx drivers. I can select CPU too, the problem is that when the computer reboots, it goes back to my video card as default Physx processor. I don't want to switch manually to CPU each time I reboot.

I play World of Warcraft which doesn't use Physx. From some researches on their forum, I found that disabling Physx could increase performance. This is why I would like to permanently disable Physx.

Something I don't understand. How can nVidia control panel makes me able to select the Physx processor even though the drivers were unistalled and fully removed?
Score
0
a c 466 Î Nvidia
November 3, 2010 7:32:13 PM

I think the Control Panel is part of the Nvidia display driver, and the PhysX drivers are separate. Therefore, you will always see the PhysX configuration in the Control Panel, but that does not necessarily mean that PhysX is installed. That might actually explain why it keeps resetting the configuration to default every time you restart. Besides using the Control Panel do you know if PhysX is really enabled?

I would check under (sorry I'm not on my home computer, so not sure), the part of the Control Panel that lists your driver versions. If there is a PhysX driver listed, you need to uninstall it, again. If there is none listed, then your system is clean of PhysX drivers and you can ignore the PhysX configuration tab.
Score
0

Best solution

a b Î Nvidia
November 3, 2010 7:44:03 PM

Just having physX on your system will not effect a game like WoW in any way. Its similar to people thinking they are getting BETTER performance by a dedicated physX installed in their system, in non physX games. If WoW does not have coding for a physX 'hook', its all immaterial, or in peoples minds.

I googled Wow and physX and sure enough I found a thread where the answer said disable physX will give more fps, but thats totally untrue. The fps WILL be the same.
Share
November 10, 2010 7:16:59 PM

Best answer selected by Netspiderz.
Score
0
a c 173 Î Nvidia
November 11, 2010 2:43:59 AM

This topic has been closed by Mousemonkey
Score
0
!