Sign in with
Sign up | Sign in
Your question

Boot Error, can't install W7, problem communicating with a device?

Last response: in Systems
Share
January 3, 2011 6:56:10 PM

I finally got a monitor and I am now trying to install Windows, however, right after it says Boot from CD/DVD, it says Windows is loading files, then says it has problem communicating with a device.

I am quite frustrated because I've been waiting months and months, and my friend has the same build practically and his worked butter smooth, but I don't know what I am doing wrong.

From what I understand, there is a problem with either the Optical or Hard Drive

The CD drive opens fine, no weird sounds or beeps, and Im guessing it's the hard drive because it says "Windows is loading files" for about 10 seconds before the error comes up on the black screen, so Im guessing the CD is being read just fine

Does it matter which SATA port the SATA cables are plugged into? There's 6 blue labeled SATA_0 through SATA_5 and then 2 more which are white and GSATA_6 and 7 but Im not using those 2

When I go into BIOS and CMOS configs, I say a bunch of IDE Master and Slave options, does it matter which ones the HDD and optical drive are on?

Help is really appreciated, I've spent about $1200 bucks on all my stuff and I really would love it if I could get it working tonight...
January 3, 2011 7:30:58 PM

Usually get that error if you have a nonbootable device, such as USB key plugged in.

In case of a new build though, I'm not sure what you mean by other cable.

Do you mean SATA power?



Or did you try to connect something like an IDE or molex to the back of a SATA drive?

Molex


IDE

If you don't have both SATA and SATA power cable plugged in, a HD won't work.

If above is correct, check what mode the Controller is in the BIOS. It may be in RAID mode for example.

Also a common issue is attempting to install Win Xp on a PC with a SATA drive. This won't work since XP setup lacks drivers to recognize SATA drives.

See below for solutions
http://www.mydigitallife.info/2007/10/23/windows-xp-set...
January 3, 2011 7:58:11 PM

Yes the Sata power im in retard mode atm i apologize. Thats all, im replugging in all the cables and doing better cable management, gonna try again.

I have a gigabyte ga p55 usb3

Does it matter which sata ports i use as long as i use the blue ones? Theres 2 white ones labeled gsata which are NOT used atm

I am installin w7 not xp and the cd works ive used it on my other comp no scratches

There should only be a sata data and power cable for both cd and hdd am i correct?

Also where do i go in bios to see if my hdd is recognized? Im thinkin maybe its dead?
Related resources
January 3, 2011 8:21:53 PM

Im in my BIOS, i go to standard cmos features an i see my cd drive in ide channel 0 master and my hdd in ide channel 1 master

All the rest of channel 1-5 master and slave other than those 2 say none

Drive a says none, halt on says all but keyboard

When i click my hdd it says ide channel 1 master [auto] and same with access mode

Capacity is 1000 gb

Cylinder 65535
Head 16
Precomp 0
Landing zone 65534
Sector 255

Anything wrong here?
January 3, 2011 9:51:53 PM

Controller is in IDE mode ATM.
You'll want to swap controller to AHCI in the BIOS under integrated peripherals. Consult your mobo manual to see which SATA ports correspond with which controllers. The GSATA ports would be GA controller.

MOBO is recognizing HD so that's fine.

Check the boot order as well. Make sure boot is Optical drive before hard drive.

And yea, SATA and power should be all that's connected to your devices.
January 3, 2011 10:08:42 PM

Ok so I go into integrated peripherals to change IDE to AHCI? What exactly do I do?

My mobo manual says:

The SATA ports support 3 Gbps and 1.5 Gbps Sata connectors blah blah, says the blue are controller by the P55 chipset

The GSATA ones are controlled by the GIGABYTE SATA 2 controller

It is on CD drive boot first then HDD, Ill try again

Could it be that the HDD is recognized but dead? Im kinda freaked out about that

I dont understand why this is happening, my friend has basically the same setup and he had no difficulties /:

EDIT: I put it into AHCI mode, still getting the same error...
January 3, 2011 10:33:53 PM

Does it matter what's in the IDE Slave and Master port? Like what should the HDD and Optical drive be on? There's like IDE Master and Slave 1-5 or so I believe

Does it matter which SATA ports I plug them into? There's 3, one for the case cause it has an eSATA port, one for cd drive and one for hdd, Im guessing as long as they're in the blue ports it shouldn't matter

EDIT: My CD Drive is in IDE Master Channel 0 Master and my HDD is in Channel 0 Slave, maybe that'll help

Just realized there's PCH SATA Control Mode and Onboard SATA/IDE Ctrl Mode, they can both be set to AHCI, which one do I set to AHCI, one or both or what
January 3, 2011 11:38:06 PM

Just set them all to AHCI. You'll need to go through the manual for details on what all the options mean.
Shouldn't be running SATA drives in IDE mode period. There is no slave/master for SATA.

January 3, 2011 11:43:46 PM

Just set both to AHCI and it still gives me that error. Is there something else I can set to AHCI? My friend says his HDD is on slave and stuff, his worked just fine, what is AHCI exactly and how come that wasn't the default

Im beginning to kind of lose hope here, I got all my cables plugged in, it's obviously something to do with the hard drive or CD drive, both data and power cables are plugged in for both, I set those 2 things to AHCI, anything else I can set to AHCI?

Would load fail-safe or load optimized defaults do anything?
January 4, 2011 1:21:55 AM

I see these 3 options for both PCH SATA Control Mode and Onboard SATA/IDE Ctrl Mode

For the PCH I see:

IDE
RAID(XHD)
AHCI

For Onboard I see:

IDE
AHCI
RAID/IDE
!