Closed Solved

Catalyst Driver Installation Quits Without Installing Driver

XFX's Radeon 5870, Windows 7 Pro 64.

Selecting the appropriate drivers from here, it indicates I can download a driver from this month, v10.10, so I do so. (Either the pack including OpenCL, the pack without it, or just the driver itself without any other bundled software, I've tried each with no difference).

I uninstall my current drivers, which dxdiag lists as "aticfx64.dll version 8.762.0.0", (drops me down to 600x800 res or so). Then I run the Catalyst Installer from my admin account.

The installation utility unpacks, then I click install... then the process just quits and nothing is installed.

Has anyone else faced this problem?

(Tried to ask AMD... but they haven't responded.)

EDIT: Fresh install of Windows fixed this and several other issues I was experiencing.
15 answers Last reply Best Answer
More about catalyst driver installation quits installing driver
  1. Uninstall all ATI related files in Add/Remove programs.
    Download and install Driversweeper
    Run Driversweeper in safemode
    Check Ati
    Analyse and clean
    Restart normal
    Download and install appropriate drivers
  2. Davcon:

    Thanks for the reply. Unfortunately, while Driversweeper did find a few additional ATI files / registry values that the standard uninstall was missing, attempting to install the drivers ran into the same issue.

    The Installer asks for language, then asks whether you want to install or uninstall. After clicking "Install" the installer disappears from the screen, and a few seconds later, disappears from task manager.

    Maybe I'll try with 10.9 if I can find it... maybe this version has a bug in the installer or something.
  3. This happens to me, and a LOT of other people. Something is (and has been) messed up with their install package for some time now...

    Its the instal program suite thats the problem; you can still install the drivers via the command line (assuming you know what switches to toggle). I have the link for such an install on my home PC, though it should be easy enough to google...
  4. Try to install the latest .net framework from microsoft first.
  5. Yeah sounds like maybe you need to update Windows first. Hopefully that works.
  6. ^^ I know thats not the case with me; I do a LOT of development, and have the latest SDK and the CCC install always crashes.
  7. Thanks for all the suggestions.

    Tried downloading/installing .NET from Microsoft, but it appears to be latest version: 4.0.30319 ?

    Did a repair just in case. My .NET setup contains .NET client, .NET extended, and .NET multi-targeting pack.

    No luck.

    I googled for installs via command line, saw a lot of stuff for Ubuntu and Fedora... found this command:
    (unpacked directory)\setup.exe /INSTALL /FORCE_HIDE_FIRST_RUN /AUTOACCEPT_ALL

    Tried that, not sure if that's what you meant or not. Didn't seem to do anything.
  8. Best answer
    I once had a windows version that just refused to install any catalyst as well. I dunno what it is that causes it, but the only way around it was to do a fresh reinstall of windows.
  9. I'll post the link I have when I get home today; the command you listed is NOT the one I use (again, I need my bookmark from home to remember WHAT it actually is).

    Anoying ATI can't even get its install software to work right; I've had problems as far back as my vanillia Vista install (which is when I got my 4890).
  10. It's possible there's something corrupt with the download itself, maybe a disk error. You should try to delete the file completely, then redownload it and see if it works... /shrug might work :D
  11. Tried a fresh download, no dice.

    Sent some info from my event log to ATI, they have now responded.

    They believe it is likely a bug in the Windows Kernel, because both InstallManager and ntdll were listed in the Application Error.

    I feel like we get punted by tech support to other parties a little too easily, but I suppose they could be right. They recommend unplugging nonessential usb items and uninstalling remote access software, unchecking some startup items from msconfig... I think they're trying to lighten the load on the kernel. There might be other creative ways I can try doing that to hope to dodge any conflicts. I rate it as a longshot, sounds a bit like voodoo, but we'll see how it goes.

    After that I will reinstall windows. I'm putting that off a bit, I don't have the process streamlined for reinstalling all my apps or anything.
  12. The fresh reinstall will probably fix it. I went through what you are doing once and in the end, that's all that fixed it. I dunno if it was an ATI problem or something in windows, but the only fix for me was the fresh install.
  13. Try partitioning a section of your drive then save a windows backup onto it. Then format the main partition and reinstall windows there, and you can then try installing the backup to get most of your stuff back.
  14. Best answer selected by brownbat.
  15. This topic has been closed by Mousemonkey
Ask a new question

Read More

Graphics Cards Drivers Catalyst Graphics