Sign in with
Sign up | Sign in
Your question

5970 running slower than my 5870!... Help!

Last response: in Graphics & Displays
Share
November 4, 2010 11:23:36 PM

Hey guys,

I, having problems with. My 5970 I've got an XFX 5970 Black Edition 2GB, it's in my computer on a PCIe 2.0 16x Slot connected to a good 1000W PSU,

My CPUs are 2.66 GHz Quads. Two of them 8 cores total,
Ive over clocked to 3.2 GHZ by upping the FSB to 1600Mhz

I've got 12GB DDR2 FB-DIMM RAM @ 800mhz

And my boot disk is a Crucial C300 SSD.

I've got my 5970 at stock speeds, but vie also over clocked it by increasing voltage and upping bits to the speed of a 5870 850/1200...

Now here's my problem: my FPS In Batman arkham asylum is 58FPS average, if I overclock it's 58, if I put it in a 8x slot it's 58, if I put it in a 4x slot it's 58, if I connect it to an external 450w PSU it's.... 58

Ok so fine your thinking that's the speed my 5970 can get out of this game is 58FPS so now here's the bizarre bits, my 5870 which I also own gets thee exact same results.

So maybe your thinking it's the game. So I've tried Crysis, Crysis warhead (both of which are the same regardless.) my copy of mafia 2 I get 65 fps with my 5870 and only 40 fps with my 5970!

Temperatures, it's not temperatures, they are within acceptable range and with my fans running full below standard ranges.

I've disconnected everything else from my computer, hard drives, optical drives USB stuff etc etc. And here I am.

So leaving MSI Afternurner running shows that normally my GPU 1 is running at about 80% and number two at 30%! when clocked at normalnspeed and worse when over clocked, no idea why.

Sony Bravia TV 1080p 60 Hz...

Help
:( 
November 5, 2010 8:51:17 AM

Hello and welcome to the forums
First of all,revert your OCs to stock speeds and see if it helps. and make sure you have the latest VGA drivers installed.Also is CrossFire enabled? open CCC>Graphics>3D>AI and make sure "Disable catalyst AI" is unchecked.
November 5, 2010 11:49:15 AM

Maziar said:
Hello and welcome to the forums
First of all,revert your OCs to stock speeds and see if it helps. and make sure you have the latest VGA drivers installed.Also is CrossFire enabled? open CCC>Graphics>3D>AI and make sure "Disable catalyst AI" is unchecked.


Thanks for the reply, unfortunately I've tried all of the above.
Related resources
November 5, 2010 12:14:22 PM

I too have a 5970 black edition. I also get 58fps in warhead aT 1680X1050 4aa and everything on enthusiast. What res are you playing at. Are you also saying your 5870 will run warhead at 58fps also? Running Mafia, not all games are optimised for crossfire and can actually degrade performance in some games which may explain your drop in performance in Mafia.
I used to run a GTX295 and since the Nvidia drivers tend to be better I was able to run off 1 gpu rather than both and sometimes I had an increase in performace. I owuld have thought the 5970 would kill the 5870 in Crysis Warhead though.
November 5, 2010 12:20:18 PM

from what i see it's not a hardware problem.why don't you try posting this on ati forum?
!