Sign in with
Sign up | Sign in
Your question

ASMedia USB 3.0 ASM1042 BSOD Lockup Unstable Drv Compatibility Issues

Last response: in Motherboards
Share
December 5, 2011 8:49:02 PM

Hi,

I have bunch of issues with ASMedia ASM1042 USB 3.0 controllers. They provide 4 USB 3.0 ports on ASUS motherboards (P8Z68-V Pro). Their drivers and firmware seem completely unstable and buggy. The symptoms are blue screens of death / BSOD, lockups, and standby (sleep) / resume issues. The problems mostly appear when using USB 1.1 and 2.0 devices on USB 3.0 ports. It seems, backward compatibility has not been fully ensured. I just don’t understand how this controller received USB-IF certification with all the problems I’m seeing.

I’m using Win7 Pro x64.

Please note: I have no control over what USB devices users will connect to these ports. So, “don’t plug in USB 1.1 devices to blue USB 3.0 ports” is not a solution.

NEC/Renesas uPD720200 USB 3.0 host controllers work flawlessly with all the USB devices I have.

I have documented all the problems in detail on ASUS forums:
http://vip.asus.com/forum/view.aspx?id=2011120306544244...
If this link does not work, just google: “ASMedia USB 3.0 (ASM1042), BSOD, Unreliable, Unstable Drivers”.

Is anyone else experiencing the same or similar problems?

Thanks
December 7, 2011 9:48:32 AM

I recently built a computer using a Asus P8P67 Deluxe board. (The version after the recall.) I purchased a new Corsair USB 3.0 thumb drive and a new Lacie external USB 3.0 drive. They initially worked but at very slow speeds and then would not work at all in any computer. On the Lacie I took the enclosure apart and tried to use the SATA drive inside but it is dead. If I didn't know better I'd say it was physically broken.

I have searched, and installed, drivers with no luck. I don't want to invest in more USB 3.0 devices to test it, that has already been expensive! I am a long time Asus customer and I was just going to buy another model motherboard, (yes from Asus) UNTIL I started seeing more and more posts about this problem. And lack of response from Asus. So I'll be looking elsewhere for a replacement mother board.

Dave B



CodeMajster said:
Hi,

I have bunch of issues with ASMedia ASM1042 USB 3.0 controllers. They provide 4 USB 3.0 ports on ASUS motherboards (P8Z68-V Pro). Their drivers and firmware seem completely unstable and buggy. The symptoms are blue screens of death / BSOD, lockups, and standby (sleep) / resume issues. The problems mostly appear when using USB 1.1 and 2.0 devices on USB 3.0 ports. It seems, backward compatibility has not been fully ensured. I just don’t understand how this controller received USB-IF certification with all the problems I’m seeing.

I’m using Win7 Pro x64.

Please note: I have no control over what USB devices users will connect to these ports. So, “don’t plug in USB 1.1 devices to blue USB 3.0 ports” is not a solution.

NEC/Renesas uPD720200 USB 3.0 host controllers work flawlessly with all the USB devices I have.

I have documented all the problems in detail on ASUS forums:
http://vip.asus.com/forum/view.aspx?id=2011120306544244...
If this link does not work, just google: “ASMedia USB 3.0 (ASM1042), BSOD, Unreliable, Unstable Drivers”.

Is anyone else experiencing the same or similar problems?

Thanks

March 24, 2012 10:42:02 PM

Oh ya. ASUS P9X79.

This is the second major USB 3 CRASH I've had using the ASmedia, just in the last week. Talk about a waste of my time troubleshooting and re-installing drivers. Absolute chaos. May work for moving a couple of small files (like "a" mp3). Try to put anything bigger than that and CRASH. My native USB 3.0 3TB WD Mybook and RAID 1 enclosure will not be recognized at all. They work perfectly fine in Intel based USB 2 ports (just slow). However, I have no choice. Asus and ASmedia should not hype this equipment as being fast or as mature or stable. It is buggy. It doesn't work. Stay away from ASmedia anything until they put out some drivers and hardware that people have tested and claim to work.
Related resources
May 26, 2012 9:39:26 AM

CodeMajster said:
Hi,

I have bunch of issues with ASMedia ASM1042 USB 3.0 controllers. They provide 4 USB 3.0 ports on ASUS motherboards (P8Z68-V Pro). Their drivers and firmware seem completely unstable and buggy. The symptoms are blue screens of death / BSOD, lockups, and standby (sleep) / resume issues. The problems mostly appear when using USB 1.1 and 2.0 devices on USB 3.0 ports. It seems, backward compatibility has not been fully ensured. I just don’t understand how this controller received USB-IF certification with all the problems I’m seeing.

I’m using Win7 Pro x64.

Please note: I have no control over what USB devices users will connect to these ports. So, “don’t plug in USB 1.1 devices to blue USB 3.0 ports” is not a solution.

NEC/Renesas uPD720200 USB 3.0 host controllers work flawlessly with all the USB devices I have.

I have documented all the problems in detail on ASUS forums:
http://vip.asus.com/forum/view.aspx?id=2011120306544244...
If this link does not work, just google: “ASMedia USB 3.0 (ASM1042), BSOD, Unreliable, Unstable Drivers”.

Is anyone else experiencing the same or similar problems?

Thanks



Similar problem here on ASrock Z77 Extreme4 with the ASM1042 USB 3.0 controller. Ports are dead in Win. 7 SP1, depending on what ASM driver I try to install it either locks up windows or fails to install. Right now I can see the controller in device manager but the ports are not functioning (system seems stable so I am leaving it as is) I need the additional ports so I either need to buy an expansion card or fix the issue. I tried disabling USB 3.0 legacy support in my BIOS (advice seen on another thread) but it didn't help my situation.

If anyone finds a solution please let me know.

JT
June 17, 2012 4:51:20 PM

Another problem with Asmedia USB 3.0 drivers:

USB 3.0 loads/functions reliably and produces high scores on ATTO benchmark. However, when booting/rebooting with an external USB 3.0 drive attached, the boot time increases by 30-70 seconds. There is a prolonged delay between the Windows splash screen and appearance of the desktop.

The problem reliably disappears when I unplug the external 3.0 drive or disable the asmedia drivers.

Any thoughts on how to fix this?
TIA, Greg.
Anonymous
a b V Motherboard
October 22, 2012 5:46:43 PM

hello,

i am using an ASUS Crosshair V mobo with WinXP x64. no usb problems.

while searching for a driver update i found www.station-drivers.com/page/asmedia.htm
maybe that firmware update fixes your deadlock issues
!