"No signed device drivers were found." - new windows 7 install

Hey guys,

I just bought a new system and built it myself and was pleasantly surprised to see that it started up ok..now im trying to install windows 7 64-bit from a DVD and I get this message:

"No signed device drivers wre found. Make sure that the installation media contains the correct dirvers, and then click OK."

I went to ASUS's website and dl'd my HDD's driver and put it on a USB. The installation recognized it and I assume used it but I still have this issue. Basically when I go to select were I want to install windows, there's nothing there.

I don't have a 4GB USB and was hoping I could fix this w/o one - I do have a phone with like 10GB storage but I think you have to wipe everything to install windows from a USB.....

Here's a list of my specs:


ASUS DRW-24B1ST/BLK/B/AS Black SATA 24X DVD Burner - Bulk - OEM


HITACHI HDS721050CLA362 (0F10381) 500GB 7200 RPM SATA 3.0Gb/s 3.5" Internal Hard Drive -Bare Drive

GIGABYTE GV-N560UD-1G GeForce GTX 560 Ti (Fermi) 1GB 256-bit GDDR5 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card


CORSAIR Vengeance 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model CML8GX3M2A1600C9W


ASUS P8Z68-V/GEN3 LGA 1155 Intel Z68 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard with UEFI BIOS


Intel Core i5-2500K Sandy Bridge 3.3GHz (3.7GHz Turbo Boost) LGA 1155 95W Quad-Core Desktop Processor Intel HD Graphics 3000 ...


Your help is greatly appreciated - I just want my damn computer to work! :fou:
Reply to Newnoob
17 answers Last reply
More about signed device drivers found windows install
  1. Shameless bump..
    Reply to Newnoob
  2. BTW I tried booting from the DVD and installing chipset drivers but those didn't work either
    Reply to Newnoob
  3. are you using the grey or the blue sata ports?
    Reply to mcnumpty23
  4. I'm using both blue ones - there's only 1 grey one
    Reply to Newnoob
  5. is this your board ?

    http://uk.asus.com/Motherboards/Intel_Socket_1155/P8Z68V/#specifications

    try the hard drive on the grey sata port just to see what happens
    Reply to mcnumpty23
  6. Did you enter the BIOS and make sure the controller is enabled, the drives are showing up, and you have a boot order assigned?
    Win 7 needs needs nothing for your SATA drives, it has all the drivers it needs.
    Reply to jitpublisher
  7. I didn't do those things and I don't know how, well maybe except the boot order - where do I go to change the controller
    Reply to Newnoob
  8. If the drives are showing up and you can set the boot order, the controller is working.
    Reply to jitpublisher
  9. Yah I remember being able to edit the boot order - there are 2 sets of cables plugged into the SATA ports - 1 set is black heads with black wires and the other set is black heads with red wires. Is this correct?
    Reply to Newnoob
  10. Does anyone have any ideas what I should do?
    Reply to Newnoob
  11. jitpublisher said:
    If the drives are showing up and you can set the boot order, the controller is working.



    THe drives aren't showing up though that's the problem
    Reply to Newnoob
  12. If you can't load the SATA device drivers because they are unsigned, then a work around would be to enter the BIOS and select IDE mode for your SATA controller. This is not quite as good as loading the SATA driver as you will lose NCQ (Native Command Queuing) but you will not notice the difference.
    Reply to pjmelect
  13. Hmm ok I'll try that out thanks
    Reply to Newnoob
  14. Nope that didn't work either: still when I go to Custom Install and it brings up the list of "Where do you want to Install Windows?" there's nothing there:

    "No drives were found. Click Load Driver to provide a mass storage driver for installation."
    Reply to Newnoob
  15. Is it possible I've plugged in the HDD incorrectly?
    Reply to Newnoob
  16. Wow....so I go to check if the HDD is plugged in and... its not lol - currently installing windows 7
    Reply to Newnoob
  17. Hey I just wanted to tell you that if you are using the blue usb ports then you are trying to use it on usb 3.0 and for some reason the installer doesn't work well with those, try only using the 2.0 port for it and if it doesn't show it when you try unplug it and plug it a back in. That worked for me
    Reply to Lemurpriest
Ask a new question Answer

Read More

Drivers Windows 7