Ultra LSP 650W PSU and microAXT mobo/Case question

Hi there all you gurus

I will be honest, being a computer tech im a little embarrassed asking this.. but i thought you guys will solve this issue..

So i have a microATX Case and mobo, and all the other parts... (i regret it now but money is spent so whats done is done) and have had it for about a year.. my PSU was way underpowered for the rig... So i bought an ATX Power supply (the LSP650 from ultra). Now, I knew it would be more than Snug on a fit.. but managed to fit it in with just a few isseus arrising.

I hooked it all up, and get a LED light on my Mobo meaning its getting some kinda power.. but it wont power up. I replaced it with my old one again and it fires right up. The only issue i can see is that the instructions state i should plug in the 6pin connector to the mobo but this one doesnt have a spot for it.

So my question to all you gurus is... why the freak isnt this powering up.. i didnt think i would have an issue. Do you think its a failed PSU or do you think it could be something im doing my end... any advice would be greatly appreciated before i send this puppy back.

Thanks!
5 answers Last reply
More about ultra 650w microaxt mobo case question
  1. OMG the 6 pin is for graphics.....the mobo should get either a square four pin or a rectangular 8 pin. A link or parts list would help all us "gurus" help you :)
  2. aaah ok . well the card i have has 2 6 pin connectors on it.. so maybe the mobo doesnt need a PCIE port itself.. not sure.. but here are my parts

    X-QPACK-NW-BK/420 APEVIA X-QPACK-NW-BK/420 Black Aluminum Case
    Intel BOXDG43GT LGA 775 Intel G43 HDMI Micro ATX Intel Motherboard
    Intel Core2 Duo 8400@3ghz CPU
    8gig (4x2) DDR2 800 mhz (some off brand)
    Nvidia Gforce 460 1gb Vid Card
    Wireless N card in PCIEx1 slot.
    160GB SSD Intel HDD

    PSU finder apps run it at around 470 Watts recommended, so i got a 650 to make sure incase i get more HDDs

    As i said, my 400w underpowered PSU runs the PC .. but it freezes a little when it gets overtaxed.

    Hope that helps.
  3. Daplinksta said:
    OMG the 6 pin is for graphics.....the mobo should get either a square four pin or a rectangular 8 pin. A link or parts list would help all us "gurus" help you :)


    oh and i just reread this.. yes it has a 4pin on it.. and the massive 12pin also..
  4. the ultra lsp range is kinda meh
  5. maybe its just bad then.. seemed wierd tho that i was getting the power LED on the mobo...

    Guess i will be returning it i guess.
Ask a new question

Read More

Power Supplies Cases Components