Sign in with
Sign up | Sign in
Your question
Closed

Kernel-Power Issue 41 (Windows 7) reboot loop

Last response: in Systems
Share
January 8, 2011 9:01:55 PM

First off, thank you to whoever takes the time to read this as I've become quite stressed out. I have a fairly high knowledge of computer building and IT (A+, Net+, CCNA, etc.).

I just bought the following:

ASUS P6X58D Premium
Intel i7 950 3.06
OCZ Vertex II 60GB SSD
Seagate 250GB HDD
OCZ 3x 2GB DDR3 12800 (it is 100% compatible in the mobo manual)
x2 Radeon Sapphire 5770 1GB GDDR5
MAGNA 900w Sparkle PSU
ASUS DVD-ROM
Phillips DVD-RW w/ Lightscribe

Every time I go to install Windows 7 Ultimate 64-bit onto the SSD, it restarts properly to finish the installation, however, it continuously reboots at the Windows splash screen where it says "Windows is updating registry files..." infinitely. Safe Mode will not even load. I've tried removing all other SATA devices, Secure Erase, removing individual sticks of memory (all of which was tested fine during MemTest), removing video cards, etc. I also updated the firmware on all SATA devices and the BIOS of the motherboard. I tried setting the SATA controller to AHCI, too. I've tried it on IDE as well but to no avail.

I finally got fed up and decided to install Windows onto the HDD. From there, I was just going to add the SSD later and create like a 20GB page file. I was successful in doing the aforementioned HDD install and page file creation. Everything was going fine, so I decided to eat since I had starved myself doing all of this tedious work. I come back and my PC had restarted. It was on the Windows 7 login screen. Ever since then, the PC just started randomly restarting. It has since been in an infinite boot loop with Windows 7 Ultimate 64-bit rebooting the PC at the Windows splash screen every single time. This started soon after I installed AVG...at least that was the last thing I could remember. Google led me to some AVG/Windows 7 problems. I tried to boot Windows without AVG running at all. This made no difference...

At this point, I have reformatted again as I'd like my OS on the SSD as was originally intended. I feel like I'm losing my mind. I've tested all the hardware which all comes back fine. I even tried to install Vista Ultimate 64-bit to the SSD which sent the PC into reboot as soon as I would select the SSD to install the OS onto...mind you, during all of the install attempts only 1 SSD/HDD has been present as Disk 0 to avoid complications.

I have read countless posts on countless forums that have gone unanswered and died. Surely there is a solution to this...I'll try anything I can. I'm currently taking a Wintersession course and University starts back in two weeks, so time is of the essence. All help is appreciated, but please don't suggest something I've already tried...

Please help...I am desperate. Any information as to shed some light on this issue will be appreciated... :sweat: 

EDIT: Maybe someone knows some drivers I need to load during the installation of the OS? I tried this once but it said my Intel F6 RST drivers for the SSD/SATA controller thing weren't signed...here are the links to the "unsigned drivers" and the post where it came from:

Intel F6 RST - http://downloadcenter.intel.com/SearchResult.aspx?lang=...

Thread: http://www.tomshardware.com/forum/264193-32-vertex-prob...



***SOLUTION: http://support.microsoft.com/kb/2028504 (Scenario 3 - I had a bad PSU the entire time. See below.)
January 8, 2011 9:20:11 PM

Also, just a note (I didn't have a chance to try this because I reformatted before Google threw this at me...):

When I successfully installed on the HDD, and it started the reboot loop on the Windows splash screen - I read there was a work around by deleting the bootcat.cache from Windows. I saw on the Microsoft forums where there was a hotfix for this, however, unavailable to the public.

Can anyone verify this? If I have to install Windows 7 to my HDD instead of SSD before University starts back, I will. That should be a last resort, though.

Again...thank you to all who read this.
Score
0
January 8, 2011 9:55:47 PM

I just tried to install Windows Vista Ultimate 64-bit onto the SSD the exact same way I would Windows 7. As soon as I selected the drive and partition to install Vista onto from the installer itself, the PC reboots. It won't even attempt (well, not that my eyes can see...) an installation of Vista onto the SSD. I'm going to take a break and watch some basketball...maybe play some Black Ops to take my mind off this new build.

I was attempting to make a Windows 7 USB bootable flash drive, but let me say it is strange the way ASUS has the boot sequence in the BIOS of the P6X58D. You can only choose three devices to boot from:

- 1 from the "Hard Drive" list (if everything is plugged in: Seagate 250 HDD, OCZ Vertex II 60GB, and Sandisk 12GB)

- 1 from the "Optical Drive" list (if everything is plugged in: Phillips DVD-RW and ASUS DVD-ROM)

- and lastly "Removable Media" (nothing...)

My issue here is that my 12GB Sandisk Cruzer shows up in the "Hard Drive" section rather than "Removable Media"...and the Sandisk is the only flash drive I have that is equal to or greater than 4GB.

I'm going to try installing Windows 7 again from a different DVD, and I'm going to try both x64 and x86 versions onto the SSD. I'll keep you readers posted...

Score
0
Related resources
January 8, 2011 11:24:35 PM

I have a few suggestions. They may seem stupid because you do have your A+ cert but the little things get us sometimes.

1. I don't know where you got your version of Win 7. If you obtained it in a way other than buying it from microsoft, make sure that when you burned the ISO to a disk that the file is correct and not missing parts and causing this whole head ache. Unlikely since the vista install didn't work either but its something to check.

2. When you tried installing the os onto the HDD was the SSD plugged in? It could be a corrupt SSD and somehow giving your hell. For instance, when you install the os on the hdd, and you boot, your computer recognizes the ssd and freaks out causing restarts.

That's just my two cents, let me know how it goes.
Score
0
January 8, 2011 11:34:40 PM

Thanks for the suggestions...let me answer #2 first.

I actually thought about that when I was installing. I formatted both, put the HDD as Disk 0, SATA 1. Once Windows 7 loaded, I installed the SSD which was recognized immediately by Windows. I don't know if anything was super fast...I had a 20GB page file on it, FFXIV, and MS Office.

I tried my burned backup of Windows 7 and the original of which both have the same issue.

I'm running out of ideas over here lol...

EDIT: For #2, the short answer is that I installed the drives at different times. HDD during install; SSD after the install.
Score
0
January 8, 2011 11:51:30 PM

OK, so I'm going to try and install to the HDD and clone that to the SSD. I've been reading up on it, and as long as I use diskpart, it should be fine and not mess with the SSD alignment. I'll keep you all posted...
Score
0

Best solution

January 9, 2011 1:47:01 AM

I am running a 30gb OCZ Vertex as my boot drive so I really hope you get it working. They are defiantly as amazing as people say they are.

One last thing, if you are still having trouble, contact your SSD tech support, they usually are pretty handy and have smart tech support.
Share
January 9, 2011 2:17:23 AM

So, I followed this little guide http://sonic-media.dk/?p=103 and it worked. I followed it word for word...

I finally solved my problem! At least for now :lol: 

EDIT: ...and for your interest and support, I will give you best answer since I cannot give it to myself! Haha! I am so happy right now man...
Score
0
January 9, 2011 2:19:23 AM

Best answer selected by vestatio.
Score
0
January 9, 2011 8:07:54 PM

Thank you, I'm happy you got it all worked out.
Score
0
January 17, 2011 3:09:57 PM

I'd have felt terrible if I didn't update this post. Over the last few days since this issue was solved, it reared its ugly face again. I'd either be playing FFXIV, surfing the internet, or even just booting up - and bam...reboot!

I should have been more specific. I don't know if I mentioned this previously, but in Event Viewer, every critical error was a "Kernel-Power Issue 41" problem. Microsoft has three scenarios under support for Windows http://support.microsoft.com/kb/2028504 in which this might occur. It should have been obvious to me to check this first, but for whatever reason, I neglected to test "Scenario 3" which applies to having a "BugcheckCode = 0" and a "PowerButtonTimestamp = 0" - if not, check the other scenarios if you are sure it is a Kernel-Power issue.

I had already tested the RAM, however, all tests came back just fine. It was working perfectly, so I ordered a brand new PSU. After I installed the new PSU, I could just tell something was different. It loaded up super fast with the SSD (mind you, I'm still running the last good image of the Windows 7 x64 Ultimate installation I made while writing this post). It actually takes the BIOS/POST longer to finish than it does Windows 7 to boot.

This whole time it was a bad PSU...I haven't had a single reboot or issue of any kind whatsoever in over four days. I Prime 95 tested it for like 26 hours on stock settings, and I still have everything set on stock settings. All I'm saying - test everything! Especially if you meet the requirements of "Scenario 3" on the url listed above...
Score
0
February 1, 2012 8:46:22 PM

Very very very informative thread. Thank you so much vestatio for coming back and posting your finds.

My girlfriend's computer is running into the same symptoms.

Gonna try swapping it with PSU and see what happens..
Not able to try the clone windows guide (damn I should've done that from the get go but this IS her 3rd SSD...) as we do not have any available HDDs lying around :kaola: 
Score
0
a b $ Windows 7
February 1, 2012 10:30:26 PM

This topic has been closed by Mousemonkey
Score
0
!