How can I enable hotplug for Marvel back e-SATA port in ASUS P8P67 LE

Hello all. I'm new to these forums, even though I've been reading Tom's Hardware articles for several years. I hope someone can help me with a little issue I'm having.

I just built a new PC with an ASUS P8P67 LE motherboard. Everything went fine, except that the "Optimal" BIOS setting is unstable and freezes my Win7 (I've found it actually overclocks the memory, so maybe that's the problem since I'm using regular cheap Corsair Value RAM, which I guess is not apt for overclocking), but using the "Normal" setting, everything seems to be fine, and I don't really intend on overclocking. I think it shouldn't be called "Optimal", since it's misleading (that term doesn't make me think it's about overclocking). Why not just call it "auto-overclock mode" or something like that?

Anyway, I'm straying from the topic. So, this board has two Marvell SATA ports, one of them is a regular SATA port and the other one is a back e-SATA port (colored in red). This particular variant ("LE") doesn't use have any J-Micron controller (which in other P8P67 boards is used for e-SATA).

My e-SATA port worked fine with the stock drivers that Windows 7 x64 installs automatically. With those regular drivers, the e-SATA port is actually treated as a hot plug port, which makes sense for an external port. When I connected an eSATA external hard disk case to that port, Windows detected it and it showed a "Safely remove hardware" icon in the tray. So that's perfectly fine.

But then I installed the "Marvell Magni driver" that came in the CD, the eSATA port stopped working altogether. No disks were recognized in that eSATA port. So I uninstalled that driver using Windows Control Panel / "Uninstall a program", and in the very same instant I finished uninstalling the driver, the external hard disk I already had plugged was immediately recognized again by Windows and my drive appeared.

But now I don't have the hotplug feature anymore. Now I don't get the "Safely remove hardware" icon when pluggin an eSATA device (only works for USB drives). And also, if I plug a eSATA hard drive during a Windows session, it's not recognized. I have to restart the system to have the disk recognized by the motherboard.

I should have never installed that Magni driver. But now, how do I get the hotplug feature back that I had with the stock Windows drivers? I have already uninstalled Marvell's driver and I can't hotplug, which I could do before installing it.

BTW, I've found that the drivers ASUS offers in its website for the P8P67 LE motherboard are actually OLDER than those in the CD. How come?

I know everybody always recommends not to use any driver CD and download from the hardware maker's website, but in this case, all drivers are older in the website than in the CD. WTF?!

Thanks for reading. I hope someone knows what's going on and can help me.

4 answers Last reply
More about enable hotplug marvel back sata port asus p8p67
  1. BTW, just in case someone thinks about this, I know I can enable hotplug for all SATA ports in the BIOS, but not for the one eSATA port :(

    In the BIOS there are options for all the Intel ports (all 4 SATA 3G ports and also the 2 SATA 6G ports, also by Intel), but there is no option for the single SATA port by Marvell and there isn't any option either for the the red colored Marvell eSATA port at the back.
  2. Nobody knows about this?
  3. Why is Tom's Hardware telling me from time to time that my question has been answered when it clearly wasn't?
Ask a new question

Read More

Asus Motherboards