12GB of RAM only allowing 8GB

Since I bought my computer in Q1 2010, it has had a issue with reporting RAM. I originally installed 6GB, and only 4GB of that was usable, according to the control panel, so I installed 12GB a few months later, and only 8GB of that 12GB is usable.

I have a i7 920, G.Skill 12GB @ 1600MHz (not running at that speed due to no overclocking) & GA-EX58-UD5 Gigabyte Motherboard with the F12 BIOS firmware running. I have 64-bit Win 7 Ultimate with all the new updates.

In the BIOs it reports only as 8GB
Control Panel reports 12.0 GB (8GB usable)
Task Manager reports that only 8GB is there.
Ran PRIME95 for 40 minutes on a torture test (blend) and didn't come back with any errors or warnings.
Gigabyte's EasyTune6 shows all RAM slots with the same data for reach slot#.

I've been trying to find a solution on and off the entire time - so, yes I've already looked at Remapping, my motherboard doesn't support it. Yes I've taken the RAM out and tested it one by one, it all appeared to work fine. Yes I've contacted Gigabyte, they've been no help.

Last night I ran MEMTEST86+ and it came back with this:


So would this mean that one of the memory sticks are defective, and is stopping the other stick in the same channel from working?
Would it help if I posted a picture of the BIOs in which reports the RAM settings - I haven't changed these but I hear that Gigabyte's mobos can automatically set values, which can cause problems.
http://i4memory.com/f54/asus-x58-6-12gb-memory-overclocking-detecting-less-memory-than-installed-19200/
1 answer Last reply
More about 12gb allowing
  1. Test each stick one at a time to find out which sticks are faulty. Posting a BIOS memory settings page picture shouldn't hurt, go for it.
Ask a new question

Read More

Memory Control Panel RAM