Wanting to upgrade graphics card

I currently have a NVIDIA GeForce 7100 and its sucks!
So, I want to upgrade to the ATI Radeon HD 5570.
My PSU gives me a terrible supply of 160W... :pfff:
But Im goin to upgrade that too.
Well the question is: I have a PCI-E X16 slot open, will it be compatible with the HD 5570?
1 answer Last reply
More about wanting upgrade graphics card
  1. Yes,PCI-E 2.0 is backward compatible with PCI-E 1.0,so 5570 should work fine on your board.
Ask a new question

Read More

Graphics Cards HD Graphics