Closed Solved

Yet another crossfire problem. 2x 5770s CCC10.10 no CFX option

Hello,
I just bought a second gfx card and i'm having some problems setting up CFX. Here are my specs:

PowerSupply: hec X-Power Pro 650W CF rdy.
http://www.newegg.com/Product/Product.aspx?Item=N82E16817339024

AMD Athalon II X4 635 2.9ghz
http://www.newegg.com/Product/Product.aspx?Item=N82E16819103702

ASRock 870 Extreme 3 CFX ready
http://www.newegg.com/Product/Product.aspx?Item=N82E16813157198

SAPPHIRE ATI HD5770 Juniper XT
http://www.newegg.com/Product/Product.aspx?Item=N82E16814102858&nm_mc=TEMC-RMA-Approvel&cm_mmc=TEMC-RMA-Approvel-_-Content-_-text-_-

ASUS CuCore Series ATI HD5770
http://www.newegg.com/Product/Product.aspx?Item=N82E16814121363

Windows 7 Home Edition 64-bit

I've followed the directions that came in the Sapphire user manual on setting up CFX, and I've followed the directions that were listed in my mobo user manual. I've followed various guides that i've found via google. Basically each time I've uninstalled and reinstalled CCC & the associated drivers. I've tried running the power cable from my PSU to both cards and they will only display on my monitors if the monitors are hooked into that gfx card(They both work but the Sapphire card is Fing LOUD!). PCI-E is enabled in bios. After doing all of this several times CCC 10.10 still does not show a CFX option under the graphics drop down menu.

If you need any other information let me know.

Thanks for reading,
Ren
20 answers Last reply Best Answer
More about crossfire problem 5770s ccc10 option
  1. I had a similar issue to this when I recently rebuilt my system.

    I'm not sure what the actual fix was, but after a full day of trying, Win7 took an update to my GPU and monitor. After that and a reboot I had Crossfire again.
  2. I just checked windows updates and oddly enough there was one for my gcard. It was listed as optional and once installed my display flickered a bit. I restarted but still no CFX option in CCC :(.
  3. Please don't take this the wrong way but I have to ask: Do you have the CF bridge mounted and pressed down firmly?

    If so and it's still not working, remove both cards, swap locations, make sure that both are seated firmly in the mobo, firmly attach the CF bridge,start your PC. Make sure CF is enabled in bios before entering windows. Then check CCC for CF Enable option.
  4. Haha, I wish that my problem were so simple Jimmyzline. I may switch the bridge with the other bridge when I swap the cards positions. I don't remember seeing a CF option in my bios. Also, the mobo user manual didn't mention any thing about it in bios.
  5. I do recall installing more than 1 GPU/monitor update from Windows. Force Windows to check for updates and see if there is another optional one available.
  6. Try thoroughly cleaning out the drivers (driver sweeper).

    Could also give older drivers a go (though 10.10 should be good I think).
  7. JimmyzLine: I switched cards around and changed the bridge out but all that did was make me reinstall the drivers. Still no CF option in CCC.

    Firebird: I forced a check the first time to find the inital update. I just checked again but there is nothing applicable to gpu/monitors.

    EXT64: I was trying to find driver cleaner pro( i think) but it said I had to pay. Then I stumbled upon driver sweeper and it didn't say it worked for windows 7 but i'll give it a shot.
  8. That's a bummer. I haven't tried either recently unfortunately, so I don't know. I am planning on trying them soon though, so hopefully one still works.
  9. Ext64: driver sweeper seemed to work fine for win7 64bit. However, the overall problem of still not seeing CF option in CCC still remains. Now actually my desktop flickers alittle bit :(.
  10. Does it flicker with only one card in? Also, are both cards "seen" in device manager when both are in? Try the other DVI port too, I've had better luck with the secondary port on the card.
  11. Unfortunatly, I had a similar problem with a couple 4850s a while back, turned out to be a bad card (even though the card showed up and worked) do you know anyone with another 5770?
  12. EXT64: I only see one card in device manager. I'll play around with the various outputs later tonight.

    Microterf: Unfortunately no, most of the ppl I know with them are 1hr+ away.
  13. Ok, just to confirm (I think you have already done this, but just to check):

    Try each card individually in the primary slot.

    Try hooking the monitor to each card when both cards are installed.

    Try swapping the position of the cards.

    Check for an updated Motherboard BIOS, and update if present.

    Try removing and reinstalling the cards, bridges, and cables to triple check everything is firmly seated.

    Update the Motherboard Chipset/peripherals Drivers.

    Might be a bad card, but if both work alone, which is it?
  14. I forgot to add that when my card messed up (still worked normally except wouldn't let me use crossfire, in GPUz it showed a weird number for the manufacturer, and frequencies..
  15. Good point, you can also check and see if GPU-Z can see both cards and what it reports.
  16. When I look at it with GPU-Z it only is showing the card in my primary PCI-E slot, even if i'm actually running power and my monitors through the secondary card. I'm not sure what numbers you were referring to for the manufacture or frequencies, but it all looks normal to me. Do you think this could be an issue with my mobo?


    EDIT: I just stumbled upon this... http://www.asrock.com/mb/vga.asp?Model=870%20Extreme3&c=CF Although it does not specifically say it supports the 5770 under windows 7, it does say that it supports the 5870 and the 4850 with crossfire. Would it be safe to assume that the 57xx series are included?
  17. Bump, Still no fix or reply from ASROCK or ATI forums. :(
  18. Best answer
    Quote:
    Don't...

    * Post in ALL CAPS or use excessive punctuation!!!
    * Share personal information, like your email address. Identify theft is real.
    * Bump posts, claim "first!"
    * Hijack a topic. Stick to the original conversation.
    * Ask for help pirating, cracking passwords, or bypassing copyright protection


    Source.
  19. Best answer selected by Renseru.
  20. This topic has been closed by Maziar
Ask a new question

Read More

Radeon Graphics Product