Sign in with
Sign up | Sign in
Your question

New build wont power up(need help asap)

Last response: in Systems
Share
January 14, 2011 1:56:44 PM

M4A87TD EVO
Gskill Ripjaws 1333
Ultra 550PSU
Sapphire HD5750
Sasmung 500gb HDD


I get a green LED on the motherboard, but when I hit the power button I get nothing, know fans or anything. I checked for shortages under the motherboard. Verified everything is connected properly. First time builder im at a complete loss :(  And yes the power button is connected to the mother board and the PSU is switched on =(

More about : build wont power asap

January 14, 2011 2:49:38 PM

I pulled the CPU out and noticed a bright spec of silver on an outside CPU pin.. Am I screwed? If it is thermal past and it got into the socket will i need a rpleacement CPU and mobo?..
January 14, 2011 3:03:09 PM

I dont see how it could have been thermal coumpund seeing as to how I didnt touch any until the CPU was in the socket
Related resources
January 14, 2011 3:32:09 PM

Ive tried starting with he basics, no ram, one stick of ram, no video card. Ive reseated the CPU and heatsink. I get absolutely nothing no fans or anything. Any help would be greatly appreciated. This isnt my computer so im very stressed out as it is my first build and not my own.
January 14, 2011 4:18:30 PM

Both of these pins are secure and connected and I have done everything suggested in that thread
January 14, 2011 4:28:32 PM

Sounds like your PSU, motherboard, or CPU was DOA--can you swap the PSU or CPU with one from another computer for testing purposes?
January 14, 2011 4:32:06 PM

I can swap PSU's but not at this moment, I have a semi off topic question aswell. When I swap PSU's if I get nothing. Should I try to RMA the motherboard and CPU? Will newegg replace CPU's if there is no visible damage such as bent pins? As I stated above I noticed a sligt silverish area on one of the outside CPU pins this was before I installed the CPU and applied thermal grease so im starting to think its the CPU or Mobo.

Also, if I cant use another PSU for testing purposes, will the paperclip thing work to test the PSU?
a b V Motherboard
January 14, 2011 4:33:38 PM

If you've gone through all the steps, then it's time to try a different PSU.

If you're within your RMA period, newegg will accept it with no hassle.
January 14, 2011 4:42:38 PM

Ok thank you all for the help.
January 14, 2011 6:57:53 PM

I cant get my hands on a compatible working PSU, should I try the paper clip jump start with the PSU connected to the case fans to see if I get anything?
a b V Motherboard
January 14, 2011 7:54:49 PM

That'll tell you if it has enough power to run a case fan. :) 

January 14, 2011 10:39:59 PM

Well I tried a different PSU, Absolutey nothing. I guess its time to RMA the Mobo? And in my third check of everything making sure everything was seated properly I somehow managed thumb contact on one of the CPU pins and there is a nice spec of what id assume is AS5.. Any suggestions on removing this? Also what are the chance of it being a bad CPU?
January 14, 2011 11:40:39 PM

If the spec that I saw on literally one of the CPU pins is the issue, would I atleast be getting fans or beeps?
January 15, 2011 4:57:29 PM

Solved...

The power switch and Reset switch in my Antec 300 case were wired wrong.. The reset switch was labeled power and the power switch labeled as reset. It never crossed my mind to check this seeing as I have very little experience, but before I decided to RMA the motherboard I said what the hell let me try to short the pins with a screwdriver and then bam it powered up! Noob mistake I guess?

Everything is recognized in the bios correctly and the CPU(Athlon ii X3) is at 33c. Is that a little too high for idle in bios?

Now just to get the software installed and hope I dont get any BSOD's ><. Thanks to toms for the help!
a b V Motherboard
January 15, 2011 5:38:16 PM

That temp is pretty good.

Thanks for the update.
!