New PCI NIC card, now computer won\'t power on.

I recently bought a Rosewill RC-404 gigabit network card, regular PCI, to throw in my old Pentium 4 machine that I'm using as a file server. However, when I install the card, I'm unable to power up the computer. The power supply LED blinks, and the power supply makes a clicking noise, but the fans don't even spin up.

I previously had a (working) 10/100 network card in the PCI slot that I'm trying to use, so I know the PCI slot functions properly. I was able to put the old card back in and the computer booted back up and the old network card worked fine again.

Now, I realize I bought a cheapo network card, and most would be quick to blame it and tell me to get a better card. However, I put the card in my AMD 1090T machine and it worked fine and provided a network connection without a problem, so it seems the card isn't defective.

The power consumption can't be significantly higher than the old NIC I'm replacing, so I doubt it's an issue of overloading the power supply. The computer has an old Intel Desktop Board with the 915G express chipset. There are two standard PCI slots, a single PCI Express x16 slot, and an x1 slot, and NONE of the other slots have anything in them. I'm using on-board graphics and since it's a server I didn't even bother with audio drivers.

I'm stumped. Anyone have any insight?
7 answers Last reply
More about card computer power
  1. Maybe, your PSU just went blink. Or maybe you can try to use the card without locking it into the PCI slot, by that I mean just push the card into the slot and don't screw it in place. Then try hitting the power switch, if it powers up, means the Cards support bracket is causing too much pressure on the Mobo when you tighten it down.
    Solution is simple either have some sort of an Insulator behind the Mobo between the Mounting plate and the mobo, or then just tighten the card into place enough so as to not have some component extension at the back of the Mobo touch the backplate and cause a short.
  2. That's what it seemed like to me, that there was a short somewhere, however I never fastened the card in with a screw. Typically when I put in new hardware I like to test it first before I go to the trouble of putting all screws in, replacing the side cover of the case, etc....

    Anyway, I had installed the previous PCI NIC card in the same slot the same way and there was no issue, so I'm hesitant to think it's an issue of the solder joints on the back of the motherboard coming in contact with the case and causing a short. Just for fun though I'll try putting something (non-conductive obviously) behind the mobo when I get home from work today.

    Surprisingly, Rosewill replied to my email inquriy in less than 45 minutes! I didn't expect that from a company that makes arguably "low end" products. Anyway, they recommended turning off legacy USB in the bios and then seeing if I can install the card and boot the PC. Not sure what that might do, but another thing to try after work today.

    Also, the PSU is still fine, along with the PCI slot. I put my old NIC back in the same slot and booted the machine and the network connection was fine through the old NIC. Tried the Rosewill again, computer wouldn't boot again.
  3. Try using the Styrofoam sheet that comes in the Mobo box, it is usually the same size and works very well as an insulator. I've used that sheet in maybe most cases that I have had doubts about shorting back contacts. Has always helped.
  4. Haha, this computer was originally a Sony pre-built from 2005... my freshman year college computer. No packaging hanging around for this motherboard! Good idea though, maybe I have the foam still from my 890FX AMD board somewhere.
  5. No No, the 890FX will have a sponge sort of sheet, not the Styrofoam one... :(
  6. Have you also tried it in another PCI slot? Could be some kind of irq mapping issue.
  7. The board only has two standard PCI slots, both provide the same result. Here's a page that has pics and some specs: http://www.ascendtech.us/intel-d915gro-d915pro-d915gvro-board_i_mbind915grodsmb.aspx
Ask a new question

Read More

Chipsets PCI Network Card Computer Motherboards