Sign in with
Sign up | Sign in
Your question

Keyboard/Mouse not working on login screen.

Last response: in Motherboards
Share
December 16, 2011 9:03:35 PM

So basically, I just installed my new ASRock Z68 Extreme3Gen3 mobo, and my new i5 2500k as an upgrade to my existing build, using same old hdd and everything.

Problem is, I can access the BIOS and everything just fine using my Mouse/Keyboard in the back USB slots only. Which I assumed was cause the BIOS wasnt updated yet/drivers not loading, idk. Something logical. So I go onto the login screen after I exit the BIOS menu, and as it says, 'Windows Is Starting' right before it pops up the password box for my profile, the keyboard and mouse stop functioning.

Anyone here seen this before/Have a fix?

If I'm leaving something out or you need more information please let me know.
December 16, 2011 9:18:37 PM

You did not say what Windows you have.
But you can try to play with the USB legacy emulation settings (maybe something with keyboard/mouse) in the BIOS. I've had a few problems with emulation enabled where XP would not be able to use the KB+mouse, but disabling it, would make win boot menu unusable (between BIOS loading HDD and windows taking control). BIOS navigation still worked, regardless of this option. but a USB-to-PS2 would not hurt to have nearby.
December 16, 2011 9:40:15 PM

mathew7 said:
You did not say what Windows you have.

My apologies, I'm currently using Windows 7 Professional, for what it's worth.

More or less the USB ports just stop working all together at the windows welcome screen after it finishes loading. This is a huge pain because I cant even log in to try and update the BIOS with the disk it came with and see if that would fix things.

I know there's an option to flash update the BIOS, but I have no idea how to do that.
Related resources
December 16, 2011 10:41:25 PM

Are you using the blue or black slots? The blue ones are USB3 and need an additional driver to work in Windows. The black ones are from the Z68, and windows should work out-of-the-box.
Did you try unplugging and replugging? If plugging in different slot, a small wait is required (20s?).
If all else fails, try with a PS2 keyboard adapter.

Update: I just had a new thought: since you're using the old HDD, I suppose you're still using the old windows install. It could be some conflict with the installed drivers from the old MB. Please tell me your old MB, maybe I could get new ideas. BTW, I'm going to sleep now, so I'll probably answer much later.
December 17, 2011 9:03:59 AM

Doh! Thanks very much for the usb 3.0 tip.. Of course, I had them plugged into the blue slots, I didn't even notice the black ones back there :/  From here I'll just update the BIOS and everything should be fine now. Thanks for your time. :) 

Update: So I installed the drivers that came with the disk for the mobo, and then continued to update them with no problems. But there are a couple issues that still worry me here:

1: The front USB ports still won't recognize anything plugged into them.

2: There's no sound being displayed from my HDTV lcd 1080p monitor via HDMI cable.
(fixed) An AMD ccc update hit me that finally recognized the audio when I started up a game.

3: My mouse lags? My mouse runs fine but will skip across the screen occasionally. It is a wireless mouse.
(fixed) Had dual channel memory running in single channel. ./facepalm.

And as for my previous motherboard, I was using a EVGA SLI 790i FTW Motherboard.
http://www.evga.com/articles/425.asp
December 17, 2011 2:47:08 PM

One more thing I don't fully understand, my windows 7 rating for my RAM used to be 6.4, now it's reading as 5.9? Do motherboards read memory differently than others?


I have noticed better performance since I fixed the memory to read as dual channel, but I still get some lag now and then.. really hoping I dont need to rma this board.
December 18, 2011 10:25:20 AM

For the front USB's you should check the MB manual and the case/or bay pin definitions. You may have them plugged incorrectly into the MB. Otherwise they should work, even if they support only USB1.1 signals (I had a "too old" case with such a problem).
December 18, 2011 10:41:23 AM

Alright, I'll look into that. The the only other thing I don't get is why my games will lag now, when they ran beyond smooth before the upgrade.

How can an upgrade make something run slower?
December 18, 2011 10:50:26 AM

So you mean stuttering, like breaking the normal flow. That could be caused by many things, even apps that are in background. Can you relate the HDD LED with the stuttering moments? In either case, you should check if the HDD(s) and CDROM(s) use DMA mode, not PIO. Especially if both motherboards used IDE emulation.
December 18, 2011 11:31:11 AM

How would I go about checking that?
March 9, 2012 3:22:04 AM

I'm having the same issue of my usb mouse and keyboard working under the Mobo's UEFI, but then stopping just as it hands off control to Windows (in this case, a clean install of Windows 7 Pro 64-bit). I have them plugged into a USB 3.0 right now due to a crazy custom case build.

I'm ordering a USB 2.0 internal to external adapter so hopefully that will fix the issue.

Disabling Legacy support kills them in both UEFI and Windows, so that makes it worse btw, and requires a CMOS reset.
March 16, 2012 2:17:23 AM

I'm sorry to see you're having the same issue I did, but contrary to your situation, my issue was fixed when I reinstalled windows. I was having conflicting driver issues due to my old mobo's data still being in there messing with things. :/ 

As for the USB issues, my old mobo did NOT need the usb cables plugged into it for them to work, this mobo needed them all plugged in, and I had them tied to the back of my case in the cable management where I didn't notice them til much later when I resolved that problem.
!