Sign in with
Sign up | Sign in
Your question
Closed

Raid 0 reporting as Disk0 in Windows 7

Last response: in Windows 7
Share
May 12, 2009 12:00:40 PM

Hi all,

I am posting this hoping that someone has a solution - if a solution is even needed. My motherboard is an Asus P6T Deluxe V2 and I have 2 WD Caviar Black 640GB drives in Raid 0. I also have 1 WD Caviar Black 1TB drive for data storage. I have the raid set through the intel hardware controller on the motherboard. The bios recognizes the raid array and Windows 7 sees the full amount of storage. I am not noticing any performance issues but that doesn't mean everything is actually working as well as it could be working.

When I look in Windows 7 device manager, the raid array only shows as Disk0 with a generic disk driver. If I use the WD utility to look at the drives it sees the 1TB drive with no problems but the array comes back showing as a bunch of funky ASCII characters. The Intel utility loads and shows an array but has no functionality.

I loaded the Intel Raid driver during the OS build but I don't think it is truly functioning - anyone have any helpful thoughts?

Thanks!
a b $ Windows 7
May 14, 2009 9:10:46 PM

Bullheaded67
Received my two WD 640 Blk drives last night, Installed Win 7 64 bit (may drop back to 32 bit). Set up the Raid0 array, booted to win 7 DVD and Win 7 loaded and is running.

I did run one of WD's HDD programs and it worked fine. Only difference in systems is you have a newer controller (10R I think) and mine is the 8R (Gigabyte P965-DQ6)

Try installing without the Intel Raid Driver, I believe Win 7 already has a driver for your Raid.

Best solution

May 14, 2009 9:41:16 PM
Share

If you installed Windows on the RAID then it is working. If it was not working you would not see the drive in windows.

Under disk drives in the device manager the RAID 0 named whatever(mine Volume 0) uses generic driver because all drivers for disk drives are generic, all CD/DVD driver are generic, all CPU drivers are generic.

The driver attached to the RAID that is not generic is the Storage controller driver. All disk drive drivers no matter what controller they are on are generic.

If the controller is not working then you would not have the driver under Windows.

The controller is the driver you need to worry about.

Think of it as this: USB hubs are listed as "USB root hub"but the controller is listed as Intel(R) ICH9 Family USB Universal Host Controller - 2934 on the Rampage Forumla. So the "USB Root Hub" uses a generic driver built into Windows. The controller is not generic.

Hope that its clear as mud.....

1Haplo
May 15, 2009 1:30:07 PM

Nope that clears things up thanks! I was just curious since te 1TB WD drive is actually labeled correctly as such in Device Manager vs the generic label for the striped drives. Thanks all!
!