Sign in with
Sign up | Sign in
Your question

ASRock P67 Extreme 4 - UEFI Bios not displaying correctly

Last response: in Systems
Share
January 17, 2011 4:45:54 AM

System:
Intel i5-2500k
Asrock P67 Extreme 4 mobo
4gb Corsair XMS3 1600mhz ddr3 (2x2gb)
Corsair TX650w PSU
Samsung Spinpoint 1tb
Sapphire Radeon HD6850 (non-overclocked version)
Cooler Master Hyper 212+

So perhaps more information then needed, but I've built the above mentioned rig and it has been running basically flawlessly and I've been again really impressed with the Asrock board.

So I was messing around and I tried to bump my XMS3's up to 1866mhz with the same timings, no apparent problems, great. I used the autooverclocking to set the CPU at 4.2ghz for turbo just for the extra juice without trying to push it at all and otherwise the bios was still default, no voltage changes made what so ever.

The computer boots, no probs, I start messing around with it on a Samsung 42" plasma (720p) and then I have issues in Starcraft 2 with the mouse (Which I shortly realized after was an issue with settings in Windows(text enlargement for visibility). But regardless, I shut down everything and reboot to see if the problem has gone in Starcraft 2, everythings apparently fine.

Next I decide not to push the ram as I'd rather have longevity and stability then 'screaming' performance on this rig, so I reboot, go to the bios and the display of it is almost entirely blacked out except for the Buttons at top. The mouse moves and as it moves exposes portions of the Bios and I'm initially thinking this is some sort of refresh rate or display issue related to the TV. So I try plugging it into my 19" 1080p Samsung LCD that is much better for refresh rate etc as you'd imagine and it pulls the same crap.

So, the computer is running perfectly fine, but the BIOS is 100% unuseable. I clear'd Cmos to make sure everything was running stock again and no problems except for with viewing the UEFI. I'm at my wits end on figuring out wtf is going on here.


January 17, 2011 5:55:43 PM

Bump, any ideas? Help?
m
0
l
April 4, 2011 4:28:10 AM

I had a similar problem (actually just a blank screen instead of the bios, and it wouldn't show post messages, but the OS came up fine) when I was using a DVI-to-HDMI adapter and HDMI cable to connect to an Insignia HDTV (on a GeForce 9800GTX.) I tried using a DVI-to-VGA adapter to the TV's VGA input instead, and it seems to be working now. Good luck!
m
0
l
Related resources
May 7, 2011 3:44:51 AM

I am having the same issue, I had it plugged into my Sony Bravia, and figured it was a display ratio issue for the large LCD TV so I plugged it into my CRT I had in the garage and it still displays the same, all I can see is the upper left corner of the bios.

Anyone help?
m
0
l
May 14, 2011 5:38:45 AM

I just upgraded to 1.70 BIOS and seem to be having the same problem. When press F2 to go into BIOS, screen is black. PC can still boot to Windows CD but not HDD since I need to get into BIOS first to switch from the default IDE to AHCI....but I can't because the UEFI doesnt appear. This never was a problem on version 1.60 for me. I tried using the DVI cord instead of HDMI but it didnt seem to fix it. Uggh.
m
0
l
May 14, 2011 4:35:32 PM

What video card are you running? Better yet, what video card is EVERYONE with this issue running?

I currently have the AMD radeon 5570.

I have an older nVidia GTX that I am thinking about sticking in just to see if it changes anything.

Ill let you know today.
m
0
l
May 22, 2011 7:21:53 AM

Same issue here. Asus P8P67 PRO + XFX Radeon 6850 to 720p projector. Garbage displayed instead of American Megatrends screen. Sometimes logo displayed with no POST text. Can't load UEFI settings screen. Must be that new video mode doesn't work with 720p/1080 displays?

EDIT: Sorry _similar_ issue: Asus not Asrock. But I think the problem is actually the Radeon card and UEFI together.
m
0
l
!